Jump to content
Калькуляторы

Catalyst 4506 SUP-V10GE лезут ошибки

Потстоянно лезут ошибки вида:

.May 24 14:29:54.642 GST: %C4K_COMMONHWACLMAN-4-OUTOFLABELS: No more free labels available for path ((out:null, 1455))

.May 24 14:29:54.834 GST: %C4K_COMMONHWACLMAN-4-OUTOFLABELS: No more free labels available for path ((out:null, 1087))

.May 24 14:29:55.015 GST: %C4K_COMMONHWACLMAN-4-OUTOFLABELS: No more free labels available for path ((out:null, 2165))

.May 24 14:29:55.119 GST: %C4K_COMMONHWACLMAN-4-OUTOFLABELS: No more free labels available for path ((in :null, 1752))

.May 24 14:29:55.291 GST: %C4K_COMMONHWACLMAN-4-OUTOFLABELS: No more free labels available for path ((out:null, 1752))

Соответственно Vlan-ы, на которые ругается не режутся QoS-ом.

 

Перебрал все мануалы на cisco.com, в поиске и в гугле по ошибке нашел только то, что:

 

Error Message C4K_COMMONHWACLMAN-4-OUTOFLABELS: No more free labels available for

path ([object-info])

 

Explanation A new label could not be assigned for an ACL that the user is trying to program. There are too many labels being used. As a result, software will apply security ACLs, and will not apply QoS features. It's possible too many distinct features using ACLs have been configured, or too many per-port per-VLAN features using ACLs have been configured. The hardware will forward the packets to the CPU for ACL processing.

 

Recommended Action Detaching and reattaching ACLs or policies may help in some cases.

Что за labels, где смотреть расходование этого ресурса и как оптимизировать этот самый расход никто не знает...

 

Вот что говорит show platform hardware acl statistics utilization brief

                           Entries/Total(%)  Masks/Total(%)
                           -----------------  ---------------
Input  Acl(PortAndVlan)     0 / 4848 (  0)     0 / 4848 (  0)
Input  Acl(PortOrVlan)   1416 / 11344 ( 12)  1416 / 11344 ( 12)
Input  Qos(PortAndVlan)     0 /  320 (  0)     0 /  320 (  0)
Input  Qos(PortOrVlan)   7110 / 15904 ( 44)  7110 / 15904 ( 44)
Output Acl(PortAndVlan)     0 / 4848 (  0)     0 / 4848 (  0)
Output Acl(PortOrVlan)      0 / 11344 (  0)     0 / 11344 (  0)
Output Qos(PortAndVlan)     0 /  320 (  0)     0 /  320 (  0)
Output Qos(PortOrVlan)   7116 / 15904 ( 44)  7116 / 15904 ( 44)

L4Ops: used 2 out of 128

 

и show platform hardware qos policers utilization

    Software Usage Statistics

                                  Used (%)        Free (%)      Total
                               --------------   --------------   ------
Input Policers                   1022 ( 12.4)   7170   ( 87.5)     8192
Output Policers                  2036 ( 24.8)   6156   ( 75.1)     8192
Control Plane Policers              0 (  0.0)   1024   (100.0)     1024
Flow Policers                       1 (  0.1)   511    ( 99.8)      512

 

Реально, облазил все что мог... даже весь релиз хистори пересмотрел на ios-ы :( Неужели примерно 1300 вланов, это все, что способна заQoSить 45-ка?

 

ЗЫ: Конфиги QoS-ов вида:

 

access-list 190 deny   ip xx.xxx.216.0 0.0.7.255 xx.xxx.216.0 0.0.7.255
access-list 190 deny   ip xx.xxx.216.0 0.0.7.255 yy.yyy.144.0 0.0.15.255
access-list 190 deny   ip yy.yyy.144.0 0.0.15.255 xx.xxx.216.0 0.0.7.255
access-list 190 deny   ip 172.16.0.0 0.15.255.255 xx.xxx.216.0 0.0.7.255
access-list 190 deny   ip xx.xxx.216.0 0.0.7.255 172.16.0.0 0.15.255.255
access-list 190 permit ip any any
access-list 191 permit ip xx.xxx.216.0 0.0.7.255 xx.xxx.216.0 0.0.7.255
access-list 191 permit ip xx.xxx.216.0 0.0.7.255 yy.yyy.144.0 0.0.15.255
access-list 191 permit ip yy.yyy.144.0 0.0.15.255 xx.xxx.216.0 0.0.7.255
access-list 191 permit ip 172.16.0.0 0.15.255.255 xx.xxx.216.0 0.0.7.255
access-list 191 permit ip xx.xxx.216.0 0.0.7.255 172.16.0.0 0.15.255.255
access-list 191 deny   ip any any

class-map match-all limit-ext
match access-group 190
class-map match-all limit-int
match access-group 191

policy-map 500k-out
class limit-ext
    police 500 kbps 62.5 kbyte conform-action transmit exceed-action drop 

policy-map 500k-in
class limit-ext
    police 500 kbps 62.5 kbyte conform-action transmit exceed-action drop 
class limit-int
    police 1000 kbps 125 kbyte conform-action transmit exceed-action drop 

interface Vlan xxx
description 1274432807
ip unnumbered GigabitEthernet1/4
ip helper-address xx.xxx.216.2
no ip unreachables
service-policy input 500k-out
service-policy output 500k-in

Share this post


Link to post
Share on other sites

Ну в общем-то 44% - и при изменении надо перекомпилировать все. Соответственно, на перекомпиляцию у него, судя по всему, не хватает.

Пользуйте 6500/суп32 и UBRL.

Share this post


Link to post
Share on other sites
Ну в общем-то 44% - и при изменении надо перекомпилировать все. Соответственно, на перекомпиляцию у него, судя по всему, не хватает.

Пользуйте 6500/суп32 и UBRL.

Нет, перекомпилять оно начинает если балансировку по TCAM'у меняешь...

Насчет 6500/суп32 оригинальный совет...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this