Jump to content
Калькуляторы

BGP, работа над ошибками.

Добрый день.

Случилась такая ситуация, приобрели AS, приобрели блок адресов /23, подключили аплинк, настроили BGP (quaga), анонс всего 1, сеть /23.

В базе ripe прописали inetnum, указали адреса как assigned, прописали route указали нашу AS.

Всё это произошло более 2х суток назад.

Проблема в том что многие интернет ресурсы (тот же яндекс) пингуются из нашей сети с существенными задержками (40+).

Однако, на BGP роутере 2 интерфейса, один с адресом аплинка, другой с нашим. Так вот, если делать тесты с адреса аплинка то всё хорошо, если с нашим, то всё плохо.

Это я так понимаю логично, ибо запросы с их адреса маршрутизируются "по правилам их AS".

Если пустить трейсы на эти адреса (проверял через lg.retn.ru) то они приходят по разным путям. Вышестоящий говорит что косяк у нас... Я не пойму никак где...

Но неужели обновления записей(фильтров / маршрутов) идёт более 2х суток ?

Как определить в чём мы напортачили, или если напортачили не мы что я могу предъявить вышестоящему ?

Их тех.поддержка на все мои вопросы отвечает только "косяк у вас, ищите, исправляйте"...

Буду благодарен за помощь.

Share this post


Link to post
Share on other sites

Либо кто-то не обновил фильтры (есть такие, кто делает это вручную).

Так же интересно, добавил ли вас ваш аплинк в members в описании своей AS.

Правиьный ли route object создали в RIPE и анонсите ли именно этот блок, который описан в RIPE.

 

Вариантов масса.

Share this post


Link to post
Share on other sites

Если вы имеете ввиду aut-num, то да, мы прописаны.

Правиьный ли route object создали в RIPE и анонсите ли именно этот блок, который описан в RIPE.
По-моему там довольно сложно напортачить.

Сеть анонсируем точно такую же как и прописали в route object.

Share this post


Link to post
Share on other sites

у нас прошло как-то более 3 суток пока все проанонсировалось верно

Share this post


Link to post
Share on other sites

Вас мегафон никуда не проанонсировал кроме телии и прямых пиров, хотя по записям в райпе все должно быть ок.

 

 

Комьюнити никакие не ставили? LG у мегафона не работает.

Share this post


Link to post
Share on other sites

Комьюнити не ставили, к тому же пока только одна нога.

Про лукинг гласс в курсе...

Share this post


Link to post
Share on other sites

Гы. Сразу анонсы не посмотрел.

У вас два /24 специфика, а в райпе в route только агрегат /23.

Вот его только телия и принимает от мегафона.

Share this post


Link to post
Share on other sites

Проверю...

Но точно анонсируем /23...

Share this post


Link to post
Share on other sites

Всё. Косячина была действительно у нас.

Дегтярев Илья, спасибо за помощь =)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this