Jump to content
Калькуляторы

dwl 7100 flash error

народ хелп!!!!!начинаю прошивать dwl7100 выдает вот это

jtag> flashmem 0x1fc00000 /root/jtag_bin/bootmonitor

program blocks:

Chip: AMD Flash

Manufacturer: AMD

Chip: Unknown (ID 0x007e)

Protected: 0000

flash_unlock_block 0x1FC00000 IGNORE

block 0 unlocked

flash_erase_block 0x1FC00000

........................flash_erase_block 0x1FC00000 DONE

erasing block 0 to program 8192 bytes, status: 0

................................................................................

................................................................................

.

.......................................

flash error

 

 

пробовал и бут и от 2100 все одно и тоже..может критина длина кабеля жтага???у мну всего 8 см..спаяна на резюках...доделываю на микрухе..но не суть....дело...может бут мертвый????.и что за флеш еррор???

Share this post


Link to post
Share on other sites

.может критина длина кабеля жтага???

 

да и очень критична.

Share this post


Link to post
Share on other sites
.может критина длина кабеля жтага???

 

да и очень критична.

насколько очень???сегодня обрезал до 5 см...чот картина не изменилась((((

Share this post


Link to post
Share on other sites

если мамка не АТХ то надо учитывать и длинну шлейфа

был такой косяк, пока не подрезал провода, чтоб только в разъем втыкались, если флешка подбитая, она обычно ругается в процессе

Share this post


Link to post
Share on other sites
если мамка не АТХ то надо учитывать и длинну шлейфа

был такой косяк, пока не подрезал провода, чтоб только в разъем втыкались, если флешка подбитая, она обычно ругается в процессе

мамка АТХ, флеша вроде норм..потому как пробовал на двух точках..выдает одно и тоже...начинаю париться......((((

Share this post


Link to post
Share on other sites
значит либо провод, либо ошибка в схеме

сегодня собрал провод на микросхеме....пробовал и так и эдак....все идет нормально..все определяет как нужно..но как дело доходит до заливки бута упирается в одну и туже ошибку... после 0 блока пишет флэш эрор.....поменял уже две материнки..думал бич в них....что еще можете посоветовать..может всеже что то делаю не так...????есть у когонить пошаговая схема прошивки??

Share this post


Link to post
Share on other sites

ну что то все заглохло...с места ничего не сдвигается...я уже три точки разобрал..с рабочих сливается безпроблем..а потом в этуже рабочую пробую залить то что слил..выдает флэш эрор..и посленедолгих манипуляций точка становится такой же не рабочей..всмысле лампочки на ней все гаснут..можт я убил флешку??хотя когда сливал все работало..

Share this post


Link to post
Share on other sites

Надо заливать командой flashmem 0x3fc00000 /root/jtag_bin/bootmonitor

 

 

cable parallel 0x378 WIGGLER

detect

include atheros/ar2312/ar2312

poke 0x58400000 0x100e3ce1

detectflash 0x3fc00000

readmem 0x3fc00000 0x400000 boot.bin

Share this post


Link to post
Share on other sites

readmem это я так понимаю команда для слития бута с точки?ну собственно говоря точно так я и пытаюсь но каменный цветочек у мну не выходит....(((мож с настройками порта что нетак..в биосе..хотя я перепробовал всевозможные варианты

Share this post


Link to post
Share on other sites

Та же хрень с ошибкой флеша...

решил следующим способом:

1. провожу инициализацию по 0х3fc00000 .. пытаюсь прошить - ошибка

2. провожу повторную инициализацию по адресу 0x1fc00000 - но не шью...

3. еще раз провожу инициализацию по 0х3fc00000 ... и вуаля - все пишет ...

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this