Jump to content
Калькуляторы

OSPF в одной зоне

neto.jpg

 

Здравствуйте, стоит задача запуска второго NAS PPPOE, немного погуглив понял, что без динамической маршрутизации не обойтись, в качестве протокола решил выбрать OSPF.

Начать решил с пару машин, дабы получится на 2х и на остальных получется, а если точнее задача стоит при установке pppoe ng0 (10.100.0.24/32) на NAS1 сообщить Web серверу, что 10.100.0.24/32 находится за шлюзом NAS1 (10.99.0.110)

Промучевшись выходные понял делаю что то не так, укажите пожалусто что делаю не так...

 

NAS1

#cat cat /usr/local/etc/zebra/zebra.conf
!
hostname nas1
password zebrahomenadym
enable password zebrahomenadym
!
interface lo
!
! Static default route sample.
ip route 0.0.0.0/0 10.99.0.1
!
log file /var/log/zebra.log

 

# cat /usr/local/etc/zebra/ospfd.conf
!
hostname nas1
password zebrahomenadym
enable password zebrahomenadym
!
router ospf
network 10.99.0.0/24 area 0
!
log file /var/log/ospfd.log

 

 

 

web

#cat cat /usr/local/etc/zebra/zebra.conf
!
hostname file
password zebrahomenadym
enable password zebrahomenadym
!
interface lo
!
! Static default route sample.
ip route 0.0.0.0/0 10.99.0.1
!
!log file zebra.log

 

# cat /usr/local/etc/zebra/ospfd.conf
!
hostname file
password zebrahomenadym
enable password zebrahomenadym
!
router ospf
ospf router-id 10.99.0.80
network 10.99.0.0/24 area 0
!
!log stdout

 

 

передать web серверу что 10.100.0.24 находится за 10.99.0.110 не получается :(

Edited by Dushes

Share this post


Link to post
Share on other sites
redistribute connected

пробывал не помогло

 

 

 

 

network 10.99.0.0/24 area 0

 

правильно ли я понял это мы указываем в какой сети анонсировать OSPF или всё же здесь нужно указать все сети возможные, в данном случае тунели которые устанавливаются ?

Share this post


Link to post
Share on other sites

[root@vpn0 ~]# cat /etc/quagga/ospfd.conf
! -*- ospf -*-
!
! OSPFd sample configuration file
!
!
hostname vpn0.lds.net.ua
password **********
enable password ***********
!
interface eth0
ip ospf priority 0
!
router ospf
  ospf router-id 10.0.0.13

  network 10.0.0.0/24 area 0

  area 0 range 10.0.0.0/24

  redistribute connected
  redistribute static
!
!log file /var/log/quagga/ospfd.log

 

ну и на роутере поднят ospf в тойже зоне... все работает....

Share this post


Link to post
Share on other sites

Как вам уже написали не хватает на nas1 redistribute connected. Если при его добавлении ничего не меняется - смотрите файрволы и т.п. Оспф-ы должны для начала друг друга "увидеть". Проверяйте например через show ip ospf neighbor или включайте дебаг.

Share this post


Link to post
Share on other sites
network 10.99.0.0/24 area 0

 

правильно ли я понял это мы указываем в какой сети анонсировать OSPF или всё же здесь нужно указать все сети возможные, в данном случае тунели которые устанавливаются ?

Правильно понял, надо указывать только сеть 10.99.0.0/24.

1. Добавить на насах redistribute connected

2. Проверить резание мультикаста 224.0.0.5 и 224.0.0.6 в ДМЗ (может свич режет?)

Edited by Alexandr Ovcharenko

Share this post


Link to post
Share on other sites

Правильно ли я понял на всех остальных машинах нужно настроить ospfd.conf так :

 

hostname file
password zebrahomenadym
enable password zebrahomenadym
!
interface eth0
!
router ospf
ospf router-id 10.99.0.80
network 10.99.0.0/24 area 0
!
!log stdout

 

1) при этой конфигурации сервер не будет в сеть ничего транслировать только принимать маршруты ?

2) на что указывает ip ospf priority 0 в конфигурации nas ? (обязательна ли для остальных серверов)

3) на что указывает area 0 range 10.99.0.0/24 в конфигурации nas ? (обязательна ли для остальных серверов)

4) interface eth0 -- тем самым мы указываем интерфейс на котором транслировать и принимать мультикаст OSPF ?

 

 

Share this post


Link to post
Share on other sites

1) да

2) для точного указания основного Full/DR и бекапного Full/Backup роутеров, обычно они выбираются автоматом, Full/DR - в основном у кого аптайм больше. Вам можно не указывать

3) суммирование маршрутов, вам можно не указывать нигде

4) да

 

Share this post


Link to post
Share on other sites

Спасибо большое всё вроде получилось ...

 

а можно как нить запретить отправлять определенные маршруты ?

Share this post


Link to post
Share on other sites

Можно, читайте про route-map.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this