Jump to content
Калькуляторы

A STA is rejected by 802.1x daemon на rtl8186 железках

замучался уже.

ткните пожалуйста припожалуйста носом почему оно так работает.

прошивка wive 0.5.8.

пробовал раздобытые модули auth и iwcontrol от wive-ng 0.2.18 и родные от g700ap.

запускаю их после ip link set wlan0 down и соотв. перед ip link set wlan0 up:

 

/mnt/mmc/system/auth wlan0 br0 auth /etc/network/wifi/wpa.conf

/mnt/mmc/system/iwcontrol wlan0

 

основные настройки

wep:

 

# 0 - disabled; 1 - WEP64; 5 - WEP128; 2 - WPA-PSK/WPA2-PSK

iwpriv wlan0 set_mib encmode=2

 

wpa.conf:

 

# 2 tkip

# 4 aes

# 6 tkip+aes

encryption = 2

ssid = "Spice-AP w"

enable1x = 0

enableMacAuth = 0

supportNonWpaClient = 0

wepKey = 0

wepGroupKey = ""

authentication = 2

unicastCipher = 2

#1 - TKIP, 2 - AES

wpa2UnicastCipher = 2

enablePreAuth = 0

usePassphrase = 1

psk = "qwertyui"

groupRekeyTime = 86400

rsPort = 1812

rsIP = 192.168.1.1

rsPassword = ""

rsMaxReq = 3

rsAWhile = 5

accountRsEnabled = 0

accountRsPort = 1813

accountRsIP = 0.0.0.0

accountRsPassword = ""

accountRsUpdateEnabled = 0

accountRsUpdateTime = 60

accountRsMaxReq = 3

accountRsAWhile = 5

 

пробовал уже и psk и tkip и оба сразу.

не подсоединяется ноут и всё тут.

процессы в памяти висят:

 

на wive-ng нормально подсоединялся.

 

может дело в бридже? ну например когда wlan0 лежит запускается auth а br0 наверняка изменён (наверное там нет в нём wlan0) ?

и остальные бредовые идеи кончились.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this