Jump to content
Калькуляторы

тормозит multilink

Поставил Cisco, до неё 2 vpn тунеля. Хочется насроить multilink на эти ВПН.

Все настроил, поднимается multilink, а нифига не работает он.

т.е. вместо 2х ppp появляется 1 ppp, т.е. linux и правда думает что есть мультилинк, но скорость скачки я получаю примерно 200кбайт/сек, и последующим падением в течении 10 сек до 30-70 кбайт/сек.

 

Отключаю мультилинк в конфиге Линукса, все бегает пучком. свои положенные 200кбайт/сек при скачке отдаёт С КАЖДОГО ИНТЕРФЕЙСА.

 

В чем фишка, не пойму.

 

cisco

 

Router#sh run

Building configuration...

 

Current configuration : 1418 bytes

!

version 12.3

no service timestamps debug uptime

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable password 7 11081F0D111812

!

no aaa new-model

ip subnet-zero

!

!

ip cef

!

ip audit po max-events 100

vpdn enable

!

vpdn-group 1

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

!

multilink virtual-template 1

!

!

!

!

!

!

!

!

!

!

!

!

username admin password 7 060709294A4410

!

!

!

!

!

!

interface Multilink1

no ip address

ppp multilink

ppp multilink group 1

!

interface Ethernet0/0

ip address x.y.9.99 255.255.255.248 secondary

ip address x.y.9.100 255.255.255.248 secondary

ip address x.y.9.98 255.255.255.248

ip nat outside

full-duplex

no cdp enable

!

interface Ethernet1/0

no ip address

shutdown

full-duplex

!

interface Virtual-Template1

mtu 1372

ip address 192.168.10.1 255.255.255.0

ip nat inside

peer default ip address pool vpnpool

ppp authentication ms-chap-v2 chap

ppp multilink

bridge-group 1

!

ip local pool vpnpool 192.168.10.2 192.168.10.254

ip nat inside source list 10 interface Ethernet0/0 overload

no ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 x.y.9.97

!

!

access-list 10 permit 192.168.10.0 0.0.0.255

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login local

transport input all

!

!

end

 

Конфиги Linux Debian

 

/etc/ppp/peer/vpn1

pty "pptp x.y.9.98 --nolaunchpppd"

user admin

password "xxx"

nodeflate

nobsdcomp

noauth

mtu 1372

defaultroute

multilink

debug

unit 10

 

/etc/ppp/peer/vpn2

pty "pptp x.y.9.99 --nolaunchpppd"

user admin

password "xxx"

nodeflate

nobsdcomp

noauth

mtu 1372

defaultroute

multilink

debug

 

И где можно посмотреть логи pppd?

 

Share this post


Link to post
Share on other sites

:)

были вроде как и более интересные идеи агрегировать каналы

в рфц к мультилинку написано что он не рекомендуется для быстрых каналов..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this