Jump to content
Калькуляторы

Cisco+linux через vpn

Добрый день!

 

Помогите разобраться.

Система такая:

на Cisco 3620 поднят VPN сервер с поддержкой мультилинка, а к нему подключается linux pptp клиент так же мультилинком.

Смысл мультилинка - для увеличения скорости суммарной. Каждый линк бегает по своему adsl модему.

 

Подключение происходит нормально, пинги бегают замечательно, а вот http трафик например бегает со скоростью от 8 до 128кбит/сек в зависимости от mtu. при mtu 700 скорость порядка 128, при 1300 не больше 1-2. В тоже самое время пинги не глохгут. Наблюдаю потери порядка 2% обусловненные adsl каналом.

 

Виндовый клиент так же цепляется без проблем. Ситуация такая же.

До vpn шлюза 192.168.10.1 пинги бегают с длинной более 5000, а вот например до mail.ru более 1372 не удалось протолкнуть.

 

На клиенте mtu меняю одновременно со сменой на Cisco, ну и естественно реконект.

Из наблюдений: без мультилинка така же фигня. И без НАТ-а тоже (реальный ИП отдавал клиенту).

Secondary ip на eth 0/0 для подключения второго vpn.

 

Даже не знаю что и делать.....

 

Конфиг:

Router#sh run

Building configuration...

 

Current configuration : 1418 bytes

!

version 12.3

no service timestamps debug uptime

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable password xxxxx

!

no aaa new-model

ip subnet-zero

!

!

ip cef

!

ip audit po max-events 100

vpdn enable

!

vpdn-group 1

! Default L2TP VPDN group

! Default PPTP VPDN group

accept-dialin

protocol any

virtual-template 1

!

!

!

!

!

!

!

!

!

!

!

!

!

username admin password xxxxxxxxxxxxxxxxxxxxx

!

!

!

!

!

!

interface Ethernet0/0

ip address x.y.9.99 255.255.255.248 secondary

ip address x.y.9.98 255.255.255.248

ip nat outside

full-duplex

no cdp enable

!

interface Ethernet1/0

no ip address

shutdown

full-duplex

!

interface Virtual-Template1

mtu 1300

ip address 192.168.10.1 255.255.255.0

ip nat inside

ip policy route-map clear-df

peer default ip address pool vpnpool

ppp authentication ms-chap-v2 chap

ppp ipcp dns x.y.a.b

ppp multilink

bridge-group 1

!

ip local pool vpnpool 192.168.10.2 192.168.10.254

ip nat inside source list 10 interface Ethernet0/0 overload

no ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 x.y.9.97

!

!

access-list 10 permit 192.168.10.0 0.0.0.255

access-list 150 permit tcp any any

!

route-map clear-df permit 20

match ip address 150

set ip df 0

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login local

transport input all

!

!

end

 

Конфиги linux

 

pty "pptp x.y.9.98 --nolaunchpppd"

user xx

password "yy"

nodeflate

nobsdcomp

noauth

mtu 1300

defaultroute

multilink

 

и

 

pty "pptp x.y.9.99 --nolaunchpppd"

user xx

password "yy"

nodeflate

nobsdcomp

noauth

mtu 1300

defaultroute

multilink

 

Share this post


Link to post
Share on other sites

Разобрались в чем проблема.

С какого то перепугу cisco провайдера установила 10 half-duplex, когда была на автомате, а на моем интерфейсе 10 full-duplex принудительно стоял.

Share this post


Link to post
Share on other sites

Добрый день. Подскажите возможно ли посредством мультилинкового VPN решить следующую задачу:

имеетсся инетернет дома (безлимитный достаточно быстрый с реальным IP), есть необходимость сделать интернет на удаленном объекте - но там только gprs - есть возможность поставить там несколько модемов. Задача суммировать скорость не только при наличии нескольких подключений, но и для одного подключения - например чтобы можно было использовать удаленную работу в рамках терминальной сессии, передавать файлы.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this