Jump to content
Калькуляторы

Cisco NX-OS проброс relay

Господа цисководы... ударился больно лбом об NX-OS 9x. на cisco nexus n3k-3132Q-40GE
Проблема в перебросе relay и opt.82

 

Изначально был следующий конфиг:

 

ip dhcp snooping
ip dhcp snooping information option
service dhcp
ip dhcp relay
ip dhcp relay information option
ip dhcp relay information option trust
ipv6 dhcp relay

 

interface Vlan2500
  ip address 10.2.0.33/32 
  ip dhcp relay address 1.2.3.4 

 

interface Ethernet1/32
  ip dhcp snooping trust
ip dhcp snooping vlan 2500

 

Запрос приходит с 10.2.0.33 - Все работает. Но в этом случае под каждый влан пришлось бы заводить в билингие свой NAS
Задача - чтобы релей отправлял запрс на биллинг с единого IP

 

Например: 
interface loopback0
  ip address 100.64.201.2/32

 

===

 

Если на добавить на интерфейс влана 
ip dhcp relay source-interface loopback 0
то релей вообще перестает слать запросы

===
Так же был реализован следующий вариант:

interface loopback0
  ip address 100.64.201.2/32
  ip address 10.2.0.33/32 secondary

interface Vlan2500
  no shutdown
  medium p2p
  no ip redirects
  ip unnumbered loopback0
  ip proxy-arp
  ip dhcp relay address 1.2.3.4 

ip route 10.2.0.32/27 Vlan2500

релей шлет запрос с нужного нам адреса, но пользователь айпи не получает


подскажите в какую сторону еще копать... а то уже чувствую себя деревянным по пояс...

Share this post


Link to post
Share on other sites

Добрый день.

Удалось понять в чем проблема?

Сейчас на N3K-C3064PQ-10GE абсолютно такая проблема

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now