Jump to content
Калькуляторы

[РЕШЕНО] SNR-S2960-24G ... странное Trun'cовый порт пропускает не все VLAN

Ставим на дома свичи доступа разных вендоров и масти.

Стараемся не делать гирлянду, но бывает 2 свича в цепочке.

Простейшая схема влан на свич + изоляция портов + аплинки в транке и "трасте" ).

Схема, проверенная многими годами и очень удобная с точки зрения автоматизации конфигурирования и замены этих свичей рядовыми технич. сотрудниками.

 

И вот тут я с одним новым домом потратил кучу времени, какие только версии не отработал, чего я только не делал )))), мозг взлетел под 100% CPU.

Не работает клиент во 2 свиче в цепочке - хоть убейся.

Пока я уже тупо не прописал явно влан на 1 свиче в цепочке (просто глобально одна команда

vlan 3413

. И всё. Т.е. транковый режим на аплинк портах я оставил и ничего не прописывал больше.

И всё сразу взлетело.

Таким образом промежуточный свич (тоже SNR-S2960-24G) не пропускал VLAN. Причем весьма конкретный (3413), а другие пропускал (ибо схема типовая и работает давно во многих других домах) !

 

Никто не сталкивался с такой бородой?

(Прошива на самую свежую версию не меняет ситуацию).

Share this post


Link to post
Share on other sites

Сам себе отвечаю.

Загуглил и внезапно все равно вышел на forum.nag.ru

Был такой вопрос уже 3 года назад.

Вот пруф:

 

"Пропустить незнакомые вланы через trunk порт"

http://forum.nag.ru/forum/index.php?showtopic=83704

 

Суть ответа:

switchport trunk allowed vlan all

 

В итоге: сам лашара - нужно читать мануалы )

 

P.S. Прикольно тогда по какой логике он пропускает вланы без этой команды (ну да ладно - мне не в лом добавить в шаблон конфига)

Share this post


Link to post
Share on other sites

switchport trunk allowed vlan all

 

Данная команда присутствует в конфиге свиче по sh run ?

Share this post


Link to post
Share on other sites

о блин, хотел ответить на ваш вопрос, а оказалось все немножко запутаннее...

 

1. в конфиге, внезапно, нету команды

switchport trunk allowed vlan all

 

2. Зато каким-то боком в конце конфига заметил voice-vlan <NNN>

где NNN - это мой проблемный влан, который не пролетал транзитом по аплинк (транк) портам

(я сам не мог прописать такую бороду (даю 99,9% :))

 

3. Еще я нарыл у себя в личной базе знаний старый комент, когда начинал знакомиться со свичами SNR

команда
no vlan ingress enable

отключает фильтрацию vlan на порту,

с дефлотным конфигом , когда такой команды на порту нет, пропускаются только allowed vlan-ы.

Эта команда в конфиге показывается.

 

Согласен, формулировка не четкая - надо снова делать лабу и разбираться....

Share this post


Link to post
Share on other sites

Итак, на свежий мозг заново формулирую ситуацию.

Во всем городе гирлянды из свичей доступа SNR 2960 работают без проблем по схеме влан на свич- вланы дальних свичей проходят прозрачно через вланы ближних свичей через аплинк порты, на которых включен trunc режим (по дефолту для всех VLAN.

Это сильно упрощает настройку свичей (не нужно прописывать явно транзитные вланы).

 

И вот появилась комбинация вланов, которая не работает.

Обновление прошивки не помогает,

switchport trunk allowed vlan all - не помогает

switchport trunk allowed vlan X, где X - транзитный влан - не помогает

no vlan ingress enable - не помогает.

 

Помогает только явное прописывание транзитного влана на свиче

vlan X,Y,Z

(что усложняет жизнь при добавлении свчией в гирлянду)

 

 

Вот типовой конфиг свича доступ, который работает

(кроме случая, когда свич c влан 3413 подключен через свич с влан 3412)

vlan 152 - это влан управления.

Аплинк порт = 25

 

 

service password-encryption
!
hostname V022
sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
sysContact support@nag.ru
!
authentication logging enable
!
username admin privilege 15 password 7 bla-bla-bla
!
authentication line console login local
authentication ip access-class cli_acl in
!
!
!
!
!
service dhcp
!
!
ip dhcp snooping enable
ip dhcp snooping vlan 3413
ip dhcp snooping binding enable
!
ip dhcp snooping information enable
ip dhcp snooping information option subscriber-id format hex
!
!
!
!
!
!
loopback-detection interval-time 10 3
!
loopback-detection control-recovery timeout 30
!
!
vlan 1;152;3413 
!
ip access-list standard cli_acl
 permit 192.168.0.0 0.0.255.255
 permit host-source 10.10.152.254
 exit
!
Interface Ethernet1/1
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/2
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/3
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/4
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/5
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/6
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/7
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/8
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/9
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/10
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/11
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!         
Interface Ethernet1/12
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/13
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/14
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/15
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/16
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/17
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/18
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/19
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/20
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/21
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/22
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/23
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/24
switchport access vlan 3413
loopback-detection specified-vlan 3413
loopback-detection control block
ip dhcp snooping binding user-control
ip dhcp snooping binding user-control max-user 4
!
Interface Ethernet1/25
switchport mode trunk
ip dhcp snooping trust
!
Interface Ethernet1/26
switchport mode trunk
ip dhcp snooping trust
!
Interface Ethernet1/27
switchport mode trunk
ip dhcp snooping trust
!
Interface Ethernet1/28
switchport mode trunk
ip dhcp snooping trust
!
interface Vlan152
ip address 10.10.152.22 255.255.255.0
!
ip default-gateway 10.10.152.254
!
ntp enable
ntp server 192.168.10.1
!
no login
!
!         
isolate-port group g1 switchport interface Ethernet1/28
isolate-port group g1 switchport interface Ethernet1/27
isolate-port group g1 switchport interface Ethernet1/26
isolate-port group g1 switchport interface Ethernet1/24
isolate-port group g1 switchport interface Ethernet1/23
isolate-port group g1 switchport interface Ethernet1/22
isolate-port group g1 switchport interface Ethernet1/21
isolate-port group g1 switchport interface Ethernet1/20
isolate-port group g1 switchport interface Ethernet1/19
isolate-port group g1 switchport interface Ethernet1/18
isolate-port group g1 switchport interface Ethernet1/17
isolate-port group g1 switchport interface Ethernet1/16
isolate-port group g1 switchport interface Ethernet1/15
isolate-port group g1 switchport interface Ethernet1/14
isolate-port group g1 switchport interface Ethernet1/13
isolate-port group g1 switchport interface Ethernet1/12
isolate-port group g1 switchport interface Ethernet1/11
isolate-port group g1 switchport interface Ethernet1/10
isolate-port group g1 switchport interface Ethernet1/9
isolate-port group g1 switchport interface Ethernet1/8
isolate-port group g1 switchport interface Ethernet1/7
isolate-port group g1 switchport interface Ethernet1/6
isolate-port group g1 switchport interface Ethernet1/5
isolate-port group g1 switchport interface Ethernet1/4
isolate-port group g1 switchport interface Ethernet1/3
isolate-port group g1 switchport interface Ethernet1/2
isolate-port group g1 switchport interface Ethernet1/1
end

 

 

 

sh ver
 SNR-S2960-24G Device, Compiled on Mar 11 09:34:33 2016
 sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
 CPU Mac f8:f0:82:73:a4:eb
 Vlan MAC f8:f0:82:73:a4:ea
 SoftWare Version 7.0.3.5(R0217.0142)
 BootRom Version 7.1.3
 HardWare Version 1.0.2
 CPLD Version 1.2
 Serial No.:SW011510F213000716
 Copyright (C) 2016 NAG LLC
 All rights reserved
 Last reboot is warm reset.
 Uptime is 2 weeks, 3 days, 21 hours, 18 minutes

В чём секрет? :)

Share this post


Link to post
Share on other sites

Офицательный ответ:

 

На транковом порту по умолчанию пропускаются все созданные vlan, по этому команда switchport trunk allowed vlan all не отображается в конфигурации.

Но для того чтобы трафик проходил в vlan, его надо создать, можно создать сразу все vlan командой "vlan 1-4094"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this