Перейти к содержимому
Калькуляторы

гемор в настройке OSPF Juniper

Впервые настраиваю juniper ex3300

Настроил OSPF, завел ip интерфейс на влане, затем пока не указал в ручную принадлежность интерфейса области оспф эта сеть не анонсировалась

После cisco где просто указываешь глобально сети которые анонсируются и больше ОСПФ не трогаешь, перспектива заводить каждый интерфейс в оспф откровенно напрягает

Чую что должен быть аналогичный cisco способ облегчить жизнь, чтоб она просто все что к ней подключено анонсировала по дефолту, но во всех мануалах прописывают каждый интерфейс.

Может кто подскажет где копать?

 

ЗЫ. вообще конечно некоторые моменты после киски в ступор вводят...

пол дня пытался понять что же не правильно настроил в виртуальном шасси, поскольку в конфиге интерфейсы второго свича не показывались, пока не узнал что их в ручную прописывать нужно.

Логику наличия unit 0 на каждом интерфейсе вообще не понимаю, на агрегированных линках сходу и не догадаешься что его удалить нужно.

Изменено пользователем sergsa

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

либо

#set proto ospf ar 0 int all passive

либо

#set proto ospf export redistribute-connected

#set polic polic redistribute-connected from proto direct

#set polic polic redistribute-connected then accept

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Впервые настраиваю juniper ex3300

Настроил OSPF, завел ip интерфейс на влане, затем пока не указал в ручную принадлежность интерфейса области оспф эта сеть не анонсировалась

После cisco где просто указываешь глобально сети которые анонсируются и больше ОСПФ не трогаешь, перспектива заводить каждый интерфейс в оспф откровенно напрягает

Чую что должен быть аналогичный cisco способ облегчить жизнь, чтоб она просто все что к ней подключено анонсировала по дефолту, но во всех мануалах прописывают каждый интерфейс.

Может кто подскажет где копать?

 

ЗЫ. вообще конечно некоторые моменты после киски в ступор вводят...

пол дня пытался понять что же не правильно настроил в виртуальном шасси, поскольку в конфиге интерфейсы второго свича не показывались, пока не узнал что их в ручную прописывать нужно.

Логику наличия unit 0 на каждом интерфейсе вообще не понимаю, на агрегированных линках сходу и не догадаешься что его удалить нужно.

 

 

Вы заблуждаетесь, в конфигурации процесса OSPF мы не прописываем никаких сетей.

конфиг вида

 

network 192.213.0.0 0.0.255.255 area 0.0.0.0

 

говорит нам не о том, что оглашаем сеть 192.213.0.0, а о том, что все интерфейсы, которые попали под данную сеть будут работать в области 0.0.0.0, а следовательно пытаться установить связь.

 

включать OSPF на клиентский интерфейсах как минимум не красиво.

 

По мне так лучше делать редистрибьюцию

Изменено пользователем Renaissance87

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Впервые настраиваю juniper ex3300

Настроил OSPF, завел ip интерфейс на влане, затем пока не указал в ручную принадлежность интерфейса области оспф эта сеть не анонсировалась

После cisco где просто указываешь глобально сети которые анонсируются и больше ОСПФ не трогаешь, перспектива заводить каждый интерфейс в оспф откровенно напрягает

Чую что должен быть аналогичный cisco способ облегчить жизнь, чтоб она просто все что к ней подключено анонсировала по дефолту, но во всех мануалах прописывают каждый интерфейс.

Может кто подскажет где копать?

 

ЗЫ. вообще конечно некоторые моменты после киски в ступор вводят...

пол дня пытался понять что же не правильно настроил в виртуальном шасси, поскольку в конфиге интерфейсы второго свича не показывались, пока не узнал что их в ручную прописывать нужно.

Логику наличия unit 0 на каждом интерфейсе вообще не понимаю, на агрегированных линках сходу и не догадаешься что его удалить нужно.

 

 

Вы заблуждаетесь, в конфигурации процесса OSPF мы не прописываем никаких сетей.

конфиг вида

 

network 192.213.0.0 0.0.255.255 area 0.0.0.0

 

говорит нам не о том, что оглашаем сеть 192.213.0.0, а о том, что все интерфейсы, которые попали под данную сеть будут работать в области 0.0.0.0, а следовательно пытаться установить связь.

 

включать OSPF на клиентский интерфейсах как минимум не красиво.

 

По мне так лучше делать редистрибьюцию

 

Можно делать passive-interface default, а затем no passive-interface xxx для конкретного интерфейса.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Настроил OSPF, завел ip интерфейс на влане, затем пока не указал в ручную принадлежность интерфейса области оспф эта сеть не анонсировалась

После cisco где просто указываешь глобально сети которые анонсируются и больше ОСПФ не трогаешь, перспектива заводить каждый интерфейс в оспф откровенно напрягает

 

 

У вас базовое непонимание принципа работы ospf.

Если включать на всех интерфейсах, то и на всех интерфейсах протокол будет ожидать соседей, это ни разу не безопасно.

 

В вашем случае, как и на cisco, так и на juniper (как я понял из текста) нужно просто сделать редистрибьюцию connected маршрутов. В частности на cisco правильно будет сделать так:

 

!int vlan 200ip 10.10.10.1 255.255.255.0!router ospfredistribute connected subnetspassive-interface defaultnetwork 10.10.10.1 0.0.0.255 area 0!

 

 

На юнипере смотрите в мануалах. Ключевая часть redistibute.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

У вас базовое непонимание принципа работы ospf.

Если включать на всех интерфейсах, то и на всех интерфейсах протокол будет ожидать соседей, это ни разу не безопасно.

Так вроде passive отключает соседство на порту.

To advertise the direct interface addresses without actually running OSPF on that interface (adjacencies are not formed and hello packets are not generated), you configure that interface as a passive interface
Изменено пользователем sergsa

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Настроил OSPF, завел ip интерфейс на влане, затем пока не указал в ручную принадлежность интерфейса области оспф эта сеть не анонсировалась

После cisco где просто указываешь глобально сети которые анонсируются и больше ОСПФ не трогаешь, перспектива заводить каждый интерфейс в оспф откровенно напрягает

 

У вас базовое непонимание принципа работы ospf.

Если включать на всех интерфейсах, то и на всех интерфейсах протокол будет ожидать соседей, это ни разу не безопасно.

 

В вашем случае, как и на cisco, так и на juniper (как я понял из текста) нужно просто сделать редистрибьюцию connected маршрутов. В частности на cisco правильно будет сделать так:

!
int vlan 200
ip 10.10.10.1 255.255.255.0
!
router ospf
redistribute connected subnets
passive-interface default
network 10.10.10.1 0.0.0.255 area 0
!

 

На юнипере смотрите в мануалах. Ключевая часть redistibute.

Можно даже без redistribute connected subnets, network 10.10.10.1 0.0.0.255 area 0 обеспечит ему type intra area, в таблице маршрутизации.

Можно более точно указать только данный интерфейс network 10.10.10.1 0.0.0.0 area 0

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Настроил OSPF, завел ip интерфейс на влане, затем пока не указал в ручную принадлежность интерфейса области оспф эта сеть не анонсировалась

После cisco где просто указываешь глобально сети которые анонсируются и больше ОСПФ не трогаешь, перспектива заводить каждый интерфейс в оспф откровенно напрягает

 

У вас базовое непонимание принципа работы ospf.

Если включать на всех интерфейсах, то и на всех интерфейсах протокол будет ожидать соседей, это ни разу не безопасно.

 

В вашем случае, как и на cisco, так и на juniper (как я понял из текста) нужно просто сделать редистрибьюцию connected маршрутов. В частности на cisco правильно будет сделать так:

!
int vlan 200
ip 10.10.10.1 255.255.255.0
!
router ospf
redistribute connected subnets
passive-interface default
network 10.10.10.1 0.0.0.255 area 0
!

 

На юнипере смотрите в мануалах. Ключевая часть redistibute.

Можно даже без redistribute connected subnets, network 10.10.10.1 0.0.0.255 area 0 обеспечит ему type intra area, в таблице маршрутизации.

Можно более точно указать только данный интерфейс network 10.10.10.1 0.0.0.0 area 0

В общем пришли к тому же - достаточно сети указать

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем пришли к тому же - достаточно сети указать

 

В общем Вы так и не поняли о чем мы Вам пытались рассказать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

В общем пришли к тому же - достаточно сети указать

 

В общем Вы так и не поняли о чем мы Вам пытались рассказать.

чего я не понял?

то что лучше redistribute или export from использовать, а включать на портах со своими, вроде это я понял

или то что networks включает ospf на портах так же как перечисление interfaces

Изменено пользователем sergsa

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас