Jump to content
Калькуляторы

Source routing + NAT на SE100 Source routing (forward policy) + NAT на SE100

Всем доброго времени суток.

 

В связи с необходимостью использования пулов IP адресов от разных провайдеров, при отсутствии собственной AS, возникла задача настроить Source Routing.

Интернет раздается пользователям с использованием NAT на SmartEdge100.

Попытки настроить Source Routing вместе с NAT на БРАС успехом не увенчались.

 

Привожу тестовый конфиг:

 

context test1

!

no ip domain-lookup

!

ip nat pool NAPT-pool1 napt paired-mode logging

address 192.168.188.10/32 port-block 1 to 15

!

ip nat pool NAPT-pool2 napt paired-mode logging

address 192.168.188.20/32 port-block 1 to 15

!

nat policy NAT-test1 enhanced

! Default class

drop

icmp-notification

! Named classes

access-group NAT-test-acl

class TCLASS

pool NAPT-pool1 test1

inbound-refresh udp

icmp-notification

class do-not-nat-L

ignore

inbound-refresh udp

icmp-notification

!

nat policy NAT-test2 enhanced

! Default class

drop

icmp-notification

! Named classes

access-group NAT-test-acl

class TCLASS

pool NAPT-pool2 test1

inbound-refresh udp

icmp-notification

class do-not-nat-L

ignore

inbound-refresh udp

icmp-notification

!

interface testnat multibind

ip address 192.168.177.1/24

!

interface uplink1

ip address 192.168.190.1/24

no logging console

!

interface uplink2

ip address 192.168.191.1/24

no logging console

!

policy access-list NAT-test-acl

seq 10 permit ip any host 192.168.177.1 class do-not-nat-L

seq 20 permit ip any class TCLASS

!

policy access-list FWD-test-acl

seq 10 permit ip host 192.168.188.20 any class FWDCLASS

seq 20 permit ip any class LCLASS

!

!

subscriber name testnat1

ip address 192.168.177.10

nat policy-name NAT-test1

!

subscriber name testnat2

ip address 192.168.177.20

nat policy-name NAT-test2

!

ip route 0.0.0.0/0 192.168.190.10

 

 

 

context local

 

forward policy SROUTE

ip access-group FWD-test-acl test1

class FWDCLASS

redirect destination ip next-hop 192.168.191.10

class TCLASS

class do-not-nat-L

 

 

port ethernet 2/2

dot1q pvc 130

forward policy SROUTE in

service clips

clips pvc 77005

bind subscriber testnat1@test1

clips pvc 77006

bind subscriber testnat2@test1

dot1q pvc 131

bind interface uplink1 test1

dot1q pvc 132

bind interface uplink2 test1

 

, где

192.168.177.10 - клиент1

192.168.177.20 - клиент2

192.168.188.10 - IP, в который натится клиент1

192.168.188.20 - IP, в который натится клиент2

192.168.190.10 - шлюз по умолчанию

192.168.191.10 - шлюз, в который должны уходить все пакеты, имеющие в поле "source IP" адрес 192.168.188.20

 

На каждый из шлюзов (192.168.190.10 и 192.168.191.10) повесил по машине со снифером.

Стучусь с клиента1 и клиента2 на произвольный хост через tcp или icmp.

Вижу, что пакеты в любом случае приходят только на 192.168.190.10

 

Возможно, кто-то уже решал подобную задачу на Redback-е?

Подскажите, где у меня может быть ошибка?

Возможно ли в принципе использование Source Routing совместно с NAT на SE100 в рамках одного контекста?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this