Jump to content

Mikrotik + PPPoE + PPTP Mikrotik + PPPoE клиент + PPTP клиеньт

Есть железяка RB 2011Uas 2n hd

Аплинк витая пара (Локалка dhcp, интернет PPPoE)

Есть задача пустьть весь траффик через удаленный PPTP сервер.

В качестве сервера Centos 7.

Сервер на 100% рабочий с винды подключается без проблем.

С Микротика PPTP соединение поднимается.

 

/interface pptp-client

add add-default-route=no allow=mschap2 connect-to=1.2.3.4 dial-on-demand=\

no disabled=no keepalive-timeout=disabled max-mru=1450 max-mtu=1450 mrru=\

disabled name=g_vnp password=pass profile=default-encryption user=\

user

 

Прописываю статический роут

/ip route

add distance=1 dst-address=1.2.3.4/32 gateway=pppoe-out1

 

Прописываю Дефолт роуты На 2 соединения

add distance=101 gateway=pppoe-out1

add distance=99 gateway=g_vnp

 

Траффик с микротика идет через PPTP - если верить результатам трассировки

 

Но как только пытаюсь развернуть весь пользовательский трафик в ВПН

 

/ip firewall nat

add action=masquerade chain=srcnat out-interface=pppoe-out1

меняю на

add action=masquerade chain=srcnat out-interface=g_vpn

 

VPn соединение отваливается после прохождения 2-5 пингов и уходит в циклическое переподключение.

хотя с микротика пинг до ВПн сервера не прерывается

В чем может быть проблема?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.