Jump to content
Калькуляторы

750 микртоик VLAN от провайдера 750 микртоик VLAN от провайдера - а как собственно лучше?

Доброе настроение всем! Нуждаюсь в совете как лучше настроить. Есть 750 микртоик на 1 входит инет и VLAN от провайдера для ip теллефонии.

особенность в том что нужно на 2 й порт (в связи с тем что строители пробросили только один кабель до р места) подать интернет для компьютера, и по VLAN 3624 2 номера на 2 ip телефона гигасет.

Мой вариант - все стандартно 192,168,88,1 - локал, на 1 м порту прописал VLAN 3624 на 2м тоже , обьеденил бриджем. телефон работает инте тоже но тут подняли gre тунель до офиса и оказалось что с микротика пинг в сеть есть а с сети 88 - нет.

Вообшем обнулил все думаю как быть.

условия - 1 порт -есть ИНЕТ, есть VLAN 3624 с адресацией 10,227,*,*

надо

поднять gre тунель с осн офисом, (сделаю)

на 2 м порту (в енго воткнут свич)

инет на сеть 88

маршруты на офисную сеть для уд доступа..

проброс портов на камеры уже делал тоесть работает..

и главное красиво подключить 2 телефона - провайдер выдал 2 адресса 10,227,31,1 и 2 + сервера и пароли явки

но еше надо с этих же телефонов завернуть (создать еше по одному подключению ip телефона) в офисную сеть

Share this post


Link to post
Share on other sites

Смотрите в сторону маршрутов, по моему там косяк

Share this post


Link to post
Share on other sites

дело в том что пока незнаю как сделать схему правильной. по сути получается что ип телефоны надо и направить в 10 сеть провайдера и в свою для доступа к астериксу.

Share this post


Link to post
Share on other sites

вопрос .. возможна ли такая схема

vlan1 = 3624, он привязан к ether1 инет и влан от провайдера. по влану идут 2 телефона ип номера телефона указан на vlan1 и еше раз vlan1

10.227.31.1 это шлюз внутри влана у прова а сам телефон внутри сети 192.168.88.24 и 23

вот # ADDRESS NETWORK INTERFACE

0 ;;; default configuration

192.168.88.1/24 192.168.88.0 ether2-master-local

1 46.163.172.218/19 46.163.160.0 ether1-gateway

2 192.168.58.6/30 192.168.58.4 gre-tunnel-2

3 192.168.58.10/30 192.168.58.8 gre-tunnel-1

4 10.227.31.24/32 10.227.31.0 vlan1

5 X 10.227.31.23/32 10.227.31.0 vlan1

 

ну сделать проброс в разные стороны ка то так

 

chain=forward action=accept protocol=udp dst-address=10.227.31.1 in-interface=VLAN1 out-interface=ether2

chain=dstnat action=dst-nat to-addresses=10.227.31.1 protocol=udp in-interface=VLAN1 dst-port=10000-20000

chain=dstnat action=dst-nat to-addresses=10.227.31.1 to-ports=5060 protocol=tcp in-interface=Vlan1 dst-port=5060

chain=dstnat action=dst-nat to-addresses=10.227.31.1 to-ports=5060 protocol=udp in-interface=vlan1 dst-port=5060

 

на каждом интерфейсе влан 1 и 2

Edited by EvgeniyKoskin

Share this post


Link to post
Share on other sites

упрощу вопрос

на 1ether надо повесить VLAN 3624 и создать в нем 2 интерфейса с 2 мя ip никами, чтобы через них занатить 2 sip телефона находяшиеся внутри сети. а сообсвенно как?

2 vlan c одним id на один 1 й порт не повесить

но возможно присвоить 2 ип адреса одному vlan ... А теперь как то надо настроить маршрут исходяший от каждого телефона через vlan -

телефоны соединяются к 2 м серверам - один без заморочек на адресс 172.20.1.1 а второй черз сеть vlan *** сеть 10 **** шлюз 10 **1 и сам сервер что то 85 *****

причем сам сервер не пингуется ни извне ни по влану.... жесть

Edited by EvgeniyKoskin

Share this post


Link to post
Share on other sites

вот еше нагляднее.

судя по всему нат на эту подсеть (10****) или на сам sip сервер сделать можно . Но как быть с входящими подключениями, ведь надо "опубликовать" 2 адресса 10.227.31.23 и 10.227.31.24 и с каждого завернуть порты вовнутрь. А dsnat умеет это делать только с интрфеса

post-126350-049110200 1427277813_thumb.jpg

Share this post


Link to post
Share on other sites

НУ хорошо .. еше вариант

ТА находится в VLAN пусть с номером 300 - хсема такая

 

устройство ТА тегированый порт VLAN300

IP - 10.227.31.23

MASK - 255.255.255.0

GW - 10.227.31.1

 

порт 2 МК --- VLAN300

бридж

порт 1 МК --- VLAN300

 

провайдер

 

поэтому соединению телефон связывается с sip сервером провайдер.

Вопрос как его дополнительно смаршрутизировать на НЕтегированую локальную сеть для доступа к серверу SIP2

ну и дать из локальной сети возможность его (ТА) управления

ТА - не циска а банальный 510 гигасет радио дект ip телефон

Share this post


Link to post
Share on other sites

тема закрыта .. спасибо за помошь Константин (скайп kizimka4) помог

вообшем для натсройки нам потребовалось на порт 1 провайдера зацепить влан с тегом на него еше прицепить ип адресс - один из тех что провайдер дал.

/interface vlan

add interface=ether1-gateway l2mtu=1596 name=vlan3624 vlan-id=3624

add address=10.227.31.24/24 interface=vlan3624 network=10.227.31.0

нат на сеть до шлюза в сети влан

нат до адресса сип сервера внутри влан

нат на свой астерикс он в локальной сети но не в сети тика.. (так получилось до этих изменений работало и без ната только с помошью маршрута

вот

add action=masquerade chain=srcnat comment="тунель до офиса где все в том числе сип сервер" dst-address=\

172.25.0.0/16 out-interface=тунель до офиса где все в том числе сип сервер

add action=masquerade chain=srcnat comment="voip provider" dst-address=\

85.12.253.0/24 out-interface=vlan3624

add action=masquerade chain=srcnat comment="voip provider" dst-address=\

10.227.31.0/24 out-interface=vlan3624

add action=masquerade chain=srcnat comment=internet dst-address=\

!10.227.31.0/24 out-interface=ether1-gateway

как видим нижнее правило натит все остальное уже в мир

телефоны находятся в локальной сети 192.168.88.0

всем спасибо!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this