Jump to content

Отправка статистики по интерфейсу на почту. Микротик

Нужен скрипт, который отправит информацию о pppoe подключении(или другом интерфейсе) на e-mail.

При вводе в окне "New terminal" команды "interface pppoe-client monitor PPPOE1", где PPPOE1 - название интерфейса, появляется подробная статистика:

"status: connected

uptime: 5d53m59s

active-links: 1

encoding:

service-name:

ac-name: DOM.RU

ac-mac: 00:90:00:00:00:00

mtu: 1480

mru: 1480

local-address: 123.123.123.123

remote-address: 123.123.123.123"

 

Что прописать в NETWATCH во вкладке "UP", чтобы при подключении к pppoe-серверу вышеуказанная статистика отправилась на почту.

С командой "tool e-mail send from и тд..." и настройкой smtp сервера знаком.

Заранее спасибо

Edited by bumble-bee007

Share this post


Link to post
Share on other sites

не помню чтобы в микротике можно было прописывать какие либо обработчики событий(во вкладку не заглядываю), поэтому

можно написать скрипт с проверкой нужного Вам условия и отправкой сообщения. запускаете его в планировщике раз в пять-десять секунд.

накидаю строки скрипта, для анализа

 

:set EOIPtunnelname [/interface get [find (type="eoip") and (disabled=no) ] name];

:set status [/int eoip get $EOIPtunnelname running] ;

:if ( $status = true ) do={

:log info "MONITOR-EoIP: ALARM!!! Tunnel status is $status." ;

/tool e-mail send server=11.11.111.1 port=25 user=user@domainname.ru to=noc@domainname.ru from="mikrotik1@domainname.ru" subject="HELLO!" ;

}

Edited by QWE

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.