Jump to content
Калькуляторы

multicast+des-3200-28 Проблема с конфигом

Друзья выручайте. азъясните возможно ли сделать то что я хочу. Кажется что возможно но не могу понять как. На фото примитивная схема с обозначеными портами и устройствами. Вроде видно все. Имеем коммутатор, источники multicast и клиентов. В моем понимании мультикаст идет только туда где его просят. во все порты он не валится. Прилагаю конфиг коммутатор:

 

 

# SNOOP

 

enable igmp_snooping

config igmp_snooping data_driven_learning max_learned_entry 1

enable igmp_snooping multicast_vlan

config igmp_snooping vlan_name default state disable fast_leave disable

config igmp_snooping data_driven_learning vlan_name default aged_out disable

config igmp_snooping querier all query_interval 125 max_response_time 10 robustn ess_variable 2 last_member_query_interval 1 state disable version 2

config igmp_snooping vlan_name Ferma state disable fast_leave disable

config igmp_snooping data_driven_learning vlan_name Ferma aged_out disable

config igmp_snooping querier vlan_name Ferma query_interval 125 max_response_tim e 10 robustness_variable 2 last_member_query_interval 1 state disable version 3

config igmp_snooping vlan_name Manager state disable fast_leave disable

config igmp_snooping data_driven_learning vlan_name Manager aged_out disable

config igmp_snooping vlan_name iptv state enable fast_leave enable

config igmp_snooping data_driven_learning vlan_name iptv aged_out disable

config igmp_snooping querier vlan_name iptv query_interval 125 max_response_time 10 robustness_variable 2 last_member_query_interval 1 state enable version 2

config router_ports iptv add 21,25-26

config igmp access_authentication ports 1-28 state disable

 

 

create vlan iptv tag 971 advertisement

config vlan iptv add tagged 21,28

config vlan iptv add untagged 1-8,11,18-19,23,25-26

disable qinq

disable gvrp

config qinq ports 1-28 role nni outer_tpid 0x88A8 trust_cvid disable vlan_transl ation disable

config gvrp 1-8,11,18-19,23,25-26 state disable ingress_checking enable acceptab le_frame admit_all pvid 971

config gvrp 9-10,12-17,20,22,24 state disable ingress_checking enable acceptable _frame admit_all pvid 666

config gvrp 21,27-28 state disable ingress_checking enable acceptable_frame admi t_all pvid 1

 

 

 

# FDB

 

config fdb aging_time 300

config multicast port_filtering_mode 1-28 filter_unregistered_groups

 

 

 

вроде все что нужно привел. Могу остатки выложить если нужно. Суть в следующем.в 26 порт прилетает multicast и настроено так что порт 26 работает только с 25 портом и весь multicast уходит на железку ip->dvb-c. multicast c портов 1-24 выходит в 28 порт и все рады довольны. Источники multicast разные. 1-14 свои источники, порт 26 другой источник. по нумерации групп они не пересекаются. Проблема в следующем. Как только я разрешаю ходить 26 порту куда он хочет, те. снимаю traffic segmentation, сразу в 28 порт валятся все 180 Мбит потока multicast и сеть ложиться. как избежать этого? Как сделать так чтобы эти 180 Мбит шли только на железку ip->dvb-c. И только если клиент из 28 порта запросит группу с 26 порта только тогда конкретная группа вещалась. А не валила все во все порты

DSC_0321 (1).JPG

Share this post


Link to post
Share on other sites

Ничего не понял, но может виланами развести какие надо порты

Share this post


Link to post
Share on other sites

Если вы создаете мультикаст влан, то его не надо создавать еще раз как обычный влан.

Для мультикаст влана надо указать источником только реальный порт источника, то есть 26, а у вас там еще 25 зачем-то. Потом надо указывать клиентские порты. У вас 1-25, 28.

Чтобы весь мультик не лился в порт - настроить фильтр

config multicast port_filtering_mode 1-25 filter_unregistered_groups

Может данная статья поможет http://habrahabr.ru/post/111317/ или погуглите как настроить мультикаст влан на длинке. примеров и инструкций полно

Share this post


Link to post
Share on other sites

config multicast port_filtering_mode 1-25 filter_unregistered_groups

Это натсроено. самая последняя строчка. правда на все порты раскинуто. Сам комутер я настраивал и она работает у меня ещё источники на первых 11 портах есть. Но там по 9 каналов максимум идет. И с ними комутатор отрабатывает нормально. Лишнего не пропускает. А с источником именно с 26 порта вот такая беда. Статью уже эту читал. Немного конфиг подправил- не помогло. Про источник попробую исправить порты

Edited by Eagle18

Share this post


Link to post
Share on other sites

Немного оживлю тему. В данный момент конфиг не менялся но как то само с собой стало что прилетает 180Мбит мультикаста в порт Des 3200-28. и все. дальше ничего не идет. Идет трафик только тогда когда кто-то включает канал. и трафик идет только для канала а не все 180Мбит как раньше было. Но появилась у меня в тесте железка BDcomm. Настроил её по многим статьям и где то сам. Прописал пул multicast ip mcst mc-vlan 971 range 238.1.1.200 - 238.1.1.250. И так далее по статьям. Нужно приведу весь конфиг.И как только я её подключаю в сеть. Даже не имея ни одной подключенной онушки сразу весь мультикаст начинает проходить через коммутатор как будто Bdcomm сам все каналы в себя берет. это же не правильно. Пробовал range на BDcomm указать в один канал всего лишь-все равно весь трафик побежал. Помогите конфиг допилить для multicasta.Или вообще с нуля все настроить

Share this post


Link to post
Share on other sites

Ещё добавлю что между des3200 и BDComm ещё есть ряд коммутатором и 16 портовики есть и DGS32 версии. Но на них igmp не настроен.

Share this post


Link to post
Share on other sites

И ещё уточнения. мультикаст до клиента у нас идет ни как полноценный мультикаст с настройкой каждог окомутера а на головном коммутаторе мультикаст заворачивается в обычный влан и летит до клиента. клиенту этот влан просто выдается антегом и Stb прекрасно работают. Также этот метод доставки работал и на оборудовании eltex-так же нареканий не было. а вот BDcomm собираемся ставить и собрать не получается схему

Share this post


Link to post
Share on other sites

Друзья выручайте. Сегодня с утра перестало iptv работать. Вот конфиг который на des3200-28 сейчас:

 

 

# SNOOP

 

enable igmp_snooping

config igmp_snooping data_driven_learning max_learned_entry 1

enable igmp_snooping multicast_vlan

create igmp_snooping multicast_vlan iptv 971

config igmp_snooping multicast_vlan iptv state enable

config igmp_snooping multicast_vlan iptv add member_port 21

config igmp_snooping multicast_vlan iptv add source_port 1-9,11,18,25

config igmp_snooping multicast_vlan_group iptv add 238.1.1.0-238.1.1.240

config igmp_snooping vlan_name iptv fast_leave enable

config igmp_snooping data_driven_learning vlan_name iptv aged_out enable

config igmp_snooping querier vlan_name iptv query_interval 125 max_response_time 10 robustness_variable 2 last_member_query_interval 1 state enable version 3

config router_ports iptv add 25

config igmp access_authentication ports 1-28 state disable

 

# FDB

 

config fdb aging_time 300

config multicast port_filtering_mode 10,12-17,19-25,28 filter_unregistered_groups

config multicast port_filtering_mode 1-9,11,18,26-27 forward_unregistered_groups

 

# VLAN

 

disable asymmetric_vlan

enable pvid auto_assign

config vlan default delete 1-28

config vlan default advertisement disable

create vlan Ferma tag 204

config vlan Ferma add tagged 21,24,28

create vlan Manager tag 666 advertisement

config vlan Manager add tagged 21,28

config vlan Manager add untagged 10,12-17,19-20,22,24

disable qinq

disable gvrp

config qinq ports 1-28 role nni outer_tpid 0x88A8 trust_cvid disable vlan_translation disable

config gvrp 1-9,11,18,21,23,25-28 state disable ingress_checking enable acceptable_frame admit_all pvid 1

config gvrp 10,12-17,19-20,22,24 state disable ingress_checking enable acceptable_frame admit_all pvid 666

 

 

 

причем бывает такое что один канал начинает показывать. переключишь и потом обратно, и все не показывает. При этом если смотреть с источника напрямую до коммутатора то все показывает отлично. а если смотреть с коммутатора с одного из портов-то не показывает нифига либо рандомно канал включается. Неделя до отпуска осталась, помогите разобраться, а то не хочется отпуск переносить

Share this post


Link to post
Share on other sites

config router_ports iptv add 25 - и ни одного другого влана в 25 порту. Точно аплинк? Попробуй удалить статический роут порт

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this