Jump to content
Калькуляторы

Juniper SRX routing-instances tunnels

Здравствуйте!

Надеюсь верно форум выбрал :).

Столкнулся с совершенно не понятной траблой. Опишу что было и что есть.

Есть джунипер, у него 2 канала во внешку и через каждый канал поднят туннель до другой машинки. Оба канала это pppoe подключения. Первый туннель идет по дефолнтному роутингу, а второй через routing-instances . И все работало намано. Но вот один провайдер купил другого и теперь эти оба канала принадлежат одному прову. Да и ладно и так тоже хорошо, так как разные провода к нам идут. Но вот один момент смущает, то что шлюз выдается один и тот же. Да и тут вроде проблемм нет, с внешки захожу по ссх на любой из ипов. Но вот туннель который через routing-instances работать перестал. Траф через него не идет. На другом конце у меня фрюха и через tcpdump вижу, что мультикаст все таки приходит, но только он и больше ничего.

 

Что еще показать, как потестить подскажите плиз... Пробовал еще делать дампы на самом джунипере, но вот на втором pppoe получается получить только входищий траффик, хотя на первом все в порядке...

Уже всю голову сломал, ничего не могу выдумать...

 

14:23:22.055995 IP 9.109.11.124 > 5.79.98.124: IP 10.0.59.10 > 224.0.0.5: OSPFv2, Hello, length 56 (ipip-proto-4)

Вот настройки джунипера

kiran@sklad# show routing-instances
reserv {
   instance-type virtual-router;
   interface pp0.1;
   routing-options {
       interface-routes {
           rib-group inet cp-reserv-to-main;
       }
       static {
           route 0.0.0.0/0 next-hop pp0.1;
       }
   }
}


kiran@sklad# show interfaces ip-0/0/0 unit 59 
tunnel {
   source 9.109.11.124;
   destination 5.79.98.124;
   routing-instance {
       destination reserv;
   }
}
family inet {
   mtu 1280;
   inactive: sampling {
       input;
       output;
   }
   address 10.0.59.10/30;
}


kiran@sklad# show security zones security-zone core 
host-inbound-traffic {
   system-services {
       all;
       ping;
   }
   protocols {
       all;
   }
}
interfaces {
   ip-0/0/0.59;
   gr-0/0/0.59;
   inactive: gr-0/0/0.5;
}

kiran@sklad# show security zones security-zone core 
host-inbound-traffic {
   system-services {
       all;
       ping;
   }
   protocols {
       all;
   }
}
interfaces {
   ip-0/0/0.59;
   gr-0/0/0.59;
   inactive: gr-0/0/0.5;
}

kiran@sklad# show routing-options                              
interface-routes {
   rib-group inet cp-route;
}
static {
   rib-group cp-route;
   route 0.0.0.0/0 next-hop pp0.0;
   route 5.79.98.124/32 next-hop pp0.1;
}
rib-groups {
   cp-reserv-to-main {
       import-rib [ reserv.inet.0 inet.0 ];
   }
   cp-route {
       import-rib [ inet.0 reserv.inet.0 ];
       import-policy import-route;
   }
}
router-id 169.255.59.1;

Share this post


Link to post
Share on other sites

Я бы для начала попросил прова перенести терминацию на другой адрес, или дать эзернет напрямую.

Share this post


Link to post
Share on other sites

Я бы для начала попросил прова перенести терминацию на другой адрес, или дать эзернет напрямую.

я попросил, только не факт, что у них можно, мне там чел сказал что подумает, что можно придумать... Но пока тишина. По конфигам все вроде впорядке?

Share this post


Link to post
Share on other sites

Появилась мысль, это ведь один провайдер. Можно как то заставить пппое если по одному ифейсу подключиться не получается, что бы она по другому подключалась? Что то типа подмены underlying-interface. Это бы решило все траблы.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this