Jump to content
Калькуляторы

Потерял 6 байт в L2VPN MPLS помогите найти где не пролезает

Решил потестить L2VPN, собрал такую схему

ПК > access port 504 SW1 trunk > MX2 > MPLS CORE > MX1 > SW2 (SVI 504)

 

ПК 1.1.1.1/30

SW2 (SVI 504) 1.1.1.2/30

 

MX-1# show routing-instances L2VPN_TEST
instance-type l2vpn;
interface xe-0/0/2.502;
route-distinguisher 172.16.16.3:50;
vrf-target target:2906:151;
protocols {
   l2vpn {
       encapsulation-type ethernet-vlan;
       no-control-word;
       interface xe-0/0/2.502;
       site Butovo {
           site-identifier 102;
           interface xe-0/0/2.502 {
               remote-site-id 103;
           }
       }
   }
}

[edit]



MX-2# show routing-instances L2VPN_TEST
instance-type l2vpn;
interface ae0.502;
route-distinguisher 172.16.16.4:50;
vrf-target target:2906:151;
protocols {
   l2vpn {
       encapsulation-type ethernet-vlan;
       no-control-word;
       interface ae0.502;
       site Med {
           site-identifier 103;
           interface ae0.502 {
               remote-site-id 102;
           }
       }
   }
}

[edit]
MX-2#


Магистральные линки
MX-1> show configuration interfaces xe-0/0/0
mtu 1600;
unit 0 {
   family inet {
       address xxxxxxxx/30;
   }
   family mpls;
}

MX-1>



MX-2> show configuration interfaces ge-1/1/9
mtu 1600;
unit 0 {
   family inet {
       address xxxxxxxx/30;
   }
   family mpls;
}

MX-2>



Пинг между PE.
MX-1> ping 172.16.16.4 source 172.16.16.3 do-not-fragment size 1488
PING 172.16.16.4 (172.16.16.4): 1488 data bytes
1496 bytes from 172.16.16.4: icmp_seq=0 ttl=62 time=1.796 ms
1496 bytes from 172.16.16.4: icmp_seq=1 ttl=62 time=1.777 ms
^C
--- 172.16.16.4 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.777/1.786/1.796/0.010 ms

MX-1> ping 172.16.16.4 source 172.16.16.3 do-not-fragment size 1489
PING 172.16.16.4 (172.16.16.4): 1489 data bytes
^C
--- 172.16.16.4 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss

MX-1>


MX-2> show interfaces ae0.502 extensive
 Logical interface ae0.502 (Index 5372) (SNMP ifIndex 6334) (Generation 217424)
   Flags: SNMP-Traps 0x0 VLAN-Tag [ 0x8100.502 ]  Encapsulation: VLAN-CCC
   Statistics        Packets        pps         Bytes          bps
   Bundle:
       Input :         90958          0       7321598          608
       Output:          2948          0        235552            0
   Adaptive Statistics:
       Adaptive Adjusts:          0
       Adaptive Scans  :          0
       Adaptive Updates:          0
   Link:
     ge-1/1/0.502
       Input :         61812          0       4842524          272
       Output:          2885          0        231520            0
     ge-1/1/1.502
       Input :         29146          0       2479074          336
       Output:            63          0          4032            0
   Marker Statistics:   Marker Rx     Resp Tx   Unknown Rx   Illegal Rx
     ge-1/1/0.502               0           0            0            0
     ge-1/1/1.502               0           0            0            0
   Protocol ccc, MTU: 1522, Generation: 217107, Route table: 0
     Flags: Is-Primary

MX-2>




MX-1> show interfaces xe-0/0/2.502 extensive
 Logical interface xe-0/0/2.502 (Index 1027) (SNMP ifIndex 2693) (Generation 1463941)
   Flags: SNMP-Traps 0x0 VLAN-Tag [ 0x8100.502 ]  Encapsulation: VLAN-CCC
   Traffic statistics:
    Input  bytes  :               235552
    Output bytes  :              7288747
    Input  packets:                 2948
    Output packets:                90943
   Local statistics:
    Input  bytes  :                    0
    Output bytes  :                    0
    Input  packets:                    0
    Output packets:                    0
   Transit statistics:
    Input  bytes  :               235552                    0 bps
    Output bytes  :              7288747                 1576 bps
    Input  packets:                 2948                    0 pps
    Output packets:                90943                    2 pps
   Protocol ccc, MTU: 1522, Generation: 1464068, Route table: 0
     Flags: Is-Primary

 

На ядровых линках 1600 (на магистрали между MX-ами стоит 6509) могу оттуда что-то показать...

6509#sh run int t5/4   <<<<<<<  to core
interface TenGigabitEthernet5/4 
to core
mtu 1586
ip address xxxxxxxxxxx 255.255.255.252
load-interval 30
mpls traffic-eng tunnels
mpls ip
ip rsvp signalling hello
end

6509#sh run int g7/23  <<<<<<< to PE_MX2
interface GigabitEthernet7/23
to PE_MX2
mtu 1586
ip address xxxxxxxxxxx 255.255.255.252
ip ospf 1 area 0
mpls traffic-eng tunnels
mpls ip
ip rsvp signalling hello
end

 

 

 

Скрин того сколько проходит. В какую сторону смотреть?

thumb.png

Share this post


Link to post
Share on other sites

с

MXpe1 > 6509 > MXcore> MXpe2

MXpe1> ping mpls rsvp MXpe1>MXcore sweep
100! 5052. 2576. 1340! 2580. 1960. 1652. 1496! 1576. 1536! 1556! 1568! 1580. 1576. 1572!
--- lsp ping sweep result---
Maximum Transmission Unit (MTU) is 1572 bytes



MXpe1> ping mpls rsvp MXpe1>MXpe2 sweep
100! 5052. 2576. 1340! 2580. 1960. 1652. 1496! 1576. 1536. 1516! 1528. 1524. 1520.
--- lsp ping sweep result---
Maximum Transmission Unit (MTU) is 1516 bytes




странно. ведь между MXcore и MXpe2
MXcore> show interfaces xe-1/2/2.0 extensive | match mtu 
   Protocol inet, MTU: 1586, Generation: 1186, Route table: 0
   Protocol mpls, MTU: 1574, Maximum labels: 3, Generation: 1189, Route table: 0
   Protocol multiservice, MTU: Unlimited, Generation: 1187, Route table: 0

MXpe2> show interfaces xe-0/0/0.0 extensive | match mtu
   Protocol inet, MTU: 1586, Generation: 1407843, Route table: 0
   Protocol mpls, MTU: 1574, Maximum labels: 3, Generation: 1407936, Route table: 0
   Protocol multiservice, MTU: Unlimited, Generation: 1407844, Route table: 0

Share this post


Link to post
Share on other sites

Ping между PE 1488 max означает, что в ядре совсем не 1600 и не 1586, а 1524 (1488 payload+8 icmp+20 ip). При l2 VPN в ядре к полному пакету IP добавляется eth-заголовок 18 и пара-тройка меток по 4, тоесть 1500 превращается в 1526 или 1530(похоже, именно Ваш случай, как раз 6Б разница). И не пролазит в 1524. Делайте трассировки и пингуйте каждый хоп.

Share this post


Link to post
Share on other sites

Нашел затык между ядровым роутером и PE. MX_CORE <> MX1

Но ведь между ними 1600! На одном тестовом участке помогло увеличение до 9к :)

Хотелось бы понять почему при 1.6 не помещается...

 

MX_CORE> ping 172.16.16.3 source 172.16.16.2 do-not-fragment size 1488 
PING 172.16.16.3 (172.16.16.3): 1488 data bytes
1496 bytes from 172.16.16.3: icmp_seq=0 ttl=64 time=2.126 ms
^C
--- 172.16.16.3 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.126/2.126/2.126/0.000 ms

MX_CORE> ping 172.16.16.3 source 172.16.16.2 do-not-fragment size 1489    
PING 172.16.16.3 (172.16.16.3): 1489 data bytes
^C
--- 172.16.16.3 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss



MX_CORE> show route 172.16.16.3 table inet.0          

inet.0: 536495 destinations, 1545018 routes (536006 active, 72 holddown, 1712 hidden)
+ = Active Route, - = Last Active, * = Both

172.16.16.3/32     *[OSPF/10] 2w2d 05:06:26, metric 1
                   > to xxxxxxxx via xe-1/2/2.0

MX_CORE> 

MX_CORE> show configuration interfaces xe-1/2/2 
description to_MX1;
mtu 1600;
unit 0 {
   family inet {
       address xxxxxxxx1/30;
   }
   family mpls;
}


======================================================

MX1> ping 172.16.16.2 source 172.16.16.3 do-not-fragment size 1488
PING 172.16.16.2 (172.16.16.2): 1488 data bytes
1496 bytes from 172.16.16.2: icmp_seq=0 ttl=64 time=4.133 ms
1496 bytes from 172.16.16.2: icmp_seq=1 ttl=64 time=2.512 ms
^C
--- 172.16.16.2 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 2.512/3.322/4.133/0.811 ms

MX1> ping 172.16.16.2 source 172.16.16.3 do-not-fragment size 1489
PING 172.16.16.2 (172.16.16.2): 1489 data bytes
^C
--- 172.16.16.2 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss



MX1> show route 172.16.16.2 table inet.0

inet.0: 5787 destinations, 5792 routes (5787 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

172.16.16.2/32     *[OSPF/10] 2w2d 05:07:14, metric 1
                   > to xxxxxxxxxxx via xe-0/0/0.0

MX1>



MX1> show configuration interfaces xe-0/0/0
mtu 1600;
unit 0 {
   family inet {
       sampling {
           input;
           output;
       }
       address xxxxxxxx2/30;
   }
   family mpls;
}

MX1>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this