Перейти к содержимому
Калькуляторы

Nekit73rus

Пользователи
  • Публикации

    13
  • Зарегистрирован

  • Посещение

О Nekit73rus

  • Звание
    Абитуриент
  1. Mikrotik + Zyxel и Роуминг

    Так и думал :( спасибо!
  2. Mikrotik + Zyxel и Роуминг

    Здравствуйте! Суть: На даче был установлен Zyxel LTE6100, по дому всё прекрасно работает. Хотелось бы увидеть Wi-Fi ещё и в беседке(работает но плохо). Вопрос: Если подключить к Zyxel(проводом) Mikrotik WAP(поставить его в беседку), то возможно ли организовать "бесшовный" Wi-Fi? В каком режиме настраивать Mikrotik или на что посмотреть в Zyxele чтобы заработал роуминг?
  3. Я пока пробую перекинуть не всю подсеть, а свой локальный ip для теста. Создаю правило Mangle: chain: prerouting src: 10.0.2.2 dst: !10.0.2.2 (пробовал и 10.0.0.0/20) protocol: tcp dst.port: 80,8080 Action: mark routing New mark: testsquid Passthrough: enable И сам маршрут IP -> Routes Dst: 0.0.0.0/0 type: unicast Gateway: 10.0.9.1 Distance: 1 Scope: 30 Target scope: 10 Routing mark: testsquid И не работает :( Это идея первоапрельской шутки, на squid настроен splash page(показать пользователю страницу-шутку, после чего он спокойно работает в интернете дальше) потому что именно он хорошо работает с компами которые ещё за NAT'ом в локальной сети(политика компании). Так же пробовал принудительно в DHCP сервере выдавать шлюз 10.0.9.1 - и если подключить новое устройство, то всё отрабатывает хорошо. Но текущие клиенты уже получили шлюз 10.0.0.1 :(
  4. Как создать это исключение? потом попробую перекинуть уже в 10.0.20.0/24
  5. Здравствуйте! Возникла необходимость пустить всех клиентов локальной сети через другой шлюз (а конкретно через прозрачный squid); И так имеем: 1) Mikrotik: Eth1 - смотрит в сеть провайдера, DHCP Client; Eth2(10.0.0.1) - смотрит в локальную сеть, DHCP Server - 10.0.0.0/20; (Lease time 3d) Всё прекрасно работает, клиенты получают ip из своего диапазона с DNS 10.0.0.1 и шлюзом 10.0.0.1; Далее был настроен комп, на ubuntu 14.04, прозрачный squid, завёрнут трафик с 80 на 3128 порт сквида, 443 на 3129 порт сквида. Eth0 - DHCP client, смотрит в сеть интернет провайдера; Eth1 - Смотрит в локальную сеть, адрес 10.0.9.1; Требуется: всех клиентов локальной сети пропустить через шлюз 10.0.9.1; проблемы: клиентам уже выдан шлюз 10.0.0.1, и время жизни настроек 3 дня. Менять это не хочется, т.к. новый шлюз будет использоваться всего 1 день. Что испробавано: пробовал настроить ip->firewall->Mangle - mark routing ("onsquid") и IP->Routes - Dst.address:0.0.0.0/0 Distance:1 Gateway: 10.0.9.1 Routing mark: "onsquid". Но на клиенте ничего не открывается, страница "висит". Если же на самом клиенте поменять шлюз 10.0.9.1 вместо 10.0.0.1 то всё отрабатывает отлично. Так же пробовал через netmap перекинуть всех с 80 порта на 10.0.9.1:3128 и 443 на 10.0.9.1:3129 - но тоже тишина; Как правильно перенаправить всех клиентов локальной сети на новый шлюз(или завернуть трафик через squid на 10.0.9.1)?
  6. Mikrotik, Proxy-ARP, NAT

    Спасибо, out-inteface убран. Локалка успешно вышла под 168 адресом через src-nat.
  7. Mikrotik, Proxy-ARP, NAT

    На Сервер_1 был включен proxy-arp на обоих интерфейсах. Сейчас нарисую схемы.
  8. Здравствуйте! История такая: Провайдер предоставляет диапазон внешних адресов 83.xxx.yyy.129-254. Было: 2 маршрутизатора на Debian: Провайдер(83.xxx.yyy.254/30) -> <- (83.xxx.yyy.253/30 proxy-arp) -(наруж.инт.) Маршрутизатор_1(Debian)(внут.инт.) - (83.xxx.yyy.250/128 proxy-arp) -> Свитч TrendNet TrendNet "собирает" весь диапазон внешних адресов, предоставляемый провайдером. Далее: TrendNet <- 83.xxx.yyy.168/128(наруж.инт) - Маршрутизатор_2(Debian) - (внут.инт.) - NAT, DHCP(192.168.0.0/24) -> Свитч D-Link внутренней локальной сети. TrendNet -> остальные порты для подключения других внешних ip. Всё прекрасно работает. Появился Mikrotik Cloud Core CCR 1036, требуется скоммутировать всё на него и избавиться от двух шумных маршрутизаторов. Что получилось(По портам микротика), действия по порядку: Eth1 -> Подключен к проводу провайдера, с адресом 83.xxx.yyy.253, на интерфейсе включен Pxoxy-arp; Eth2 -> Подключен в свитч TrendNet, адрес порта 83.xxx.yyy.250, на интерфейсе включен Proxy-arp; - Должен являться шлюзом внешних адресов что сидят на TrendNet. Вбит маршрут Dst: 0.0.0.0/0 на шлюз провайдера 83.xxx.yyy.254; Внешние адреса прекрасно заработали, подключая устройства к TrendNet. Далее, требуется обеспечить выход локальной сети во внешку под адресом 83.xxx.yyy.168. Так как документации по поводу виртуальных интерфейсов мало, было придумано так: Eth3 -> Подключен в свитч TrendNet, присвоен адрес 83.xxx.yyy.168. Eth4 -> Подключен в свитч D-Link локальной сети, поднят DHCP 192.168.0.0/24. Всё прекрасно завелось, клиенты локалки получают адреса, надо настроить NAT. Делаем: IP->Firewall->NAT: src: 192.168.0.0/24 Out-Interface: Eth3, Action:masquarade. В итоге не работает, клиенты локальной сети видят 168 адрес, 250 и 253, но 254(шлюз провайдера нет!). Но, если поменять Out-Interface на Eth1, то клиенты локалки спокойно выходят в интернет, но под адресом 83.xxx.yyy.253 (при требуемом 168-м). Кажется что каких то маршрутов я не дописал, вроде на пути истинном. В чём ошибка и как можно реализовать такую схему на микротике?
  9. Страница предупреждения

    из за NAT не получиться вытащить никак. Схема на самом деле сложнее Интернет <-> Основной маршрутизатор <-> Маршрутизатор 1 <-> Маршрутизатор 2 <-> Маршрутизатор 3 На каждом маршрутизаторе висит по сетке. Всё за NAT'ом. Итого 4 сети изолированных друг от друга но с доступом в инет. Изменить или вытащить из NAT уже проблема. Видимо с такой схемой задача не решаема? Хотя основной маршрутизатор отправляет же пакеты обратно клиентам? Он же сортирует их как то. За что ещё можно зацепиться? Подобная схема в Московском метро работает. Нажал "авторизоваться" и пользуешься.
  10. Страница предупреждения

    Возможно ли это сделать по MAC? Маршрутизатор не один же. Как определять пользователей? Тоесть PHP на web сервере по нажатию ссылки "видел" запишет в iptables нужные данные? или какой скрипт? Другая подсеть находиться на NAT'ом просто. По ip не вариант.
  11. Здравствуйте! Надеюсь написал в том разделе. Задача - сделать разовую страничку предупреждения(объявления) для пользователей в сети. (Должна показаться пользователю 1 раз). Железки: Интернет <-> (основной маршрутизатор Debian)<-> Сеть 192.168.0.0/24 <-> ещё маршрутизатор(Debian) <-> сеть 192.168.1.0/24 Имеются 2 сети, 2 маршрутизатора: основной(с одной сеткой), к нему подключен другой маршрутизатор (со второй сеткой). Все пользователи благополучно пользуются интернетом. Появилась необходимость показать пользователю страничку с объявлением(1 раз на 1 пользователя), когда он пытается открыть любой сайт. Подскажите в какую сторону копать на основном маршрутизаторе. как отсеивать пользователей кто видел эту страницу, а кто нет? Возможно ли это сделать через iptables. Или проще поднять squid(если там есть такое).
  12. Mikrotik RB2011UiAS-2HnD

    Здравствуйте! Проблема с открытием страниц из гостевой сети. пинг и трейс есть, но в браузере тишина. Конфиг роутера: /interface bridge add name=bridge1 add name=bridge2 /interface wireless set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=auto hide-ssid=yes l2mtu=2290 mode=ap-bridge ssid=MikroTikTest wireless-protocol=802.11 add disabled=no l2mtu=2290 mac-address=4E:5E:0C:B8:91:5F master-interface=wlan1 name=wlan2 ssid=INBITest wds-cost-range=0 wds-default-bridge=bridge1 wds-default-cost=0 \ wds-mode=dynamic /interface wireless security-profiles set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys wpa2-pre-shared-key=12345 add authentication-types=wpa2-psk eap-methods="" management-protection=allowed mode=dynamic-keys name=Guests supplicant-identity="" wpa2-pre-shared-key=12345 /interface wireless add disabled=no l2mtu=2290 mac-address=4E:5E:0C:B8:91:60 master-interface=wlan1 name=wlan3 security-profile=Guests ssid=INBI_Guest wds-cost-range=0 wds-default-bridge=\ bridge2 wds-default-cost=0 wds-mode=dynamic /ip pool add name=dhcp_pool1 ranges=192.168.50.2-192.168.50.254 /ip dhcp-server add address-pool=dhcp_pool1 disabled=no interface=bridge2 lease-time=3d name=dhcp1 /port set 0 name=serial0 /interface bridge port add bridge=bridge1 interface=sfp1 add bridge=bridge1 interface=ether1 add bridge=bridge1 interface=ether2 add bridge=bridge1 interface=ether3 add bridge=bridge1 interface=ether4 add bridge=bridge1 interface=ether5 add bridge=bridge1 interface=ether6 add bridge=bridge1 interface=ether7 add bridge=bridge1 interface=ether8 add bridge=bridge1 interface=ether9 add bridge=bridge1 interface=ether10 add bridge=bridge1 interface=wlan2 add bridge=bridge2 interface=wlan3 /ip address add address=192.168.0.19/24 interface=bridge1 network=192.168.0.0 add address=192.168.50.1/24 interface=bridge2 network=192.168.50.0 /ip dhcp-server network add address=192.168.50.0/24 dns-server=192.168.50.1 gateway=192.168.50.1 /ip dns set allow-remote-requests=yes servers=192.168.0.250 /ip firewall filter add chain=forward /ip firewall nat add action=masquerade chain=srcnat out-interface=bridge1 src-address=192.168.50.0/24 /ip route add distance=1 gateway=192.168.0.1 -------------------------------------------------------------------------------------------------- Основная сеть 192.168.0.0/24 gateway 192.168.0.1 dns 192.168.0.250, dhcp 192.168.0.251. Микротик подключен портом Eth1 к основной сети. Адрес Eth1 (IP > Adresses) 192.168.0.19. Создан bridge1 - с портами wlan2-Eth1-Eth10. DHCP выключен. Настроены DNS - IP > DNS - 192.168.0.250. Проводами и подключением к wlan2 - полёт нормальный, клиенты получают адреса из диапазона 192.168.0.0/24. Создана гостевая сеть wlan3, для неё отдельный bridge2. bridge2 - IP > Adresses - 192.168.50.1. Настроен DHCP. Клиент подключается, получает IP, всё норм. Настроены правила: /ip firewall nat add action=masquerade chain=srcnat src-address=192.168.50.0/24 to-addresses=0.0.0.0 /ip route add distance=1 gateway=192.168.0.1 Трейс и пинг у клиентов есть, но в браузере странички не открываются. Все пляски с NAT ничем не закончились. Кто нибудь может помочь? Прошивка микротика 6.25.
  13. Гостевая сеть

    Здравствуйте! Конфигурация дефолтовая. Роутер Mikrotik RB2011UiAS-2HnD. 2м портом(DHCP сервер выключен) подключен к основной сети 192.168.0.0/24 - всё работает. Создаю VirtualAP(10.5.50.1) с DHCP сервером (10.5.50.0/24), клиенты подключаются, получают IP но интернета нет. Как правильно настроить гостевую AP для доступа в интернет через второй порт роутера? Чтобы сеть 192.168.0.0/24 они не видели?