Перейти к содержимому
Калькуляторы

conrad

Пользователи
  • Публикации

    55
  • Зарегистрирован

  • Посещение

О conrad

  • Звание
    Абитуриент
  1. Запрос пароля происходит в любом случае... и в суппорте микротика ответили что через скрипт к сожалению пока это не реализовать, обещали поправить в ближайших релизах routerOS.
  2. Всем доброго времени суток! Необходимо сделать скрипт для обновления RouterOS используя в качестве репозитория другой mikrotik. Содержание скрипта следующее: :local ip x.x.x.x :local x [/system upgrade upgrade-package-source get number=[find where address=$ip]] :if ( [:len $x] < 0 ) do={ /system upgrade upgrade-package-source add user=update address=$ip password } /system upgrade refresh /system upgrade download-all reboot-after-download=yes download-beta=no Проблема в том что команда /system upgrade upgrade-package-source add user=update address=$ip не имеет аргумента password и пароль всегда запрашивается в интерактивном режиме. Возможно ли как то передать пароль из скрипта? Заранее благодарю за ответ!
  3. Только для туннеля между микротиком и сервером доступа, клиенты через этот туннель в мир не выходят.
  4. Всем доброго времени суток! Появилась задача в личном кабинете хотспота в качестве которого используется mikrotik отображать информацию о количестве трафика для каждого пользователя хотспота. Для снятия статистики с mikrotik пробуем использовать netflow, в качестве коллектора тестируем nfcapd. Подскажите пожалуйста, как определять уникальных пользователей, при условии что ip адреса выдаваемые клиентам хотспота динамические? Заранее благодарю за ответ!
  5. Виснет MPD

    DJ Conrad? Лепс? Подольск? Неа.. Просто Conrad, Лепса не слушаю. Ташкент.
  6. Виснет MPD

    Выкинул часть пользователей с проблемного браса (umtxn после 1.8к пользователей) на другой брас аналогичной конфигурации (и по железу и по софту), так второй брас начал заваливаться каждые сутки с той же проблемой но уже при количестве сессий ~500 Попробовал последовать сообщению dadv - обновился с 10.3-release до stable и обновил mpd до 5.8_2, пока ничего не патчил. Второй брас живет уже 3 день, подожду еще чуть и если все ок то проделаю те же действия с первым брасом. Всем спасибо за советы.
  7. Виснет MPD

    Наоборот, выключен.
  8. Виснет MPD

    ну чё... запинговать локалхост до смерти тоже ведь "траффик" ТС, а покажите конфигу мпд. У меня в своё время грабли были из-за нетфлоу... startup: # enable TCP-Wrapper (hosts_access(5)) to block unfriendly clients #set global enable tcp-wrapper # configure the console old way set user xxxxxx xxxxx xxxxxx set console self 10.17.0.100 5005 set console open # Radius CoA/PoD set radsrv peer xxxxx xxxxxxx set radsrv self 10.17.0.100 3799 set radsrv open default: # load pptp_server load pppoe_server load /usr/local/etc/mpd5/filters.conf filters pppoe_server: create bundle template B set iface idle 0 set iface enable tcpmssfix proxy-arp set ipcp no vjcomp set ipcp ranges 10.17.0.100 ippool pool1 set ipcp dns 10.17.0.100 ### PPPOE on igb1 create link template L pppoe set link action bundle B set pppoe acname "bras1" set pppoe iface igb1 set pppoe service "*" set pppoe mac-format unix-like load server_common ### PPPOE on vlan2 create link template L1 pppoe set link action bundle B set pppoe acname "bras1" set pppoe iface vlan2 set pppoe service "*" set pppoe mac-format unix-like load server_common ### PPPOE on vlan3 create link template L2 pppoe set link action bundle B set pppoe acname "bras1" set pppoe iface vlan3 set pppoe service "*" set pppoe mac-format unix-like load server_common server_common: set link no pap eap set link yes chap-md5 set link keep-alive 20 60 set link enable incoming set link no acfcomp protocomp load radius radius: set radius server xxxxxx xxxxxx 1812 1813 set radius config /etc/radius.conf set radius retries 3 set radius timeout 60 set auth acct-update 300 set auth enable radius-auth set auth enable radius-acct set auth disable internal Влан интерфейсов в конфиге больше, не стал выводить все, конфигурация на них аналогичная. Netflow на BRAS-е нет, он на линуховом гейте.
  9. Виснет MPD

    ИМХО, уже многовато. Как первое, так и второе. "Священное число" - 70%.. Во всяком случае, в плане трафика. У себя в такой ситуации запускаю 2..3...и т.д. NAS. Если машины более-менее одинаковые по железу/памяти, то нагрузка на каждую распределяется вполне ровно. А PPPoE вроде как и теоретически не раскидать по ядрам, т.к. L2. Может и ошибаюсь, но где-то об этом читал.. Логирование mpd выключено, так как даже на 1к сессий лог будет расти с космической скоростью. Отключен давно, так как хорошо грузил проц. Снимаю стату по трафику с порту коммутатора к которому подключен брас. А это ?И ещё - NAT на NAS-е есть, или вынесен? Если есть, то могут быть и его "плоды". У меня почему-то NAT FreeBSD (ipfw) так и "не получился". Вынес на машину с CentOS и забыл. P.S. А CPU Load?? NATа на NAS-е нет, он на линуксе, CPU не снимаю и думаю что его можно снимать не только с помощью snmp но и каких то скриптов которые парсят значения с top.
  10. Виснет MPD

    bind прибит к интерфейсам (listen-on { 127.0.0.1; 10.17.0.100; };) неужели все равно будет дергать другие интерфейсы? Отключен давно, так как хорошо грузил проц. Снимаю стату по трафику с порта коммутатора к которому подключен брас.
  11. Виснет MPD

    Это маршрутизируемого трафика вообще никак не касается. Спасибо, попробую.. А что скажете на счет этого? Говорят на 9.3 проблемы нет..
  12. Всем доброго времени суток! Имеется сервер Dell C6100 в качестве PPPoE браса, две головы Intel® Xeon® CPU L5630 2.13GHz, двух портовая интеловская карточка на чипсете 82576 (драйвер igb), на сервере установлены: FreeBSD 10.3-RELEASE, MPD version 5.8, BIND 9.9.9-P, HT отключен. Из тюнинга: /boot/loader.conf hw.igb.rxd=4096 hw.igb.txd=4096 hw.igb.max_interrupt_rate=32000 net.isr.defaultqlimit=4096 net.link.ifqmaxlen=10240 kern.maxusers=2048 net.add_addr_allfibs=0 /etc/sysctl.conf dev.igb.0.rx_processing_limit=4096 dev.igb.1.rx_processing_limit=4096 net.inet.ip.fastforwarding=1 net.inet.tcp.blackhole=2 net.inet.udp.blackhole=0 net.inet.icmp.icmplim=500 kern.ipc.soacceptqueue=1024 net.graph.recvspace=8388608 net.graph.maxdgram=8388608 kern.ipc.maxsockbuf=20971520 net.inet.ip.intr_queue_maxlen=8192 net.inet.tcp.recvbuf_auto=0 net.inet.tcp.sendbuf_auto=0 hw.igb.enable_aim=0 net.inet.tcp.sendspace=131072 net.inet.tcp.tso=0 CPU 0: 0.0% user, 0.0% nice, 0.8% system, 61.0% interrupt, 38.2% idle CPU 1: 1.2% user, 0.0% nice, 0.4% system, 7.1% interrupt, 91.3% idle CPU 2: 0.8% user, 0.0% nice, 0.0% system, 6.3% interrupt, 92.9% idle CPU 3: 0.4% user, 0.0% nice, 0.4% system, 8.7% interrupt, 90.6% idle CPU 4: 2.0% user, 0.0% nice, 0.4% system, 9.4% interrupt, 88.2% idle CPU 5: 3.1% user, 0.0% nice, 0.0% system, 11.4% interrupt, 85.4% idle CPU 6: 0.8% user, 0.0% nice, 0.8% system, 10.6% interrupt, 87.8% idle CPU 7: 0.4% user, 0.0% nice, 0.8% system, 9.4% interrupt, 89.4% idle Проблема заключается в том что как только число онлайн PPPoE сессий приблизилось к 2к(трафик в пике 700mbit/200mbit) брас стал ежедневно падать, в статусе процесса mpd наблюдаю umtxn. Подскажите пожалуйста, можно ли как то поправить ситуацию? Заранее благодарю за ответ. P.S.: Пробовал раскидывать прерывания от карточек по ядрам, толку нет. Очень сильно грузит ядро прерывание которое обслуживает нулевую очередь порта на котором поднимаются туннели(ядро 0 в показателях выше).
  13. Всем доброго времени суток. После проблем с питанием, softraid уровня 1 из двух дисков на FreeBSD перешел в состояние DEGRADE и один из дисков начал синхронизацию с другим. На сервере есть mysql и freeradius, проблема заключается в том что спустя некоторое время после начала синхронизации количество запросов в очереди mysql резко увеличивается (show processlist) и СУБД просто входит в ступор, радиус сервер соответственно тоже. Подскажите пожалуйста, возможно ли как то снизить скорость ресинхронизации, а может есть какие то другие варианты решения проблемы? Заранее благодарю за ответ! P.S.: FreeBSD 10.3-RELEASE
  14. Всем доброго времени суток! Имеется сервер с debian jessie 8.6, на нем установлен qemu-kvm из репозитория (версия 2.1). Для более рационального использования места под бекап жестких дисков виртуальных машин решили перейти с raw на qcow2, но после конвертации с помощью команды qemu-img convert -p -f raw -O qcow2 hdd.img ./hdd.qcow виртуалка перестает загружаться выдавая при старте следующее: error: file '/boot/grub/i386-pc/normal.mod' not found. Entering rescue mode... Подскажите пожалуйста в чем может быть проблема? Заранее благодарю.