Добрый день! Обгуглил все что мог, но так и не смог найти ответа.

 

Есть сеть в которой гуляет Мультикаст по PIM-SM. Появился стык с другим провайдером, которому надо отдать некоторые группы по MBGP+MSDP.

 

sh ver:

Cisco Internetwork Operating System Software 
IOS (tm) s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(18)SXD6, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 17-Aug-05 18:13 by evmiller
Image text-base: 0x4002100C, data-base: 0x42320000

ROM: System Bootstrap, Version 12.2(17r)S2, RELEASE SOFTWARE (fc1)
BOOTLDR: s72033_rp Software (s72033_rp-PK9SV-M), Version 12.2(18)SXD6, RELEASE SOFTWARE (fc1)

7609-Belyaevo uptime is 2 years, 3 days, 3 hours, 39 minutes
Time since 7609-Belyaevo switched to active is 2 years, 3 days, 3 hours, 46 minutes
System returned to ROM by error - a Software forced crash, PC 0x40381020 at 12:27:55 MSK Thu Sep 11 2008 (SP by power-on)
System restarted at 12:35:02 MSK Thu Sep 11 2008
System image file is "disk0:/s72033-pk9sv-mz.122-18.SXD6.bin"

 

Настройки:

neighbor 95.90.1.1 remote-as 6434
neighbor 95.90.1.1 version 4
!
address-family ipv4
no neighbor 195.90.129.110 activate
exit-address-family
!
address-family ipv4 multicast
neighbor 95.90.1.1 activate
no auto-summary
exit-address-family

ip msdp peer 95.90.1.1 remote-as 6434
ip msdp cache-sa-state

interface Vlan4060
mtu 9216
ip address 95.90.1.2 255.255.255.252
ip pim bsr-border
ip pim sparse-dense-mode

 

Проверка:

sh ip msdp peer 95.90.1.1 ad
Not an RP for any group nor an MSDP border

MSDP SA advertised to peer 95.90.1.1 (?) from SA cache

 

Если стыковаться на железке, где принимаем по MSDP от другого провайдера, то это отдается, а то что гуляет у нас по сети ни в какую не хочет.

 

Mroute:

sh ip mro
IP Multicast Routing Table

(*, 233.6.7.1), 06:29:46/00:03:28, RP 95.90.1.4, flags: S
  Incoming interface: Vlan4092, RPF nbr 1.1.1.1, RPF-MFD
  Outgoing interface list:
    Vlan4091, Forward/Sparse-Dense, 06:27:04/00:03:28, H

(4.3.3.5, 233.6.7.1), 06:29:37/00:03:29, flags: T
  Incoming interface: Vlan4092, RPF nbr 1.1.1.1, RPF-MFD
  Outgoing interface list:
    Vlan4091, Forward/Sparse-Dense, 06:27:04/00:03:28, H

 

Смотрел в сторону ip msdp border, но ее у нас на железке нет...

 

 

Подскажите в какую сторону посмотреть... уже не знаю что делать :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
interface Vlan4060

mtu 9216

ip address 95.90.1.2 255.255.255.252

ip pim bsr-border

ip pim sparse-dense-mode

Включить надо sparse-mode и отключить bsr-border.

mtu осознанно такое сделано?

 

address-family ipv4

no neighbor 95.90.1.1 activate

 

Сессии mbgp, msdp, pim поднялись?

sh ip msdp sa-cache

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Включить надо sparse-mode и отключить bsr-border.
Сделано.

 

mtu осознанно такое сделано?
Железо позволяет с обеих сторон - просто было настроено по дефолту.

 

address-family ipv4

no neighbor 95.90.1.1 activate

 

Сессии mbgp, msdp, pim поднялись?

sh ip msdp sa-cache

 

sh ip bgp ipv4 multicast n 95.90.1.1
BGP neighbor is 95.90.1.1,  remote AS 6434, internal link
  BGP version 4, remote router ID 95.90.1.1
  BGP state = Established, up for 02:01:46
  Last read 00:00:46, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Address family IPv4 Multicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                0          0
    Keepalives:           124        124
    Route Refresh:          0          0
    Total:                125        125
  Default minimum time between advertisement runs is 5 seconds

 

sh ip msdp peer 
MSDP Peer 95.90.1.1 (?), AS 6434 (configured AS)
Description: 
  Connection status:
    State: Up, Resets: 0, Connection source: none configured
    Uptime(Downtime): 00:21:28, Messages sent/received: 23/24
    Output messages discarded: 0
    Connection and counters cleared 00:21:32 ago
  SA Filtering:
    Input (S,G) filter: none, route-map: none
    Input RP filter: none, route-map: none
    Output (S,G) filter: none, route-map: none
    Output RP filter: none, route-map: none
  SA-Requests: 
    Input filter: none
    Sending SA-Requests to peer: disabled
  Peer ttl threshold: 0
  SAs learned from this peer: 0
  Input queue size: 0, Output queue size: 0

 

sh ip pim n
PIM Neighbor Table

95.90.1.1    Vlan4060                 01:23:52/00:01:30 v2    1 / DR S

 

sh ip msdp sa-cache
MSDP Source-Active Cache - 0 entries

Изменено пользователем Grey666

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Мультикаст вы принимаете на другом роутере? Тогда нужно настроить msdp и mbgp между этим роутером и тем что принимает мультикаст.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Мультикаст вы принимаете на другом роутере? Тогда нужно настроить msdp и mbgp между этим роутером и тем что принимает мультикаст.
Да на другом, но откуда ему знать где этот мультикаст зарождается? Он также приходит откуда-то по PIM. А если это трафик прилетающий от другого провайдера?

Как вообще первоначально выглядит запихивание маршрутов в MSDP?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Мультикаст вы принимаете на другом роутере? Тогда нужно настроить msdp и mbgp между этим роутером и тем что принимает мультикаст.
Да на другом, но откуда ему знать где этот мультикаст зарождается? Он также приходит откуда-то по PIM. А если это трафик прилетающий от другого провайдера?

Как вообще первоначально выглядит запихивание маршрутов в MSDP?

Маршруты попадают в msdp из pim-rp. C того роутера, который является у вас rp, вам нужно поднять MSDP с роутером с которого вы будете отдавать мультикаст.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Мультикаст вы принимаете на другом роутере? Тогда нужно настроить msdp и mbgp между этим роутером и тем что принимает мультикаст.
Да на другом, но откуда ему знать где этот мультикаст зарождается? Он также приходит откуда-то по PIM. А если это трафик прилетающий от другого провайдера?

Как вообще первоначально выглядит запихивание маршрутов в MSDP?

Маршруты попадают в msdp из pim-rp. C того роутера, который является у вас rp, вам нужно поднять MSDP с роутером с которого вы будете отдавать мультикаст.

Не очень нравится такая схема :( MSDP на сети не используем, а количество подключаемых групп скоро будет сильно расти. Не хочется поднимать фул-меш MSDP на всем кольце.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Фулл-меш не надо. MSDP может работать через L3, как multihop bgp.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В продолжении темы. Схема такая:

 

7609 N1 - 7609 N2 - 7609 N3 - 7609 N4 - 7609 N5 - 7609 N6

 

Между N1 и N6 поднят MBGP, маршруты летают. Можно ли поднять MSDP между ними напрямую, а не последовательно каждый со следующим?

 

Сейчас ситуация такова:

sh ip msdp peer 
MSDP Peer 21.5.14.12 (?), AS 6434 (configured AS)
Description: 
  Connection status:
    State: Down, Resets: 0, Connection source: none configured
    Uptime(Downtime): 00:09:18, Messages sent/received: 0/0
    Output messages discarded: 0
    Connection and counters cleared 00:09:18 ago

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В дебаге с обеих сторон видно следующее:

MSDP(0): 21.5.14.12: Sending TCP connect
MSDP(0): 21.5.14.12: TCP connection reset

 

Проблема решилась указанием

connect-source Loopback0

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Такая же засада. На кошке принимаем по msdp+mbgp от двух провайдеров мультикаст, отдаем его же третьему так же по msdp+mbgp (downlink). Но есть еще dgs3620, в который воткнуты стримеры, так вот как этот мультикаст отдать downlink-у? циска и длинк соединены по pim.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Такая же засада. На кошке принимаем по msdp+mbgp от двух провайдеров мультикаст, отдаем его же третьему так же по msdp+mbgp (downlink). Но есть еще dgs3620, в который воткнуты стримеры, так вот как этот мультикаст отдать downlink-у? циска и длинк соединены по pim.

На dgs3620 указан ип Rendezvous Points?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Вы комментируете как гость. Если у вас есть аккаунт, пожалуйста, войдите
Ответить в этой теме...

×   Вы вставили контент с форматированием.   Удалить форматирование

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

Подписчики 0