Добрый день,

 

Тестирую SNR S2980G, в качестве QinQ на LAG (port-group)+DHCP-relay+super-vlan. Текущая версия ПО 7.0.3.1(R0058.0002).

Схема тестирования следующая:

 

BRAS(cvlan 51)----/port-group100/----SNR S2980G(qinq 51:4033)----/port-group110/----CORE-SW---AGGR-SW(qinq 4033:51)---client(vlan 51)

 

port-group100 смотрит в БРАС(downlink), port-group110 смотрит в CORE-SW(uplink).

Когда из схемы тестирования исключаю SNR (и соотв-но, добавляю qinq на БРАСе), все отрабатывается корректно, клиент получает адрес по DHCP,натится, выходит в паблик.

Когда в схеме с SNR, подозрение, что не работает qinq в ЛАГе, на коммутаторе SNR.

Текущая конфигурация коммутатора SNR, прошу прокомментировать возможные ошибки в моей конфигурации. Заранее спасибо!

 

NR-S2980G-24F#show running-config

!

no service password-encryption

!

hostname SNR-S2980G-24F

!

username admin privilege 15 password 0 admin

!

authentication line console login local

!

!

!

!

service dhcp

!

ip forward-protocol udp bootps

!

!

!

!

!

!

mtu 1600

!

!

vlan 1;3-60;1508;4033

!

vlan 1601

name *CORE1---BRAS_SE100_test*

!

vlan 100

supervlan

subvlan 51-52

!

class-map dot1q1

match vlan range 51-52

!

policy-map dot1q1

class dot1q1

add s-vid 4033

exit

!

port-group 100

!

port-group 110

!

Interface Ethernet1/0/1

!

Interface Ethernet1/0/2

!

Interface Ethernet1/0/3

!

Interface Ethernet1/0/4

!

Interface Ethernet1/0/5

!

Interface Ethernet1/0/6

!

Interface Ethernet1/0/7

!

Interface Ethernet1/0/8

!

Interface Ethernet1/0/9

!

Interface Ethernet1/0/10

!

Interface Ethernet1/0/11

!

Interface Ethernet1/0/12

!

Interface Ethernet1/0/13

media-type copper

service-policy input dot1q1

switchport mode hybrid

switchport hybrid allowed vlan 51-52;1508;1601 tag

switchport hybrid allowed vlan 4033 untag

port-group 100 mode on

!

Interface Ethernet1/0/14

media-type copper

service-policy input dot1q1

switchport mode hybrid

switchport hybrid allowed vlan 51-52;1508;1601 tag

switchport hybrid allowed vlan 4033 untag

port-group 100 mode on

!

Interface Ethernet1/0/15

media-type copper

service-policy input dot1q1

switchport mode hybrid

switchport hybrid allowed vlan 51-52;1508;1601 tag

switchport hybrid allowed vlan 4033 untag

port-group 100 mode on

!

Interface Ethernet1/0/16

media-type copper

service-policy input dot1q1

switchport mode hybrid

switchport hybrid allowed vlan 51-52;1508;1601 tag

switchport hybrid allowed vlan 4033 untag

port-group 100 mode on

!

Interface Ethernet1/0/17

media-type copper

service-policy input dot1q1

switchport mode hybrid

switchport hybrid allowed vlan 51-52;1508;1601 tag

switchport hybrid allowed vlan 4033 untag

port-group 100 mode on

!

Interface Ethernet1/0/18

media-type copper

service-policy input dot1q1

switchport mode hybrid

switchport hybrid allowed vlan 51-52;1508;1601 tag

switchport hybrid allowed vlan 4033 untag

port-group 100 mode on

!

Interface Ethernet1/0/19

media-type copper

switchport mode hybrid

switchport hybrid allowed vlan 1508;1601;4033 tag

port-group 110 mode on

!

Interface Ethernet1/0/20

media-type copper

switchport mode hybrid

switchport hybrid allowed vlan 1508;1601;4033 tag

port-group 110 mode on

!

Interface Ethernet1/0/21

media-type copper

switchport mode hybrid

switchport hybrid allowed vlan 1508;1601;4033 tag

port-group 110 mode on

!

Interface Ethernet1/0/22

media-type copper

switchport mode hybrid

switchport hybrid allowed vlan 1508;1601;4033 tag

port-group 110 mode on

!

Interface Ethernet1/0/23

media-type copper

switchport mode hybrid

switchport hybrid allowed vlan 1508;1601;4033 tag

port-group 110 mode on

!

Interface Ethernet1/0/24

media-type copper

switchport mode hybrid

switchport hybrid allowed vlan 1508;1601;4033 tag

port-group 110 mode on

!

Interface Port-Channel100

description *to BRAS_SE100_test*

!

Interface Port-Channel110

description *to CORE1-xxx*

!

interface Vlan100

ip address 10.190.0.1 255.255.0.0

!forward protocol udp 67(active)!

ip helper-address 10.190.255.254

!

interface Loopback1

ip address 172.29.0.105 255.255.255.255

!

!

no login

!

end

 

SNR-S2980G-24F#

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

vashucashu, добрый!

Извините за задержку с ответом. Действительно, на ранних версиях ПО имела место подобная проблема. Передал информацию R&D для доработки ПО SNR-S2980G-24F.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Понятно, спасибо за комментарии.

Сейчас на 2990g создал конфигурацию selective QinQ на ЛАГе, остальная часть конфигурации, как для 2980 (в старте данной темы):

Interface Ethernet1/0/21
 media-type copper
 dot1q-tunnel selective s-vlan 4033 c-vlan 51-52
 switchport mode hybrid
 switchport hybrid allowed vlan 51-52;99;1508;1601 tag
 switchport hybrid allowed vlan 4033 untag
 port-group 100 mode on
!
Interface Ethernet1/0/22
 media-type copper
 dot1q-tunnel selective s-vlan 4033 c-vlan 51-52
 switchport mode hybrid
 switchport hybrid allowed vlan 51-52;99;1508;1601 tag
 switchport hybrid allowed vlan 4033 untag
 port-group 100 mode on

 

Есть ощущение, что selective QinQ на 2990 в ЛАГе также не работает. Текущая версия ПО 2990g: 7.0.3.5(R0102.0100).

Виктор, можете прокомментировать..? Заранее благодарю!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, Victor Tkachenko сказал:

vashucashu, необходимо обновить ПО. Архив с рекомендуемой для S2990G версией ПО здесь.

Спасибо, в ближайшее время отпишусь..

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Обновился до версии 7.0.3.5(R0102.0239) + бутром до версии 7.1.41.

 

SNR-S2990G-24FX#sh ver
  SNR-S2990G-24FX Device, Compiled on Aug 24 14:22:05 2017
  sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
  CPU Mac f8:f0:82:75:8b:33
  Vlan MAC f8:f0:82:75:8b:32
  SoftWare Version 7.0.3.5(R0102.0239)
  BootRom Version 7.1.41

 

В конфиге изменил тип конфигурирования selective QinQ на вариант с полиси (на ЛАГ коммутатор не дал повесить service policy, пришлось разбирать ЛАГ, добавлять на каждом из интерфейсов, потом снова объединил в ЛАГ). Но опять есть подозрение, что selective QinQ не отрабатывает.

Последний конфиг прилагаю в спойлере. Заранее спасибо за содействие!

 

Спойлер

 

SNR-S2990G-24FX#sho run
!
no service password-encryption
!
hostname SNR-S2990G-24FX
sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
sysContact support@nag.ru
!
authentication logging enable
!
username admin privilege 15 password 0 admin
username test privilege 15 password 0 test
!
authentication line console login local
!
!
!
!
!
service dhcp
!
ip forward-protocol udp bootps
ip dhcp relay share-vlan 101 sub-vlan 51-52
!
!
ip dhcp snooping enable
ip dhcp snooping vlan 51-52;101
 ip dhcp snooping binding enable
!
!
!
!
!
!
!
Interface Ethernet0
!
!
!
vlan 1;51-52;98-99;1508;1601;4033
!
vlan 101
 supervlan
 subvlan 51-52
!         
class-map qinq1
 match vlan 51 52
!
policy-map qinq1
 class qinq1
 add s-vid 4033
 exit
!
port-group 100
!
port-group 120
!
Interface Ethernet1/0/1
!
Interface Ethernet1/0/2
!
Interface Ethernet1/0/3
!
Interface Ethernet1/0/4
!
Interface Ethernet1/0/5
!
Interface Ethernet1/0/6
!
Interface Ethernet1/0/7
!
Interface Ethernet1/0/8
!
Interface Ethernet1/0/9
!
Interface Ethernet1/0/10
!
Interface Ethernet1/0/11
!
Interface Ethernet1/0/12
!
Interface Ethernet1/0/13
!
Interface Ethernet1/0/14
!
Interface Ethernet1/0/15
!
Interface Ethernet1/0/16
!         
Interface Ethernet1/0/17
!
Interface Ethernet1/0/18
!
Interface Ethernet1/0/19
!
Interface Ethernet1/0/20
!
Interface Ethernet1/0/21
 media-type copper
 description *LAG to CORE1-SW*
 service-policy input qinq1
 switchport mode hybrid
 switchport hybrid allowed vlan 99;1508;1601 tag
 switchport hybrid allowed vlan 4033 untag
 port-group 100 mode on
!
Interface Ethernet1/0/22
 media-type copper
 description *LAG to CORE-SW*
 service-policy input qinq1
 switchport mode hybrid
 switchport hybrid allowed vlan 99;1508;1601 tag
 switchport hybrid allowed vlan 4033 untag
 port-group 100 mode on
!
Interface Ethernet1/0/23
 media-type copper
 description *LAG to BRAS*
 switchport mode trunk
 switchport trunk allowed vlan 51-52;99;1508;1601
 port-group 120 mode on
!
Interface Ethernet1/0/24
 media-type copper
 description *LAG to BRAS*
 switchport mode trunk
 switchport trunk allowed vlan 51-52;99;1508;1601
 port-group 120 mode on
!
Interface Ethernet1/0/25
!
Interface Ethernet1/0/26
!         
Interface Ethernet1/0/27
!
Interface Ethernet1/0/28
!
Interface Port-Channel100
!
Interface Port-Channel120
 ip dhcp snooping trust
!
interface Vlan98
 ip address 192.168.7.9 255.255.255.252
!
interface Vlan99
 ip address 192.168.8.10 255.255.255.252
!
interface Vlan101
 arp-proxy subvlan all
 ip address 10.190.0.1 255.255.0.0
!
ip route 0.0.0.0/0 192.168.8.9
ip route 10.190.255.254/32 192.168.8.9
ip route 172.29.0.106/32 172.29.0.104
!
!
no login
!
!
captive-portal
!
end

SNR-S2990G-24FX#    

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, Victor Tkachenko сказал:

vashucashu, вместо service-policy воспользуйтесь функционалом dot1q-tunnel selective.

Насколько я понял из "мурзилки" (https://shop.nag.ru/article/snr_switch_qinq_selective_qinq) service-policy это функционал альтернативный конфигурированию через dot1q-tunnel selective.

И по логике, оба этих варианта должны отрабатываться коммутатором.

 

Ок, я сконфигурировал согласно Вашим рекомендациям, используя dot1q-tunnel selective на ЛАГе, вместо service-policy (в спойлере ниже). Какого-то реального эффекта это не принесло. Проблема осталась.

На ваших тестовых стендах, selective QinQ на ЛАГе как отрабатывается..? прошу комментировать, заранее спасибо.
 

Спойлер

 

SNR-S2990G-24FX#sho run
!
no service password-encryption
!
hostname SNR-S2990G-24FX
sysLocation Building 57/2,Predelnaya st, Ekaterinburg, Russia
sysContact support@nag.ru
!
authentication logging enable
!
username admin privilege 15 password 0 admin
username test privilege 15 password 0 test
!
authentication line console login local
!
!
!
!
!
service dhcp
!
ip forward-protocol udp bootps
ip dhcp relay share-vlan 101 sub-vlan 51-52
!
!
ip dhcp snooping enable
ip dhcp snooping vlan 51-52;101
 ip dhcp snooping binding enable
!
!
!
!
!
!
!
Interface Ethernet0
!
!
!
vlan 1;51-52;98-99;1508;1601;4033
!
vlan 101
 supervlan
 subvlan 51-52
!         
port-group 100
!
port-group 120
!
Interface Ethernet1/0/1
!
Interface Ethernet1/0/2
!
Interface Ethernet1/0/3
!
Interface Ethernet1/0/4
!
Interface Ethernet1/0/5
!
Interface Ethernet1/0/6
!
Interface Ethernet1/0/7
!
Interface Ethernet1/0/8
!
Interface Ethernet1/0/9
!
Interface Ethernet1/0/10
!
Interface Ethernet1/0/11
!
Interface Ethernet1/0/12
!
Interface Ethernet1/0/13
!
Interface Ethernet1/0/14
!
Interface Ethernet1/0/15
!
Interface Ethernet1/0/16
!
Interface Ethernet1/0/17
!
Interface Ethernet1/0/18
!
Interface Ethernet1/0/19
!
Interface Ethernet1/0/20
!         
Interface Ethernet1/0/21
 media-type copper
 description *LAG to CORE1-SW*
 dot1q-tunnel selective s-vlan 4033 c-vlan 51-52
 dot1q-tunnel selective enable
 switchport mode hybrid
 switchport hybrid allowed vlan 99;1508;1601 tag
 switchport hybrid allowed vlan 4033 untag
 port-group 100 mode on
!
Interface Ethernet1/0/22
 media-type copper
 description *LAG to CORE1-SW*
 dot1q-tunnel selective s-vlan 4033 c-vlan 51-52
 dot1q-tunnel selective enable
 switchport mode hybrid
 switchport hybrid allowed vlan 99;1508;1601 tag
 switchport hybrid allowed vlan 4033 untag
 port-group 100 mode on
!
Interface Ethernet1/0/23
 media-type copper
 description *LAG to BRAS*
 switchport mode trunk
 switchport trunk allowed vlan 51-52;99;1508;1601
 port-group 120 mode on
!
Interface Ethernet1/0/24
 media-type copper
 description *LAG to BRAS*
 switchport mode trunk
 switchport trunk allowed vlan 51-52;99;1508;1601
 port-group 120 mode on
!
Interface Ethernet1/0/25
!
Interface Ethernet1/0/26
!
Interface Ethernet1/0/27
!
Interface Ethernet1/0/28
!
Interface Port-Channel100
!         
Interface Port-Channel120
 ip dhcp snooping trust
!
interface Vlan99
 ip address 192.168.8.10 255.255.255.252
!
interface Vlan101
 arp-proxy subvlan all
 ip address 10.190.0.1 255.255.0.0
!
ip route 0.0.0.0/0 192.168.8.9
ip route 10.190.255.254/32 192.168.8.9
ip route 172.29.0.106/32 172.29.0.104
!
!
no login
!
!
captive-portal
!
end

SNR-S2990G-24FX#

 

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

vashucashu, да, selective QinQ в port-group работает.

Примените также команду `mac-address-learning cpu-control` в режиме глобальной конфигурации.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 31.08.2017 в 16:07, Victor Tkachenko сказал:

vashucashu, да, selective QinQ в port-group работает.

Примените также команду `mac-address-learning cpu-control` в режиме глобальной конфигурации.

Добавил рекомендуемую строку в конфигурацию коммутатора, сохранил, перегрузил. Картина не поменялась.

Мак клиента 90-f6-52-dd-8f-fc вижу в c-vlan 4033, как и прежде, на аплинк порт-группе (port-channel100). Но это еще до QinQ:

 

SNR-S2990G-24FX#sho mac-address-table
Read mac address table....
Vlan Mac Address                 Type    Creator   Ports
---- --------------------------- ------- -------------------------------------
51   f8-f0-82-75-8b-32           STATIC  System   CPU
52   f8-f0-82-75-8b-32           STATIC  System   CPU
99   02-03-3e-16-67-17           DYNAMIC Hardware Port-Channel120
99   f8-f0-82-75-8b-32           STATIC  System   CPU
101  f8-f0-82-75-8b-32           STATIC  System   CPU
1508 00-25-9e-96-01-95           DYNAMIC Hardware Port-Channel100
1601 00-25-9e-96-01-95           DYNAMIC Hardware Port-Channel100
1601 02-03-3e-16-67-17           DYNAMIC Hardware Port-Channel120
4033 90-f6-52-dd-8f-fc           DYNAMIC Hardware Port-Channel100
SNR-S2990G-24FX#

 

IP по dhcp не получаю (как видно из сообщения 30.08.2017 - 17:45, 2990 выступает в качестве dhcp-relay).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

vashucashu, пожалуйста, обратитесь к нам в support, к обращению отдельным файлом приложите полный вывод `show tech` с коммутатора.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
48 минут назад, Victor Tkachenko сказал:

vashucashu, пожалуйста, обратитесь к нам в support, к обращению отдельным файлом приложите полный вывод `show tech` с коммутатора.

Оформил обращение [NAG TAC - Обращение #37328], с приложением требуемого файла show tech-support.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Добрый день, vashucashu!

Выложили архив с новой версией ПО для S2980G-24F.

Необходимо обновить ПО коммутатора и пересобрать port-channel, предварительно применив к портам service-policy.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти
Подписчики 0