Jump to content
Калькуляторы

Cisco/ Проблема с multicast

Здравствуйте!

Имеется CISCO 3750G в качестве аггрегатора для мультикаста.

На нее приходит контент с магистрали от провайдера ,так же часть каналов на нее льется с местного РТПЦ. С нее трафик уходит на оборудование кабельного телевидения.

Сейчас нужно с 3750G трафик залить в сеть для предоставления IPTV.

Стык организован между CISCO 3750G (28) и (9)CISCO ME3400

 

interface GigabitEthernet1/0/28

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3049

switchport mode trunk

 

interface GigabitEthernet0/9

description MCAST_to_ME3400

switchport trunk allowed vlan 3049

switchport mode trunk

 

interface Vlan3049 (3750G)

ip address 10.56.133.1 255.255.255.252

ip pim dense-mode

no ip route-cache

 

interface Vlan3049 (ME3400)

ip address 10.56.133.2 255.255.255.252

ip igmp join-group 233.12.144.54

ip pim dense-mode

 

Вышеуказанные интерфейсы пингуют друг друга.

В списке PIM neighbors видят друг друга.

Но на ME3400 мультикаст группы не льются.На 3400 статический джоин на одну из мультикаст групп, но вывод sh ip mroute на 3400 показывает следующее:

(*, 233.12.144.54), 1w4d/00:02:57, RP 10.56.133.1, flags: SJCL

Incoming interface: Vlan3049, RPF nbr 10.56.133.1

Outgoing interface list:

Vlan3048, Forward/Sparse-Dense, 1w4d/00:02:57

 

(*, 224.0.1.40), 1w4d/00:02:55, RP 10.56.133.1, flags: SJPCL

Incoming interface: Vlan3049, RPF nbr 10.56.133.1

Outgoing interface list: Null

 

те только одна запись для группы.

В чем может быть проблема?

Пробовал прописывать RP address ситуация не меняется.

Edited by hijke

Share this post


Link to post
Share on other sites

насколько разобрался до данного момента, то разве не две записи должно быть для каждой группы?

Share this post


Link to post
Share on other sites

Вы сами пытались прочитать ту хуйню, что вы запостили?

Что за отношение такое ... Мне тут надо помочь разобраться, вот какое-то говно в нечитаемом виде...

Вместо ip igmp join-group лучше использовать ip igmp static-group.

Про наличие маршрутов уже писали.

 

Вторая запись появится тогда, когда пойдёт поток ...

Share this post


Link to post
Share on other sites

Поправил первый пост.

В том то и дело что потока нету, в этом то и не могу разобраться никак.

Маршруты пробовал добавлять - не помогло.

C ip igmp static-group тоже ничего не изменилось.

Share this post


Link to post
Share on other sites

А покажите sh ip mroute c 3750G.

У потока TTL, случайно, не единица?

ip multicast-routing включен?

Share this post


Link to post
Share on other sites

sh ip mroute для 233.12.144.54 на 3750G показывает:

(*, 233.12.144.54), 7w0d/stopped, RP 217.150.55.185, flags: SJC

Incoming interface: Vlan91, RPF nbr 192.168.29.1, Mroute

Outgoing interface list:

Vlan5, Forward/Sparse-Dense, 21w0d/00:02:24

 

(89.179.176.202, 233.12.144.54), 3w0d/00:02:59, flags: JT

Incoming interface: Vlan91, RPF nbr 192.168.29.1, Mroute

Outgoing interface list:

Vlan5, Forward/Sparse-Dense, 3w0d/00:02:24

для всех остальных групп которые на 3750 присутствуют по две записи как и должно быть.

Multicast Routing: enabled

насчет TTL не могу сказать , как проверить можно ? снифером посмотреть?

Share this post


Link to post
Share on other sites

снифить интерфейсы по которым приходит мультикаст?

Share this post


Link to post
Share on other sites

Для начала попробуйте поснифать там, где смотрите мультикаст

Share this post


Link to post
Share on other sites

при низком ттл погиб бы процессор свитча )

 

Не верен, что на мультикаст c ttl=1 это распространяется.

Share this post


Link to post
Share on other sites

у всех mcast пакетов ttl > 1

Edited by hijke

Share this post


Link to post
Share on other sites

какие адреса у источников мультикаста?

Покажите sh ip route "адрес_источника" с обоих железок.

Share this post


Link to post
Share on other sites
Outgoing interface list: Vlan5, Forward/Sparse-Dense, 21w0d/00:02:24

У вас OIL vlan5 на 37-ой , а судя по конфигу должен быть vlan 3049.

Для начала, можете буком прицепится к 3750 в vlan3049 и посмотреть, будет идти картинка или нет.

Edited by optimous

Share this post


Link to post
Share on other sites

какие адреса у источников мультикаста?

Покажите sh ip route "адрес_источника" с обоих железок.

на 3750 sh ip mroute для 233.12.144.54

 

(*, 233.12.144.54), 7w0d/stopped, RP 217.150.55.185, flags: SJC

Incoming interface: Vlan91, RPF nbr 192.168.29.1, Mroute

Outgoing interface list:

Vlan5, Forward/Sparse-Dense, 21w0d/00:02:33

 

(89.179.176.202, 233.12.144.54), 3w1d/00:02:57, flags: JT

Incoming interface: Vlan91, RPF nbr 192.168.29.1, Mroute

Outgoing interface list:

Vlan5, Forward/Sparse-Dense, 3w1d/00:02:33

 

 

на 3400 вывод mroute для 233.12.144.54 :

 

(*, 233.12.144.54), 00:01:06/00:01:54, RP 10.56.133.1, flags: SJPC

Incoming interface: Vlan3049, RPF nbr 10.56.133.1

Outgoing interface list: Null

 

 

 

Outgoing interface list: Vlan5, Forward/Sparse-Dense, 21w0d/00:02:24

У вас OIL vlan5 на 37-ой , а судя по конфигу должен быть vlan 3049.

Для начала, можете буком прицепится к 3750 в vlan3049 и посмотреть, будет идти картинка или нет.

Gi 0/9 на 3400 (который соединен с 3750) имеет стабильный rxload 122/255

Когда снифил вчера на 3400 этот порт то там была видна куча потоков, те разные мультикаст группы от разных источникв. И если это так то ведь на 3400 и на 3750 вывод sh ip mroute должен быть одинаковый ,или я ошибаюсь?

Share this post


Link to post
Share on other sites

OIL на апстрим свитче для определенной группы должен совпадать с Incoming interface на доунстрим свитче, логично ж ?

И если на 34й у вас

Outgoing interface list: Null

то значит она у вас посточнно будет слать prune апстриму, и апстрим не будет форвардить трафик этой группы доунстриму, точнее будет, но каждый раз будет получать prune от нижестоящего.

Edited by optimous

Share this post


Link to post
Share on other sites

Вот сейчас так и есть. Совпадает.

Просто стоял sparse-dense mode

Поправил на dense.

Edited by hijke

Share this post


Link to post
Share on other sites

Покажите sh ip mroute с обоих железок.

Edited by optimous

Share this post


Link to post
Share on other sites

sh ip mroute 3400:

 

(*, 233.12.144.54), 03:16:02/stopped, RP 10.56.133.1, flags: SJPC

Incoming interface: Vlan3049, RPF nbr 10.56.133.1

Outgoing interface list: Null

 

(*, 224.0.1.40), 1w5d/00:02:36, RP 10.56.133.1, flags: SJPCL

Incoming interface: Vlan3049, RPF nbr 10.56.133.1

Outgoing interface list: Null

 

ip mroute 3750G:

 

(*, 226.100.10.218), 7w0d/stopped, RP 10.77.10.17, flags: SJC

Incoming interface: Vlan91, RPF nbr 192.168.29.1, Mroute

Outgoing interface list:

Vlan3049, Forward/Dense, 2w3d/stopped

Vlan5, Forward/Sparse-Dense, 21w1d/00:02:51

 

(10.251.251.8, 226.100.10.218), 1w5d/00:02:54, flags: JT

Incoming interface: Vlan91, RPF nbr 192.168.29.1

Outgoing interface list:

Vlan5, Forward/Sparse-Dense, 1w5d/00:02:51

 

(*, 226.100.10.217), 7w0d/stopped, RP 10.77.10.17, flags: SJC

Incoming interface: Vlan91, RPF nbr 192.168.29.1, Mroute

Outgoing interface list:

Vlan3049, Forward/Dense, 2w3d/stopped

Vlan5, Forward/Sparse-Dense, 21w1d/00:02:51

 

(10.251.251.7, 226.100.10.217), 1w5d/00:02:54, flags: JT

Incoming interface: Vlan91, RPF nbr 192.168.29.1

Outgoing interface list:

Vlan5, Forward/Sparse-Dense, 1w5d/00:02:51

 

(*, 226.100.10.211), 7w0d/stopped, RP 10.77.10.17, flags: SJC

Incoming interface: Vlan91, RPF nbr 192.168.29.1, Mroute

Outgoing interface list:

Vlan3049, Forward/Dense, 2w3d/stopped

Vlan5, Forward/Sparse-Dense, 21w1d/00:02:51

 

(10.251.251.8, 226.100.10.211), 1w5d/00:02:54, flags: JT

Incoming interface: Vlan91, RPF nbr 192.168.29.1

Outgoing interface list:

Vlan5, Forward/Sparse-Dense, 1w5d/00:02:51

 

(*, 226.100.10.210), 7w0d/stopped, RP 10.77.10.17, flags: SJC

Incoming interface: Vlan91, RPF nbr 192.168.29.1, Mroute

Outgoing interface list:

Vlan3049, Forward/Dense, 2w3d/stopped

Vlan5, Forward/Sparse-Dense, 21w1d/00:02:51

... и тд все остальные группы

Share this post


Link to post
Share on other sites

ну нету у вас приемника на группу 233.12.144.54, с какого 37я будет вам форвардить этот поток ?

 

По-видимому, из-за того, что статический igmp join работает не так, как вы себе представляете.

Попробуйте динамикой так сделать.

 

И вообще https://habrahabr.ru.../217585/

Edited by optimous

Share this post


Link to post
Share on other sites

Ссылку читал.

Динамикой имеете в виду с какого то устройства в этом сегменте запросить эту группу?

Share this post


Link to post
Share on other sites

3400 по vlan 3048 стыкуется по pim-sm с коммтутором аггрегации DGS-3627G.

Попробую как раз с того сегмента запросить группу.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this