Jump to content
Калькуляторы

junos+pppoe_bras+address-pool не работает!

Добрый день форумчане!

 

Прошу помощи в настройке PPPoE BRAS, не могу добиться что бы адрес выдавал из пула. Ткните носом, подкиньте рабочий пример!

Имеем:

 

xe-3/1/0 {

vlan-tagging;

unit 450 {

encapsulation ppp-over-ether;

vlan-id 450;

inactive: pppoe-underlying-options {

dynamic-profile PPPOE-test;

}

pp0 {

unit 0 {

ppp-options {

chap;

pap;

}

pppoe-options {

underlying-interface xe-3/1/0.450;

server;

}

family inet {

unnumbered-address lo0.0;

}

}

}

 

show access

 

address-pool test {

address-range low 10.50.50.1 high 10.50.50.254;

}

group-profile DNS {

ppp {

primary-dns 8.8.8.8;

secondary-dns 8.8.4.4;

}

}

profile RAD_tenet {

authentication-order none;

radius {

authentication-server 82.114.242.14;

accounting-server 82.114.242.14;

options {

nas-identifier m320;

}

}

}

address-assignment {

pool inet {

family inet {

network 10.2.2.1/24;

range 1 {

low 10.2.2.2;

high 10.2.2.254;

}

}

}

}

show access-profile

RAD_tenet;

Share this post


Link to post
Share on other sites

адрес не выдается сессия не поднимается. :( в логах

Dec 22 14:18:22.515512 UserAccess:testm320 session-id:180 state:login-request

Dec 22 14:18:22.515730 UserAccess:testm320 session-id:180 Access-profile:RAD_tenet Multi-Acct-Session-Id:0

Dec 22 14:18:22.515767 UserAccess:testm320 session-id:180 state:start xe-3/1/0.450:450

Dec 22 14:18:22.515882 UserAccess:testm320 session-id:180 state:log-out xe-3/1/0.450:450

Share this post


Link to post
Share on other sites

Добрый день форумчане!

 

Прошу помощи в настройке PPPoE BRAS, не могу добиться что бы адрес выдавал из пула. Ткните носом, подкиньте рабочий пример!

Имеем:

 

xe-3/1/0 {

vlan-tagging;

unit 450 {

encapsulation ppp-over-ether;

vlan-id 450;

inactive: pppoe-underlying-options {

dynamic-profile PPPOE-test;

}

pp0 {

unit 0 {

ppp-options {

chap;

pap;

}

pppoe-options {

underlying-interface xe-3/1/0.450;

server;

}

family inet {

unnumbered-address lo0.0;

}

}

}

 

show access

 

address-pool test {

address-range low 10.50.50.1 high 10.50.50.254;

}

group-profile DNS {

ppp {

primary-dns 8.8.8.8;

secondary-dns 8.8.4.4;

}

}

profile RAD_tenet {

authentication-order none;

radius {

authentication-server 82.114.242.14;

accounting-server 82.114.242.14;

options {

nas-identifier m320;

}

}

}

address-assignment {

pool inet {

family inet {

network 10.2.2.1/24;

range 1 {

low 10.2.2.2;

high 10.2.2.254;

}

}

}

}

show access-profile

RAD_tenet;

 

 

Какая модель джуна, плата ? Какое соединение до клиента pppoe?

 

Пробовали в транке выделить сабинтерфейс и в нем поднимать уже PPPoE?

Share this post


Link to post
Share on other sites

Мне кажется, что не хватает family pppoe на интерфейсе xe-3/1/0.450

Share this post


Link to post
Share on other sites

это м320, плата iq2-10ge, pppoe поддерживается. family pppoe на интерфейсе xe-3/1/0.450 - параметра нет. Есть ли у кого то живой пример для любого juna?

Share this post


Link to post
Share on other sites

это м320, плата iq2-10ge, pppoe поддерживается. family pppoe на интерфейсе xe-3/1/0.450 - параметра нет. Есть ли у кого то живой пример для любого juna?

interfaces {
   fe-0/0/5 {
       unit 0 {
           encapsulation ppp-over-ether;
       }
   }
   pp0 {
       unit 0 {
           ppp-options {
               pap {
                   access-profile ppp-profile;
                   local-password "dkwoxslxqpz";##SECRET-DATA
                   local-name "username";
                   passive;
               }
           }
           pppoe-options {
               underlying-interface fe-0/0/5.0;
               auto-reconnect 10;
               client;
               idle-timeout 0;
           }
           family inet {
               negotiate-address;
               mtu 1492;
           }
       }
   }
}   

Попробуйте так.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this