Jump to content
Калькуляторы

Mikrotik load balancing PCC с общим шлюзом

Поставили на сервер МТ, создали 4 влана для Wan, подключили 4 канала по 25 мбит, балансировка происходит, всё хорошо, но трафик идёт только через один влан. Провайдер один, работает через L2TP.

post-101066-030272300 1418984242_thumb.png

Добавил бриджи, чтобы сменить мак адреса, так как на вланах не меняются, бриджы связаны со своим вланом...

post-101066-076797800 1418984437_thumb.png

Суммарно 100 выдаёт, но физические порты на 100 мбит\с, тоесть ночью больше 100 не поднимется. Как раскидать по каждому влану трафик? Чтобы он не лился в один порт.

Share this post


Link to post
Share on other sites

Поставили на сервер МТ, создали 4 влана для Wan, подключили 4 канала по 25 мбит, балансировка происходит, всё хорошо, но трафик идёт только через один влан. Провайдер один, работает через L2TP.

1.PNG

Добавил бриджи, чтобы сменить мак адреса, так как на вланах не меняются, бриджы связаны со своим вланом...

2.PNG

Суммарно 100 выдаёт, но физические порты на 100 мбит\с, тоесть ночью больше 100 не поднимется. Как раскидать по каждому влану трафик? Чтобы он не лился в один порт.

 

 

промаркируйте все vlan через mangle.

Share this post


Link to post
Share on other sites

Промаркировали, к сожалению трафик пошёл только на отдачу :(

post-101066-074714100 1419069059_thumb.png

post-101066-008840900 1419069067_thumb.png

post-101066-084023700 1419069078_thumb.png

Share this post


Link to post
Share on other sites

Промаркировали, к сожалению трафик пошёл только на отдачу :(

1.PNG

2.PNG

3.PNG

 

Дайте конфиг

Share this post


Link to post
Share on other sites

Промаркировали, к сожалению трафик пошёл только на отдачу :(

post-101066-074714100 1419069059_thumb.png

post-101066-008840900 1419069067_thumb.png

post-101066-084023700 1419069078_thumb.png

 

Дайте конфиг

 

# dec/20/2014 14:40:31 by RouterOS 5.18
# software id = W5EY-LHT9
#
/interface ethernet
set 0 name=ether1
set 1 name=ether2
set 2 name=ether3
set 3 disabled=yes name=ether4
/interface l2tp-client
add connect-to=172.21.101.1 disabled=no name=l2tp-out1 password=124123 user=\
   141241
add connect-to=172.21.101.1 disabled=no name=l2tp-out2 password=1231 user=\
   12414
add add-default-route=yes connect-to=172.21.101.1 disabled=no name=l2tp-out3 \
   password=21334 user=213321
add connect-to=172.21.101.1 disabled=no name=l2tp-out4 password=141234 user=\
   141342
/interface vlan
add interface=ether2 l2mtu=9010 name=ttkuser2 vlan-id=34
add interface=ether2 l2mtu=9010 name=ttkuser vlan-id=33
add interface=ether2 l2mtu=9010 name=ttkuser3 vlan-id=35
/interface bridge port
add
add interface=ttkuser
add interface=ttkuser2
add
/interface l2tp-server server
set enabled=yes
/interface pptp-server server
set enabled=yes
/ip address
add address=172.16.1.1/24 interface=ether1
/ip dhcp-client
add default-route-distance=2 disabled=no interface=ttkuser2
add disabled=no interface=ttkuser
add add-default-route=no disabled=no interface=ether3
add default-route-distance=0 disabled=no interface=ttkuser3
/ip dns
set allow-remote-requests=yes cache-size=4096KiB servers=8.8.8.8
/ip firewall filter
add chain=input in-interface=!l2tp-out1
add chain=forward
add chain=input
add chain=output
/ip firewall mangle
add action=mark-connection chain=input in-interface=l2tp-out1 \
   new-connection-mark=TTK2_conn
add action=mark-routing chain=output connection-mark=TTK2_conn \
   new-routing-mark=to_TTK2
add chain=prerouting dst-address=10.208.96.0/20 in-interface=ether1
add action=mark-connection chain=prerouting dst-address-type=!local \
   in-interface=ether1 new-connection-mark=TTK2_conn \
   per-connection-classifier=both-addresses-and-ports:4/0
add action=mark-routing chain=prerouting connection-mark=TTK2_conn \
   in-interface=ether1 new-routing-mark=to_TTK2
add action=mark-connection chain=input in-interface=l2tp-out2 \
   new-connection-mark=TTK1_conn
add action=mark-routing chain=output connection-mark=TTK1_conn \
   new-routing-mark=to_TTK1
add chain=prerouting dst-address=10.208.96.0/20 in-interface=ether1
add action=mark-connection chain=prerouting dst-address-type=!local \
   in-interface=ether1 new-connection-mark=TTK1_conn \
   per-connection-classifier=both-addresses-and-ports:4/1
add action=mark-routing chain=prerouting connection-mark=TTK1_conn \
   in-interface=ether1 new-routing-mark=to_TTK1
add action=mark-connection chain=input in-interface=l2tp-out3 \
   new-connection-mark=TTK3_conn
add action=mark-routing chain=output connection-mark=TTK3_conn \
   new-routing-mark=to_TTK3
add chain=prerouting dst-address=10.208.96.0/20 in-interface=ether1
add action=mark-connection chain=prerouting dst-address-type=!local \
   in-interface=ether1 new-connection-mark=TTK3_conn \
   per-connection-classifier=both-addresses-and-ports:4/2
add action=mark-routing chain=prerouting connection-mark=TTK3_conn \
   in-interface=ether1 new-routing-mark=to_TTK3
add action=mark-connection chain=input in-interface=l2tp-out4 \
   new-connection-mark=TTK4_conn
add action=mark-routing chain=output connection-mark=TTK4_conn \
   new-routing-mark=to_TTK4
add chain=prerouting dst-address=10.208.96.0/20 in-interface=ether1
add action=mark-connection chain=prerouting dst-address-type=!local \
   in-interface=ether1 new-connection-mark=TTK4_conn \
   per-connection-classifier=both-addresses-and-ports:4/3
add action=mark-routing chain=prerouting connection-mark=TTK4_conn \
   in-interface=ether1 new-routing-mark=to_TTK4
add action=mark-routing chain=prerouting disabled=yes in-interface=l2tp-out4 \
   new-routing-mark=4 passthrough=no
add action=mark-routing chain=prerouting disabled=yes in-interface=l2tp-out1 \
   new-routing-mark=1 passthrough=no
add action=mark-routing chain=prerouting disabled=yes in-interface=l2tp-out2 \
   new-routing-mark=2 passthrough=no
add action=passthrough chain=prerouting disabled=yes in-interface=l2tp-out4
/ip firewall nat
add action=masquerade chain=srcnat out-interface=l2tp-out1
add action=masquerade chain=srcnat out-interface=l2tp-out2
add action=masquerade chain=srcnat out-interface=l2tp-out3
add action=masquerade chain=srcnat out-interface=l2tp-out4
/ip neighbor discovery
set ttkuser2 disabled=yes
set ttkuser disabled=yes
set ether4 disabled=no
set ttkuser3 disabled=yes
/ip route
add check-gateway=ping distance=1 gateway=l2tp-out1 routing-mark=to_TTK2
add check-gateway=ping distance=1 gateway=l2tp-out2 routing-mark=to_TTK1
add check-gateway=ping distance=1 gateway=l2tp-out3 routing-mark=to_TTK3
add check-gateway=ping distance=1 gateway=l2tp-out4 routing-mark=to_TTK4
add distance=1 gateway=l2tp-out1
add check-gateway=ping distance=2 gateway=l2tp-out2
add check-gateway=ping distance=3 gateway=l2tp-out3
add check-gateway=ping distance=4 gateway=l2tp-out4
add distance=1 dst-address=172.21.101.1/32 gateway=10.208.96.1%ttkuser2
add distance=1 dst-address=172.21.101.1/32 gateway=10.208.96.1%ttkuser
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes

Share this post


Link to post
Share on other sites

l2tp сервер имеет адрес только 172.21.101.1 или есть еще адреса?

Если только один, то ничего не выйдет. Придется делать извращенный вариант с четырьмя vrf, dstnat в каждом vrf и дополнительным патчкордом между двумя портами. Не факт еще, что это заработает на микротике так, как нужно.

Share this post


Link to post
Share on other sites

l2tp сервер имеет адрес только 172.21.101.1 или есть еще адреса?

Если только один, то ничего не выйдет. Придется делать извращенный вариант с четырьмя vrf, dstnat в каждом vrf и дополнительным патчкордом между двумя портами. Не факт еще, что это заработает на микротике так, как нужно.

Увы, адес один.

Share this post


Link to post
Share on other sites

Вам надо поставить 4 микротика для приема каналов, и еще один для их объединения в один. В этом случае у вас не будет проблем со шлюзами, т.к. каждый микротик будет работать сам по себе, а пятый микротик будет разруливать какого абонента на какой канал пускать.

Share this post


Link to post
Share on other sites

Вам надо поставить 4 микротика для приема каналов

спасибо, в мемориз :-))

Share this post


Link to post
Share on other sites

У меня одни знакомые подобным образом франшизу Казахтелекома воруют, только у них около 200 учетных записей для этого. Вот бы им Сааба послушать.

Share this post


Link to post
Share on other sites

Вам надо поставить 4 микротика для приема каналов

спасибо, в мемориз :-))

Сааб не будет сдаваться!

Share this post


Link to post
Share on other sites

Вам надо поставить 4 микротика для приема каналов, и еще один для их объединения в один.

 

Что то сааб мелочится.

Крайне необходимо ещё резервирование на аппаратном уровне замутить...

Share this post


Link to post
Share on other sites

Нужно больше микротиков!

Каждому микротику нужен дополнительный микритик, который будет его резервировать, а каждому резервирующему микротику нужен дополнительный микротик, который будет его резервировать (... continuous loop)

Share this post


Link to post
Share on other sites

Нужно больше микротиков!

Больше микротиков богу микротиков!

Share this post


Link to post
Share on other sites

Пока вы тут не устроили микротикосрач, задам совершенно неприличный вопрос. Как вы уже поняли по моим предыдущим сообщениям, опыта у меня хрен да маленько. Вопрос такой. Как траблшутить микротики? Брас и бордер на них. Допустим, проблема в низкой скорости и потерях пакета. Какой алгоритм траблшутинга? В какие стороны копать в первую очередь? Где почитать об этом?

Share this post


Link to post
Share on other sites

Вам надо поставить 4 микротика для приема каналов, и еще один для их объединения в один. В этом случае у вас не будет проблем со шлюзами, т.к. каждый микротик будет работать сам по себе, а пятый микротик будет разруливать какого абонента на какой канал пускать.

 

Вы иногда такую чушь впариваете, только что бы клиенту втолкнуть железко.

\

З.Ы. Сорри за офффтоп.

Share this post


Link to post
Share on other sites

У меня одни знакомые подобным образом франшизу Казахтелекома воруют, только у них около 200 учетных записей для этого. Вот бы им Сааба послушать.

 

Да, микротик вашим знакомым очень сильно бы пригодился.

 

Как траблшутить микротики? Брас и бордер на них. Допустим, проблема в низкой скорости и потерях пакета. Какой алгоритм траблшутинга? В какие стороны копать в первую очередь? Где почитать об этом?

 

Например у вас есть абоненты. Один из них жалуется на низкую скорость. Вы создаете на микротике PPTP или L2TP сервер, создаете учетку с адресом абонента, подключаетесь к ней с тестового компа, подключенного к микротику кабелем и запускаете тесты, если там все нормально, значит проблема в транспортной сети до абонента, если там проблемы - значит что-то не в порядке с оператором, либо шейперами микротика. Так же есть торч, который показывает какие данные и куда идут. Если же у вас и у абонентов микротики, например вы предоставляете интернет по радио, где в роли CPE используется устройство микротик, до него можно запустить btest и проверить скорость, через пинг потери пакетов и т.п.

Share this post


Link to post
Share on other sites

pptp ? l2tp ? пинг? это же устаревшие технологии (с)

До полного комплекта к описанной методике диагностики не хватает мешка молотых кофейных зерен, и бубна.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this