Jump to content
Калькуляторы

Пионерский вопрос по OSPF.

Экспериментирую с OSPF в Packet Tracer'e.

 

Есть три роутера, соединенных по цепочке: 1-2-3.

 

На первом есть подсеть: 192.10.0.0/24(Непосредственно на интерфейсе имеем Ip 192.10.0.1). Маска точно 24.

 

Идем на 3-ий:

Router#sh ip ospf database

OSPF Router with ID (192.168.2.2) (Process ID 1)

 

Router Link States (Area 1)

 

Link ID ADV Router Age Seq# Checksum Link count

192.168.10.1 192.168.10.1 1695 0x8000001f 0x00d337 3

192.168.2.2 192.168.2.2 904 0x8000000b 0x00e2b3 1

192.192.192.192 192.192.192.192 897 0x8000001b 0x00805b 3

 

Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

192.168.2.1 192.168.10.1 904 0x80000008 0x008070

192.168.0.1 192.192.192.192 897 0x80000005 0x00241d

 

Т.е. в датабейзе не видно ничего, по поводу этого линка.

Однако, с 3-го роутера данная посеть доступна через 2-ой.

 

Я предполагал, что SPF должен видеть в базе линков все подсети и им соответствующие линки, на основании чего и принимается решение о внесении записи в таблицу роутинга.

 

Это проблема Packet Tracer'а, или я неправильно понимаю?

Заранее благодарен за ответы.

Share this post


Link to post
Share on other sites

Конфиг ospf роутеров и интерфейсов в студию!

Share this post


Link to post
Share on other sites

Конфиг ospf роутеров и интерфейсов в студию!

 

Имеет ли смысл? Вопрос не в том, что что-то не работает, а в том, правильны ли мои ожидания в отношении результата: show ip ospf database.

А именно: подсеть 192.10.0.0 на роутере есть. С соседа доступна, но в выводе ospf database ее нет. У соседа такой подсети непосредственно подключенной нет.

 

Относительно OSPF, параметр networks делал 0.0.0.0 255.255.255.255 area 1 везде. Подсети все /24.

К тому же, Sh run инфы по ospf не выводит.

Edited by seelent

Share this post


Link to post
Share on other sites

Router3#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

O 192.10.0.0/24 [110/3] via 192.168.2.1, 00:10:24, GigabitEthernet0/2

O 192.168.0.0/24 [110/2] via 192.168.2.1, 00:10:24, GigabitEthernet0/2

192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.2.0/24 is directly connected, GigabitEthernet0/2

L 192.168.2.2/32 is directly connected, GigabitEthernet0/2

O 192.168.10.0/24 [110/2] via 192.168.2.1, 00:11:04, GigabitEthernet0/2

O 192.168.46.0/24 [110/3] via 192.168.2.1, 00:10:24, GigabitEthernet0/2

 

С него же(3 роутер):

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/2

ip address 192.168.2.2 255.255.255.0

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 1

Share this post


Link to post
Share on other sites

Экспериментирую с OSPF в Packet Tracer'e.

 

Есть три роутера, соединенных по цепочке: 1-2-3.

 

На первом есть подсеть: 192.10.0.0/24(Непосредственно на интерфейсе имеем Ip 192.10.0.1). Маска точно 24.

 

Идем на 3-ий:

Router#sh ip ospf database

OSPF Router with ID (192.168.2.2) (Process ID 1)

 

Router Link States (Area 1)

 

Link ID ADV Router Age Seq# Checksum Link count

192.168.10.1 192.168.10.1 1695 0x8000001f 0x00d337 3

192.168.2.2 192.168.2.2 904 0x8000000b 0x00e2b3 1

192.192.192.192 192.192.192.192 897 0x8000001b 0x00805b 3

 

Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

192.168.2.1 192.168.10.1 904 0x80000008 0x008070

192.168.0.1 192.192.192.192 897 0x80000005 0x00241d

 

Т.е. в датабейзе не видно ничего, по поводу этого линка.

Однако, с 3-го роутера данная посеть доступна через 2-ой.

 

Я предполагал, что SPF должен видеть в базе линков все подсети и им соответствующие линки, на основании чего и принимается решение о внесении записи в таблицу роутинга.

 

Это проблема Packet Tracer'а, или я неправильно понимаю?

Заранее благодарен за ответы.

Вы не правильно понимаете. OSPF - это построение графа между нодами а коннектед сети это просто атрибуты нод графа. Вам просто подетальней надо взглянуть на database. show ip ospf database router R1

Share this post


Link to post
Share on other sites

Насколько я помню, PT значительно урезан в возможностях вывода LSA, лучше в GNS это делать с реальными образами.

Share this post


Link to post
Share on other sites

Экспериментирую с OSPF в Packet Tracer'e.

 

Есть три роутера, соединенных по цепочке: 1-2-3.

 

На первом есть подсеть: 192.10.0.0/24(Непосредственно на интерфейсе имеем Ip 192.10.0.1). Маска точно 24.

 

Идем на 3-ий:

Router#sh ip ospf database

OSPF Router with ID (192.168.2.2) (Process ID 1)

 

Router Link States (Area 1)

 

Link ID ADV Router Age Seq# Checksum Link count

192.168.10.1 192.168.10.1 1695 0x8000001f 0x00d337 3

192.168.2.2 192.168.2.2 904 0x8000000b 0x00e2b3 1

192.192.192.192 192.192.192.192 897 0x8000001b 0x00805b 3

 

Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum

192.168.2.1 192.168.10.1 904 0x80000008 0x008070

192.168.0.1 192.192.192.192 897 0x80000005 0x00241d

 

Т.е. в датабейзе не видно ничего, по поводу этого линка.

Однако, с 3-го роутера данная посеть доступна через 2-ой.

 

Я предполагал, что SPF должен видеть в базе линков все подсети и им соответствующие линки, на основании чего и принимается решение о внесении записи в таблицу роутинга.

 

Это проблема Packet Tracer'а, или я неправильно понимаю?

Заранее благодарен за ответы.

Вы не правильно понимаете. OSPF - это построение графа между нодами а коннектед сети это просто атрибуты нод графа. Вам просто подетальней надо взглянуть на database. show ip ospf database router R1

 

Я понимаю, что протокол строит дерево, только чтобы построить, он должен обладать базой данных линков(Не собственных подсетей, а подсетей всех существующих в area маршрутизаторов). Вопрос в том, что я понял, что sh ip ospf database эту самую базу и выводит. Только в ней, в моем случае, нет ни слова про удаленную подсеть, при этом она доступна и есть в таблице маршрутизации с пометкой о том, что роут сделан оспфом.

Share this post


Link to post
Share on other sites

Так а где конфиг первого роутера? Если сеть не объявлена в оспф её и не будет видно..

Share this post


Link to post
Share on other sites

Так а где конфиг первого роутера? Если сеть не объявлена в оспф её и не будет видно..

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 100

ip address 192.168.46.1 255.255.255.0

!

interface FastEthernet0/1

ip address 192.10.0.1 255.255.255.0

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 1

Share this post


Link to post
Share on other sites

Я понимаю, что протокол строит дерево, только чтобы построить, он должен обладать базой данных линков(Не собственных подсетей, а подсетей всех существующих в area маршрутизаторов). Вопрос в том, что я понял, что sh ip ospf database эту самую базу и выводит. Только в ней, в моем случае, нет ни слова про удаленную подсеть, при этом она доступна и есть в таблице маршрутизации с пометкой о том, что роут сделан оспфом.

вы все таки не поняли что такое link-state, нету у него отдельной базы сетей. Думаю вам еще раз нужно книжку посмотреть. И мой ответ невнимательно прочитали. Знака ? В пакет трейсерте тоже нет?

Share this post


Link to post
Share on other sites

На самом деле в ospf узнали про эту сеть из LSA №1 того роутера к которому она присоединена. А посмотреть можно ее командой show ip ospf database router [router id в ospf]

Share this post


Link to post
Share on other sites

Я понимаю, что протокол строит дерево, только чтобы построить, он должен обладать базой данных линков(Не собственных подсетей, а подсетей всех существующих в area маршрутизаторов). Вопрос в том, что я понял, что sh ip ospf database эту самую базу и выводит. Только в ней, в моем случае, нет ни слова про удаленную подсеть, при этом она доступна и есть в таблице маршрутизации с пометкой о том, что роут сделан оспфом.

вы все таки не поняли что такое link-state, нету у него отдельной базы сетей. Думаю вам еще раз нужно книжку посмотреть. И мой ответ невнимательно прочитали. Знака ? В пакет трейсерте тоже нет?

Да, пропустил слово router, виноват.

Теперь понятнее, спасибо.

Одно непонятно: что тогда выводит sh ip ospf database(без доп. ключей)?

 

На самом деле в ospf узнали про эту сеть из LSA №1 того роутера к которому она присоединена. А посмотреть можно ее командой show ip ospf database router [router id в ospf]

 

Спасибо, я уже понял ошибку.

Просто предполагал, что доп. ключей команде не нужно, и вся инфа по источникам линкстейтов выводится просто через sh ip ospf database.

Share this post


Link to post
Share on other sites

Одно непонятно: что тогда выводит sh ip ospf database(без доп. ключей)?

Базу данных ospf :) Ваш кэп...

 

Просто предполагал, что доп. ключей команде не нужно, и вся инфа по источникам линкстейтов выводится просто через sh ip ospf database.

 

Это прикольно когда три роутера на стренде, а когда в сети их 50 и по 100 сетей на каждом будет не прикольно)))

Share this post


Link to post
Share on other sites

Мой совет- на этом этапе важно понять что OSPF в отличии от EIGRP распространяет не маршруты а LSA (для простоты принять что LSA это роутер и его линки) и уж потом роутер на основе SPF строит граф до этих роутеров используя косты на интерфейсах. И да ковыряться в этой database на большой сети поначалу не так просто)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this