Jump to content
Калькуляторы

ip unnumbered poll 3750E не работает на комутаторах 3750Е

Добрый время суток.

Изучаю материал на тему ip unnumbered

Просмотрел

IP Unnumbered Ethernet Polling Support

Configuring IP Unnumbered Interface

 

ip routing
ip arp poll queue 100
ip arp poll rate 100
ip arp proxy disable

interface Loopback1
ip address 192.168.1.1 255.255.255.0

interface Vlan32
ip unnumbered Loopback1 poll
no ip unreachables

interface Vlan31
ip unnumbered Loopback1 poll
no ip unreachables

 

Model SW Version

WS-C3750G-24TS-1U 12.2(46)SE

 

show ip interface loopback 1 unnumbered

Number of unnumbered interfaces with polling: 2

Number of IP addresses processed for polling: 0

Number of IP addresses in queue for polling: 0 (high water mark: 0)

 

show ip arp poll

Number of IP addresses processed for polling: 0

Number of IP addresses in queue for polling: 0 (high water mark: 0, max: 100)

Number of requests dropped:

Queue was full: 0

Request was throttled by incomplete ARP: 0

Duplicate request was found in queue: 0

 

в двух вланах находся ноутбуки с IP

192.168.1.2/24

192.168.1.3/24

При проверки оказалось что ip unnumbered poll на 3750 серии не работает

кроме основного шлюза не чего не пингуют.

Все начинает работать только при включении proxy-arp.

Это 3750 не поддерживает poll или пробелы в знаниях?

Edited by Vugluskr

Share this post


Link to post
Share on other sites

Коммутатор узнал в каком влане находится клиент? show ip arp что показывает?

Задача arp polling-а это узнавать где клиенты автоматически, без ручной\автоматической генерации маршрута.

 

То что клиенты пингуют шлюз это практически победа. Осталось понять что они НЕ пингуют. Последующие маршрутизаторы? Соседнего клиента?

Share this post


Link to post
Share on other sites

show ip arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 192.168.1.3 49 089e.0111.2fba ARPA Vlan32

Internet 192.168.1.2 0 0026.182c.b9a5 ARPA Vlan31

Свичь хосты в разных вланах видет, и успешно пингует.

 

ну в общем так в доке и написано

The polling option enables the dynamic discovery of hosts (connected though the unnumbered interfaces) based on the Address Resolution Protocol (ARP) protocol.

 

Но я думал что хосты в разных вланах (на одном Loopback) будут видеть друг друга при выключенном arp-proxy.

Но видно не судьба.

 

При ip arp proxy disable

Хосты видят только соседей по влану, что в общем то логично, и не видят некого из соседнего.

 

Есть ли возможность при такой настройки уйти от arp-proxy?

Share this post


Link to post
Share on other sites

А как вы себе это представляете иначе? Трафик идет через ваш L3 свитч и не может пройти напрямую, как вы хотите, из-за того, что вланы разные. Чтобы он прошел нужно либо объединить вланы либо прокси-арп.

Share this post


Link to post
Share on other sites

кхм, а где роут на клиента?

нет релея, что б автоматом роут поднимал...

 

ip route 192.168.1.2 255.255.255.255 vlan31

ip route 192.168.1.3 255.255.255.255 vlan32

 

шпаргалка

Edited by GrandPr1de

Share this post


Link to post
Share on other sites

нет релея, что б автоматом роут поднимал...

 

ключевое слово poll

 

to vurd

Целиком с вами согласен. Возможно чтение замылило взгляд.

Share this post


Link to post
Share on other sites

У опытных цисководов хотел уточнить какие подводные камни в использовании ip unnumbered 3750g ? Нагрузка на cpu и прочее, вообще сколько потянет?

Share this post


Link to post
Share on other sites

кхм, а где роут на клиента?

нет релея, что б автоматом роут поднимал...

 

ip route 192.168.1.2 255.255.255.255 vlan31

ip route 192.168.1.3 255.255.255.255 vlan32

 

шпаргалка

 

Зачем этот роут если клиент и так директи-коннектед?

 

Вы роут этот пишите, чтобы сказать маршрутизатору куда слать пакеты, а если он сам изучил уже где находится клиент, ему этот маршрут нафиг не нужен как-бы.

Share this post


Link to post
Share on other sites

Ну так смысл арп поллинга, чтобы не писать ничего руками:)

Второй вариант - это генерация маршрутов при dhcp-обмене.

Share this post


Link to post
Share on other sites

Добрый день.

Возникла проблема с интегрированием ip unnumbered в OSPF.

Настройка простая. 1 Loopback на который завернуто 10 SVI.

ip ospf network point-to-point для передачи сети на Loopback через OSPF.

Хосты в SVI видят друг друга, но за интерфейс Vlan32 уже не ходят.

Если выкинут ip unnumbered и на каждый влан повесить /27 сетку все работает нормально.

Коммутатор WS-C4948-10GE (чтоб не плодить темы написал в этой) в логах сыпит ошибку.

%OSPF-4-NO_IPADDRESS_ON_INT: No IP address for interface Vlan300.

Ошибку начинает сыпать когда в разных Vlan появляются хосты.

Номер влана в логах в перемешку для всех SVI на которых был "ip unnumbered".

 

interface Loopback999
description GuestVlan
ip address 10.x.y.1 255.255.255.0
no ip unreachables
no ip mroute-cache
ip ospf network point-to-point

interface Vlan30(1-10)
ip unnumbered Loopback1 poll
ip helper-address x.y.x.y
no ip unreachables
no ip proxy-arp
no ip mroute-cache

interface Vlan32
ip address x1.y1.x1.y1 255.255.255.240
no ip unreachables
no ip proxy-arp
no ip mroute-cache


router ospf 1
router-id x.y.x.y
log-adjacency-changes
passive-interface default
no passive-interface Vlan32
network 10.x.y.0 0.0.7.255 area 0



%OSPF-4-NO_IPADDRESS_ON_INT: No IP address for interface Vlan300
%OSPF-4-NO_IPADDRESS_ON_INT: No IP address for interface Vlan301

 

WS-C4948-10GE
ROM: 12.2(31r)SGA4
System image file is "bootflash:cat4500-entservicesk9-mz.150-2.SG8.bin"

Share this post


Link to post
Share on other sites

А вы это к чему? Я не пытаюсь на интерфейсе с ip-unnumbered поднять OSPF.

Мне надо маршрут который висит на loopback передать через OSPF.

Share this post


Link to post
Share on other sites

в таком случае не вижу в router ospf команды redistribute connected subnets

и не понятно зачем ip ospf network на loopback висит.

Share this post


Link to post
Share on other sites

ну маршрут и так передавался.

Потому что попадал в широченный network, существование которого чревато проблемами, если на сети появится клиентское устройство с включенным криво настроенным ospf.

 

К слову, ошибку no ip address у вас 4948 шлет вероятней всего потому что на интерфейсе отсылка идет к loopback1, а в конфиге у вас loopback999.

Share this post


Link to post
Share on other sites

А вы это к чему? Я не пытаюсь на интерфейсе с ip-unnumbered поднять OSPF.

Мне надо маршрут который висит на loopback передать через OSPF.

Для этого вам надо добавить сеть этого loopback в процесс OSPF, никаких редистрибьюций не надо.

Одно не ясно, у вас unnumbered на loopback 1, а анонсируется loopback 999.

Share this post


Link to post
Share on other sites

Да похоже я неправильно понимал работу команды network.

Share this post


Link to post
Share on other sites

в таком случае не вижу в router ospf команды redistribute connected subnets

и не понятно зачем ip ospf network на loopback висит.

Не обязательно импортировать в ospf кучу этих /32. А network на loopback потому, что по дефолту будет анонс /32, а не актуального префикса, пока на loopback не укажешь P-t-P.

Share this post


Link to post
Share on other sites

unnumbered на loopback 1, а анонсируется loopback 999

Со старта топика много времени прошло. Уже конфигурация несколько рас менялась.

Проблема в том что в логах выдаёт ошибку

%OSPF-4-NO_IPADDRESS_ON_INT: No IP address for interface Vlan301

Share this post


Link to post
Share on other sites

Не обязательно импортировать в ospf кучу этих /32

а с чего это они вдруг станут /32 ? в ospf это будет как раз 10.x.y.0/24 ;)

interface Loopback97
ip address 172.20.97.254 255.255.255.0
no ip redirects
no ip proxy-arp
end

#sh ip route 172.20.97.3
Routing entry for 172.20.97.0/24
 Known via "connected", distance 0, metric 0 (connected, via interface)
 Redistributing via ospf 21453
 Advertised by ospf 21453 subnets
 Routing Descriptor Blocks:
 * directly connected, via Loopback97
     Route metric is 0, traffic share count is 1

Share this post


Link to post
Share on other sites

Не обязательно импортировать в ospf кучу этих /32

а с чего это они вдруг станут /32 ? в ospf это будет как раз 10.x.y.0/24 ;)

Я не знаю, как работает poll, возможно в этом моя ошибка)

 

У меня это все работает с unnumbered + DHCP Snooping, который как раз создает гору /32 на SVI.

Share this post


Link to post
Share on other sites

Более того, запихнуть этот loopback в ospf, да еще и с таким network в area 0... я надеюсь это стенд и первые попытки изучения граблей ospf, но никак не боевая сеть.

Share this post


Link to post
Share on other sites

Не обязательно импортировать в ospf кучу этих /32

interface Loopback97
ip address 172.20.97.254 255.255.255.0
no ip redirects
no ip proxy-arp
end

#sh ip route 172.20.97.3
Routing entry for 172.20.97.0/24
 Known via "connected", distance 0, metric 0 (connected, via interface)
 Redistributing via ospf 21453
 Advertised by ospf 21453 subnets
 Routing Descriptor Blocks:
 * directly connected, via Loopback97
     Route metric is 0, traffic share count is 1

 

А попробуйте добавить эту 24 сеть в ospf?)

 

Loopbacks are considered host routes in OSPF, and they are advertised as /32. For more information, refer to section 9.1 of RFC 2328 leavingcisco.com. In Cisco IOS Software Releases 11.3T and 12.0, if the ip ospf network point-to-point command is configured under loopbacks, OSPF advertises the loopback subnet as the actual subnet configured on loopbacks

Share this post


Link to post
Share on other sites

А попробуйте добавить эту 24 сеть в ospf?)

через redistribute connected subnets бегает без проблем

#sh ip route 172.20.97.2
Routing entry for 172.20.97.0/24
 Known via "ospf 21453", distance 110, metric 20, type extern 2, forward metric 2
 Last update from 192.168.2.7 on Vlan1100, 5d00h ago
 Routing Descriptor Blocks:
 * 192.168.2.7, from 10.11.0.6, 5d00h ago, via Vlan1100
     Route metric is 20, traffic share count is 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this