Jump to content
Калькуляторы

Микротик, прошу помощи Микротик, прошу помощи

Прошу ткнуть, что не настроил. Уже несколько инструкций попробовал. Все просто, пытаюсь настроить микротик в качестве маршрутизатора.

Комп из внутренней сети пингуется с микротиком. Микротик пингует провайдера, все ок. Но нет пинга между внутренней сетью и провайдером и соотвественно нет инета.

NAT настраивал!!!

Проблема, как понимаю, нет маршрутизации между ether2-master-local и ether1-gateway. Провайдер воткнут в ether1-gateway. Локалка в ether2-master-local. Остальные порты не задействованы.

Вот логи.

 

[admin@MikroTik] /ip firewall nat> print

Flags: X - disabled, I - invalid, D - dynamic

0 ;;; default configuration

chain=srcnat action=masquerade src-address-list=""

out-interface=ether1-gateway connection-type=""

 

 

 

 

[admin@MikroTik] > ip address print

Flags: X - disabled, I - invalid, D - dynamic

# ADDRESS NETWORK INTERFACE

0 ;;; default configuration

192.168.0.2/24 192.168.0.0 ether2-master-local

1 120.233.245.225/29 120.233.245.224 ether1-gateway

 

 

[admin@MikroTik] > interface print

Flags: D - dynamic, X - disabled, R - running, S - slave

# NAME TYPE MTU L2MTU MAX-L2MTU

0 R ether1-gateway ether 1500 1598 4074

1 R ether2-master-local ether 1500 1598 4074

2 ether3-slave-local ether 1500 1598 4074

3 ether4-slave-local ether 1500 1598 4074

4 ether5-slave-local ether 1500 1598 4074

5 X wlan1 wlan 1500 2290

6 R bridge-local bridge 1500 65535

 

[admin@MikroTik] > ip route print

Flags: X - disabled, A - active, D - dynamic,

C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,

B - blackhole, U - unreachable, P - prohibit

# DST-ADDRESS PREF-SRC GATEWAY DISTANCE

0 A S 0.0.0.0/0 120.233.245.226 1

1 ADC 120.233.245.224/29 120.233.245.225 ether1-gateway 0

2 ADC 192.168.0.0/24 192.168.0.2 ether2-master-l... 0

Edited by denlao

Share this post


Link to post
Share on other sites

Покажите всю конфигурацию (export compact)?

Share this post


Link to post
Share on other sites

[admin@MikroTik] > export compact

# jan/02/1970 00:02:59 by RouterOS 6.15

# software id = Y72E-B6FL

#

/interface bridge

add admin-mac=4C:5E:0C:34:C1:73 auto-mac=no name=bridge-local

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=\

20/40mhz-ht-above distance=indoors l2mtu=2290 mode=ap-bridge ssid=\

MikroTik-34C177

/interface ethernet

set [ find default-name=ether1 ] name=ether1-gateway

set [ find default-name=ether2 ] name=ether2-master-local

set [ find default-name=ether3 ] name=ether3-slave-local

set [ find default-name=ether4 ] name=ether4-slave-local

set [ find default-name=ether5 ] name=ether5-slave-local

/ip neighbor discovery

set ether1-gateway discover=no

/ip hotspot user profile

set [ find default=yes ] idle-timeout=none keepalive-timeout=2m \

mac-cookie-timeout=3d

/ip pool

add name=default-dhcp ranges=192.168.88.10-192.168.88.254

/ip dhcp-server

add address-pool=default-dhcp disabled=no interface=ether2-master-local \

lease-time=10m name=default

/ip address

add address=192.168.0.2/24 comment="default configuration" interface=\

ether2-master-local network=192.168.0.0

add address=120.233.245.224/29 interface=ether1-gateway network=\

120.233.245.225

/ip dhcp-client

add comment="default configuration" dhcp-options=hostname,clientid disabled=\

no interface=ether1-gateway

/ip dhcp-server network

add address=192.168.0.0/24 comment="default configuration" dns-server=\

192.168.0.2 gateway=192.168.0.2

/ip dns

set allow-remote-requests=yes servers=192.168.11.250

/ip dns static

add address=192.168.88.1 name=router

/ip firewall filter

add chain=input src-address=192.168.0.0/24

add chain=input comment="default configuration" protocol=icmp

add chain=input comment="default configuration" connection-state=established

add chain=input comment="default configuration" connection-state=related

add action=drop chain=input comment="default configuration" disabled=yes \

in-interface=ether1-gateway

add chain=forward comment="default configuration" connection-state=\

established

add chain=forward comment="default configuration" connection-state=related

add action=drop chain=forward comment="default configuration" \

connection-state=invalid disabled=yes

/ip firewall mangle

add chain=prerouting disabled=yes

/ip firewall nat

add action=masquerade chain=srcnat comment="default configuration" \

out-interface=ether1-gateway src-address-list=""

/ip route

add distance=1 gateway=120.233.245.226

/ip upnp

set allow-disable-external-interface=no

/system leds

set 0 interface=wlan1

/tool graphing interface

add interface=ether1-gateway

add interface=ether2-master-local

/tool mac-server

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

/tool mac-server mac-winbox

set [ find default=yes ] disabled=yes

add interface=ether2-master-local

add interface=ether3-slave-local

add interface=ether4-slave-local

add interface=ether5-slave-local

add interface=wlan1

add interface=bridge-local

Share this post


Link to post
Share on other sites

У вас бридж должен объединять беспроводку и "внутренний коммутатор"?

Если так - то включите беспроводку и адрес назначьте на бридж а не на интерфейс.

DNS у вас записан дефолтный, странный, ошибка наверное...

 

Проверьте пинги с локалки до внешнего адреса микротика...

Share this post


Link to post
Share on other sites

У вас бридж должен объединять беспроводку и "внутренний коммутатор"?

 

нет, не должен.

 

Если так - то включите беспроводку и адрес назначьте на бридж а не на интерфейс.

DNS у вас записан дефолтный, странный, ошибка наверное...

Да, dns странный, по умолчанию, он пока не нужен. Пинги идут с микротика на 8.8.8.8 например.

 

Проверьте пинги с локалки до внешнего адреса микротика...

с локалки до внешнего адреса микротика пинги не идут.

Share this post


Link to post
Share on other sites

адрес назначьте на бридж а не на интерфейс

Да, dns странный, по умолчанию, он пока не нужен.

 

Сделайте сброс начальной конфигурации и настройте всё заново, например, по этой инструкции: http://spw.ru/solutions/razumnaya_nastrojka_rb2011/ ничего от себя не придумывая.

По результату отпишитесь.

Edited by Fumo

Share this post


Link to post
Share on other sites

/ip dhcp-server

add address-pool=default-dhcp disabled=no interface=ether2-master-local \

lease-time=10m name=default

 

Включает DHCP с выдачей адресов из address-pool=default-dhcp.

 

----------------------------------------------------------

 

/ip pool

add name=default-dhcp ranges=192.168.88.10-192.168.88.254

 

Меня одного пул смущает? Клиенты какой ip получают?

 

----------------------------------------------------------

 

/ip dhcp-server network

add address=192.168.0.0/24 comment="default configuration" dns-server=\

192.168.0.2 gateway=192.168.0.2

 

А дальше gate выдается только для 192.168.0.0/24, а не 192.168.88.0/24

Edited by monstr

Share this post


Link to post
Share on other sites

Мильён раз говорено: Сбрасывайте начальную конфигурацию перед настройкой. И в КАЖДОЙ инструкции про это сказано.

 

...Но у русских людей ведь аллергия на слово Инструкция.

Edited by Fumo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this