Jump to content
Калькуляторы

Резервирование 10-ти офисов по двум каналам вопрос по резервированию, чем лучше ?

Дано:

10 удалённых офисов подключенных к основному, центральному, посредством ПЦК (прямой цифровой канал) от двух операторов. Переключение выполняется вручную, если канал основного оператора "падает" :)

Всё это дело - один большой широковещательный домен 172.16.0.0/16 :(((

Хочется разделить всё это дело на сети /24 . Плюс сделать автоматическое переключение каналов. Делать планирую на оборудовании mikrotik. Сейчас для тестов имеются в распоряжении 2 RB750GL.

Думаю, что резервацию сделать можно с помощью ospf. Создать две зоны, назначить на одну из них большую стоимость маршрутов - это будет резерв.

Осталось разобраться как всё это сделать на mikrotik.

Прикладываю схему, кто, что может посоветует, может я ошибаюсь где то

post-114900-049852500 1416296272_thumb.jpg

Share this post


Link to post
Share on other sites

Не нужны вам никакие зоны.

 

OSPF включается следующим образом:

 

/routing ospf network
add area=backbone network=172.16.0.0/16

 

После этого по всем портам, на которых адреса из этой сети, роутер будет искать соседей и связываться между ними. Если нужно подать дефолтный маршрут в сеть, то в меню OSPF в настройках зоны нужно выбрать соответствующую опцию.

 

При необходимости можно задать метрику интерфейсов, для этого нужно создать его вручную, при этом, если для каких-то портов вручную не задавали, для них будет установлена одна дефолтная метрика.

 

Если вам критично время падения операторов, включите BFD:

 

/routing ospf interface add interface=all use-bfd=yes

 

Тогда можно будет задавать интервалы, по истечению которых линк считается не активным, по умолчанию это 40 секунд, с BFD можно указать время даже меньше секунды.

Share this post


Link to post
Share on other sites

Не нужны вам никакие зоны.

 

А схема сети которую я приложил остаётся той же ? Меня интересует правильно ли я сделаю если назначу на интерфейсы адресацию 10.10.х.х/24 ?

Edited by Dump

Share this post


Link to post
Share on other sites

Всё поднял ))) Спасибо за совет, почитал ещё вики по ospf mikrotik , дошло )

Share this post


Link to post
Share on other sites

А схема сети которую я приложил остаётся той же ? Меня интересует правильно ли я сделаю если назначу на интерфейсы адресацию 10.10.х.х/24 ?

 

Вы можете использовать любые адреса, например транзитные роутеры в 10 сети, остальные в 172.

Share this post


Link to post
Share on other sites

Добрый день! Апну. Не могу понять почему микротик не отдает в ospf роуты сетей

post-83919-077302200 1424785338_thumb.png

Тестирую кусок в фиолетовом овале, на микротик приходит дефаулт по ospf и микротик должен отдать инфу о подключенных сетях, но не отдает

/routing bgp instance
set default disabled=yes
/routing ospf instance
set [ find default=yes ] name=backbone redistribute-connected=as-type-1 redistribute-other-ospf=as-type-1 redistribute-static=as-type-1 router-id=10.10.40.2
add name=telekom router-id=10.10.40.2
/routing ospf area
add area-id=0.0.0.1 instance=telekom name=telekom
/routing ospf interface
add authentication-key=0 dead-interval=30s interface=vlan41 network-type=point-to-point
add authentication-key=0 cost=40 interface=vlan42 network-type=point-to-point
add authentication-key=0 interface=ether13 network-type=point-to-point
/routing ospf network
add area=telekom comment=bgw02-peer network=10.10.41.0/30
add area=telekom comment=bgw01-peer network=10.10.42.0/30
add area=telekom comment=l2-peer network=10.10.40.0/29
add area=telekom network=10.151.4.0/24
add area=telekom network=10.151.5.0/24

[admin@MikroTik] /routing> /routing ospf route print
# DST-ADDRESS        STATE          COST                                                         GATEWAY         INTERFACE
0 0.0.0.0/0          ext-2          10000                                                        10.10.41.1      vlan41
1 10.10.40.0/29      intra-area     10                                                           0.0.0.0         ether13
2 10.10.41.0/30      intra-area     10                                                           0.0.0.0         vlan41
3 10.10.42.0/30      intra-area     40                                                           0.0.0.0         vlan42
4 10.10.44.0/30      intra-area     20                                                           10.10.41.1      vlan41
[admin@MikroTik] /routing>
[admin@MikroTik] /routing> /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
0 ADo  0.0.0.0/0                          10.10.41.1              110

 

Никак не пойму в чем дело, пробовал и просто на backbone (area 0.0.0.0) перевешивать, все аналогично, со стороны bird ровно, пробовал и помимо дефаулта и другие роуты отдавать на микротик, роуты приходят, но от самого микротика ничего кроме сетей пиринга

Share this post


Link to post
Share on other sites

stub области не хватало

Edited by linx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this