Jump to content
Калькуляторы

Прошу совета с оптимизации схемы MIkrotik

Доброго времени суток уважаемые форумчане.

прошу Вашего совета.

вообщем ситуация вот в чем.

живем в удаленном регионе. оптики нет, так что выживаем как можем. и изобретаем соответственно как можем. вот одно и моих детищ.

покупать скоростные каналы весьма накладно поэтому решил склеить несколько более дешевых каналов и путем балансировки компенсировать проблему скорости.

 

для этого купил в инете VDS засунул в него микротик, VDS подключен к гигабитному каналу.

взяты несколько провадеров от них летитят тунели в VDS с натом.

между этими тунелями и балансирует микротик.

балансировка реализованна просто добавлением gw на ноль маршрутах.

 

собственно вот и вопрос. как оптимизировать схему. на мониторинге интефейсов видно что нагрузка идет не равномерна. и зная приблизительную скорость каждого из провадйеров видно что скорость суммировалась далеко не на 100%.

как приблизиться к этой цыфре?

post-118264-092332800 1414693064_thumb.jpg

Share this post


Link to post
Share on other sites

Вместо балансировки маршрутов на ноль, создайте 5 маршрутов с разными маркировками, в манглах пометьте пакеты из каждого из 5 адрес листов, что бы IP адреса из него шли по указанному каналу.

 

Что бы разбить всех абонентов на 5 групп, можно воспользоваться вот такой штукой:

 

/ip firewall mangle
add action=add-src-to-address-list address-list=ISP1 chain=prerouting per-connection-classifier=src-address:5/4 src-address=192.168.0.0/24
add action=add-src-to-address-list address-list=ISP2 chain=prerouting per-connection-classifier=src-address:5/3 src-address=192.168.0.0/24
add action=add-src-to-address-list address-list=ISP3 chain=prerouting  per-connection-classifier=src-address:5/2 src-address=192.168.0.0/24
add action=add-src-to-address-list address-list=ISP4 chain=prerouting  per-connection-classifier=src-address:5/1 src-address=192.168.0.0/24
add action=add-src-to-address-list address-list=ISP5 chain=prerouting  per-connection-classifier=src-address:5/0 src-address=192.168.0.0/24
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP1 passthrough=no src-address-list=ISP1
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP2 passthrough=no src-address-list=ISP2
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16  new-routing-mark=to_ISP3 passthrough=no src-address-list=ISP3
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16  new-routing-mark=to_ISP4 passthrough=no src-address-list=ISP4
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16  new-routing-mark=to_ISP5 passthrough=no src-address-list=ISP5

 

Либо просто добавляете абонентов вручную, соответственно при перекосах просто перекидываете абонентов куда следует.

 

Другой вариант заюзать OSPF и BFD с очень маленьким временем, тогда при перегрузке канала, он будет автоматически выводится из OSPF и нагрузка пойдет по оставшимся каналам, соответственно этот канал освобождается, OSPF снова заводится и начинает передавать данные через него.

Share this post


Link to post
Share on other sites

не уверен правильный ли вариант в манглах будет. один чел грузанет всю эту систему то обвалиться один канал. остальные будут в состоянии покоя.

потому то и думаю как загрузить все каналы равномерно.

Share this post


Link to post
Share on other sites

... заюзать OSPF и BFD с очень маленьким временем, тогда при перегрузке канала, он будет автоматически выводится из OSPF и нагрузка пойдет по оставшимся каналам, соответственно этот канал освобождается, OSPF снова заводится и начинает передавать данные через него.

АФИГЕТЬ! он превратил это в фичу.

Share this post


Link to post
Share on other sites

не уверен правильный ли вариант в манглах будет. один чел грузанет всю эту систему то обвалиться один канал. остальные будут в состоянии покоя.

потому то и думаю как загрузить все каналы равномерно.

если чел будет торенты качать, то обвалятся все каналы :)

А если только одна закачка с фтп, то по другому никак.

Сааб предложил самый оптимальный для микротиков способ.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this