Jump to content
Калькуляторы

SuperVlan в SNR S3750G и ASR

Такой вопрос:

Пробуем у себя реализацию ip unnumbered с раздачей реальников на пользователя. У snr можно через http://shop.nag.ru/article/nastrojka-super-vlan-ip-unnumbered-na-l2l3-kommutatorah-snr SuperVlan сделать.

Так вот, SNR на аггрегации, asr1002 - брас.

 

Конфиг snr

vlan 1;100;1051
!
vlan 1050
supervlan
subvlan 1051

Interface Ethernet1/0/13
description Link to ASR
media-type copper
switchport mode trunk
switchport trunk allowed vlan 100
!

Interface Ethernet1/0/14
description Link to DES-3200-24
media-type copper
switchport mode trunk
switchport trunk allowed vlan 1051
!

interface Vlan1050
ip address 95.170.175.30 255.255.255.240

100 - управление

1050 - супер влан

1051 - влан пользователя

 

Что на asr теперь должно быть? Нужно саб интерфейс поднимать 1050? 1051?

Или через маршрутизацию как-то решается?

Супер влан пробросить через порт ни в ацессе, ни в транке не дает.

С конечного пользователя пингует только 95.170.175.30.

Share this post


Link to post
Share on other sites

Зачем такая схема? Вам очень нужен L3-connected БРАС и непойми-что-за-железка в качестве терминатора вланов?

Share this post


Link to post
Share on other sites

DVM-Avgoor а что не так? поясните? схема имеет место быть - http://wiki.bitel.ru/index.php/ISG,_схема_со_стартом_сессии_и_ее_авторизацией_по_IP,_выдача_адресов_на_основе_option82

tehmeh через ip unnumbered закручивать? SNR не умеет.

Собственно на самом asrе (если SNR исключаем) все работает через ip unnumbered.

Edited by mod3m

Share this post


Link to post
Share on other sites

DVM-Avgoor а что не так? поясните? схема имеет место быть - http://wiki.bitel.ru...основе_option82

 

Зачем именно l3-connected, если ASR может сам прекрасно терминировать L2? Всякие эти "супервланы" имеют кучу неудобных особенностей, к этому надо будет налепить сверху opt82. И никто не гарантирует что оно будет работать так как вы думаете. В целом не вижу в данной ситуации никакого профита от терминации вланов на китайском счастье.

Share this post


Link to post
Share on other sites

tehmeh через ip unnumbered закручивать? SNR не умеет.

Не используйте SNR для этих целей, как уже отметили выше, ASR сделает это гораздо лучше.

Собственно на самом asrе (если SNR исключаем) все работает через ip unnumbered.

ip unnumbered на ASR != supervlan на любом китайском барахле.

Share this post


Link to post
Share on other sites

У нас работает supervlan на SNR далее на SE100 схема dclips через L3 с option 82

Share this post


Link to post
Share on other sites

DVM-Avgoor,tehmeh да это все понятно, что на ASR надо и не есть хорошо, китайское барахло засовывать в агрегацию. Но сейчас задача частично разгрузить asr. А на большее, как всегда $ не выделяют.

 

ip unnumbered на ASR != supervlan на любом китайском барахле.

Про это не согласен. Даже тут на форуме обсуждали и пришли к выводу, что ip unnumbered и supervlan практически то же самое. Реализация просто разная, суть одна. Из глобальных отличий, в первом случаи маршрут статикой прописывается, во втором этого делать не надо.

 

dm777 а можете если не сложно, поделиться частью конфига SNR и SE100? Схема точно такая же как у вас (так же 82 опция. строим ISG), только вместо SE100 - ASR.

Затык именно возник в моменте этих супервланов, на абонентское устройство адрес приходит какой надо, от него пингуется "шлюз" супервлана SNRа (мак устройства в таблице snr есть), а дальше не идет. Не уж то в сторону vrf смотреть надо? Не понятно, как маршруты завернуть на шлюз asr.

И вопрос, сабинтерфейсы у вас на SE100 для каждого абонента поднимаются или как-то по другому через 1 общий влан все заворачиваете? т.к супервлан на интерфейс не вешается

Share this post


Link to post
Share on other sites

Отдельный ip интерфейс в сторону subscriber интерфейса ASR вроде.

 

А у вас старт то по ip или по DHCP?

Share this post


Link to post
Share on other sites

Про это не согласен. Даже тут на форуме обсуждали и пришли к выводу, что ip unnumbered и supervlan практически то же самое. Реализация просто разная, суть одна. Из глобальных отличий, в первом случаи маршрут статикой прописывается, во втором этого делать не надо.

Неверно. Supervlan это херовый аналог unnumbered host polling, со всеми вытекающими отсюда. Что ни в какое сравнение с unnumbered + dhcp snooping не идет.

Share this post


Link to post
Share on other sites

Отдельный ip интерфейс в сторону subscriber интерфейса ASR вроде.

Вот здесь поподробнее, если можно. Отдельный, имеете ввиду с 30 маской или все таки допустим с /24 абонентской сделать sub? (хотя пробовал играться и кидал влан. маршрута с абонентского ПК нет)

Повторюсь, сейчас выходит:

100 - управление (на влане адрес 95.170.175.6)

1050 - супервлан (ип 95.170.175.30/28, на интерфейс не вешается - "Can not set supervlan vlan 1050 as trunk switchport allowed vlan" так и "Can not set super vlan 1050 as access switchport access vlan", тут и понятно, что он идет только внутри SNR)

1051 - (95.170.175.17 - у абонента, пинги до 95.170.175.30, 95.170.175.6 идут)

вот так сейчас на SNR:

sh vlan

VLAN Name         Type       Media     Ports
---- ------------ ---------- --------- ----------------------------------------
1    default      Static     ENET      Ethernet1/0/1       Ethernet1/0/2
                                      Ethernet1/0/3       Ethernet1/0/4
                                      Ethernet1/0/5       Ethernet1/0/6
                                      Ethernet1/0/7       Ethernet1/0/8
                                      Ethernet1/0/9       Ethernet1/0/10
                                      Ethernet1/0/11      Ethernet1/0/12
                                      Ethernet1/0/13      Ethernet1/0/14
                                      Ethernet1/0/15      Ethernet1/0/16
                                      Ethernet1/0/17      Ethernet1/0/18
                                      Ethernet1/0/19      Ethernet1/0/20
                                      Ethernet1/0/21      Ethernet1/0/22
                                      Ethernet1/0/23      Ethernet1/0/24
                                      Ethernet1/0/25      Ethernet1/0/26
                                      Ethernet1/0/27      Ethernet1/0/28
100  VLAN0100     Static     ENET      Ethernet1/0/13(T)
1050 VLAN1050     Static     ENET
1051 VLAN1051     Static     ENET      Ethernet1/0/14(T)

sh ip route

Gateway of last resort is 95.170.175.14 to network 0.0.0.0

S*      0.0.0.0/0 [1/0] via 95.170.175.14, Vlan100  tag:0
C       95.170.175.0/28 is directly connected, Vlan100  tag:0
C       95.170.175.16/28 is directly connected, Vlan1050  tag:0
C       127.0.0.0/8 is directly connected, Loopback  tag:0
Total routes are : 4 item(s)

Может маршрутизация по другому строится?

95.170.175.14 - ASR

В схеме ещё есть 3200 на доступе, транком как раз 13 порт, у абонента 1051 в ацессе. исключил из пояснения его, не влияет же.

 

А у вас старт то по ip или по DHCP?

DHCP

 

 

Неверно. Supervlan это херовый аналог unnumbered host polling, со всеми вытекающими отсюда. Что ни в какое сравнение с unnumbered + dhcp snooping не идет.

Не, ну поясните тогда в чем конкретно различия или в мануал тыкните. Просто сужу по мануалам и комментариям в форумах, где говорится что это именно аналог. Что такого можно через ip unnumbered, чего нельзя в supervlan? Мне казалось, что задача в целом то у них одна или не?

Share this post


Link to post
Share on other sites
Не, ну поясните тогда в чем конкретно различия или в мануал тыкните. Просто сужу по мануалам и комментариям в форумах, где говорится что это именно аналог. Что такого можно через ip unnumbered, чего нельзя в supervlan? Мне казалось, что задача в целом то у них одна или не?

 

 

Supervlan на SNR и прочих DigitalChina ограничен 127 subvlan'ами, в ip unnumbered такого ограничения нет. Supervlan работает только в режиме host polling, делая ARP Request для ip к каждому subvlan на интерфейсе: "Ты знаешь про этого чувака? Нет? Ладно, а ты?". Реализация забагованная до нельзя, почитайте хотя бы тему про QTech.

 

ip unnumbered в связке с DHCP Snooping работает гораздо эффективнее.

Share this post


Link to post
Share on other sites

P.S. К вопросу от том "Что можно?". У нас на 6509 каталисте в одном loopback висит 20 /24 сетей, что позволяет более плотно использовать адресное пространство (мы до сих пор всем постоянные белые отдаем) и горя не знать. Supevlan только с VLAN'ом на коммутатор сможет что-то похожее предложить, хотя скорее железка ляжет после 4-й secondary сети по CPU, или сеть от уровня ARP'ов, которые этот самый Supervlan нагенерирует.

Share this post


Link to post
Share on other sites

P.S. К вопросу от том "Что можно?". У нас на 6509 каталисте в одном loopback висит 20 /24 сетей, что позволяет более плотно использовать адресное пространство (мы до сих пор всем постоянные белые отдаем) и горя не знать. Supevlan только с VLAN'ом на коммутатор сможет что-то похожее предложить, хотя скорее железка ляжет после 4-й secondary сети по CPU, или сеть от уровня ARP'ов, которые этот самый Supervlan нагенерирует.

А как ограничение в 4к вланов и 4к svi обошли?

Share this post


Link to post
Share on other sites

А у нас на коммутатор схема, legacy мать ее. Планируем брать BRAS и делать уже человеческую схему.

Share this post


Link to post
Share on other sites

Когда то настраивал Supervlan :

 

vlan 1;101-124

!

vlan 5

name mngt

!

vlan 9

name IPTV_sourse

!

vlan 10

name IPTV

!

vlan 20

name INET

!

vlan 100

supervlan

subvlan 101-124

!

port-group 1

!

Interface Ethernet1/0/1

description Leninskaya_44

switchport mode trunk

switchport trunk allowed vlan 10;101

switchport trunk native vlan 5

!

Interface Ethernet1/0/2

description Kujbysheva_19

switchport mode trunk

switchport trunk allowed vlan 10;102

switchport trunk native vlan 5

!

Interface Ethernet1/0/3

description Suvorova_21

switchport mode trunk

switchport trunk allowed vlan 10;20;103

switchport trunk native vlan 5

!

Interface Ethernet1/0/4

description Leninskaya_42

switchport mode trunk

switchport trunk allowed vlan 10;104

switchport trunk native vlan 5

!

Interface Ethernet1/0/5

description Kujbysheva_13

switchport mode trunk

switchport trunk allowed vlan 10;20;105

switchport trunk native vlan 5

!

Interface Ethernet1/0/6

description Kalinina_13

switchport mode trunk

switchport trunk allowed vlan 10;20;106

switchport trunk native vlan 5

!

Interface Ethernet1/0/7

switchport mode trunk

switchport trunk allowed vlan 10;107

switchport trunk native vlan 5

!

Interface Ethernet1/0/8

switchport mode trunk

switchport trunk allowed vlan 10;20;108

switchport trunk native vlan 5

!

Interface Ethernet1/0/9

switchport mode trunk

switchport trunk allowed vlan 10;109

switchport trunk native vlan 5

!

Interface Ethernet1/0/10

switchport mode trunk

switchport trunk allowed vlan 10;110

switchport trunk native vlan 5

!

Interface Ethernet1/0/11

switchport mode trunk

switchport trunk allowed vlan 10;111

switchport trunk native vlan 5

!

Interface Ethernet1/0/12

switchport mode trunk

switchport trunk allowed vlan 10;112

switchport trunk native vlan 5

!

Interface Ethernet1/0/13

switchport mode trunk

switchport trunk allowed vlan 10;113

switchport trunk native vlan 5

!

Interface Ethernet1/0/14

switchport mode trunk

switchport trunk allowed vlan 10;114

switchport trunk native vlan 5

!

Interface Ethernet1/0/15

switchport mode trunk

switchport trunk allowed vlan 10;115

switchport trunk native vlan 5

!

Interface Ethernet1/0/16

switchport mode trunk

switchport trunk allowed vlan 10;116

switchport trunk native vlan 5

!

Interface Ethernet1/0/17

switchport mode trunk

switchport trunk allowed vlan 10;117

switchport trunk native vlan 5

!

Interface Ethernet1/0/18

switchport mode trunk

switchport trunk allowed vlan 10;118

switchport trunk native vlan 5

!

Interface Ethernet1/0/19

media-type copper

switchport access vlan 20

!

Interface Ethernet1/0/20

media-type copper

switchport access vlan 20

!

Interface Ethernet1/0/21

media-type copper

switchport access vlan 9

!

Interface Ethernet1/0/22

media-type copper

no vlan ingress enable

switchport mode trunk

switchport trunk allowed vlan 5;20

switchport trunk native vlan 5

!

Interface Ethernet1/0/23

media-type copper

switchport mode trunk

switchport trunk allowed vlan 10;20;123-124

switchport trunk native vlan 5

port-group 1 mode active

!

Interface Ethernet1/0/24

media-type copper

switchport mode trunk

switchport trunk allowed vlan 10;20;123-124

switchport trunk native vlan 5

port-group 1 mode active

!

Interface Ethernet1/0/25

switchport access vlan 5

!

Interface Ethernet1/0/26

switchport access vlan 5

!

Interface Ethernet1/0/27

switchport access vlan 5

!

Interface Ethernet1/0/28

switchport access vlan 5

!

Interface Port-Channel1

!

interface Vlan5

ip address 192.168.254.1 255.255.255.0

!

interface Vlan9

ip pim dense-mode

!

interface Vlan10

ip pim dense-mode

!

interface Vlan20

ip address 192.168.11.1 255.255.255.0

!

interface Vlan100

ip local proxy-arp

ip address 192.168.100.1 255.255.255.0

!forward protocol udp 67(active)!

ip helper-address 192.168.11.5 /* DHCP сервер */

!

ip route 0.0.0.0/0 192.168.11.2

!

end

 

Работало нормально в рабочей сети.

Share this post


Link to post
Share on other sites

У нас на 6509 каталисте

Ну тогда понятно.. Каждый строит на чем дают. Сами же видите, у людей рабочие схемы и через супервлан реализованы. Как понимаю, проблем особых у них с этим нет, если пишут - "Работало нормально в рабочей сети.". Так же кто-то с брасами не заморачивается особо и на тазиках все делает.

 

Олег Кривицкий, благодарю! Увидел что хотел:

 

interface Vlan20
ip address 192.168.11.1 255.255.255.0
ip route 0.0.0.0/0 192.168.11.2

Хотя подобную связку пробовал, буду пробовать ещё. Как понимаю, сеть 192.168.100.0/24 только в супервлане.

А через 20 влан, у вас маршрут в сторону браса.

Share this post


Link to post
Share on other sites

Я и не говорил, что не будет работать. Просто предостерег, поделился так сказать опытом. Наступать на грабли или нет дело ваше.

Из примера Олега 20 сабвланов это ни о чем, на серьезной нагрузке начнутся проблемы.

Share this post


Link to post
Share on other sites

У нас на 6509 каталисте

Ну тогда понятно.. Каждый строит на чем дают. Сами же видите, у людей рабочие схемы и через супервлан реализованы. Как понимаю, проблем особых у них с этим нет, если пишут - "Работало нормально в рабочей сети.". Так же кто-то с брасами не заморачивается особо и на тазиках все делает.

 

Олег Кривицкий, благодарю! Увидел что хотел:

 

interface Vlan20
ip address 192.168.11.1 255.255.255.0
ip route 0.0.0.0/0 192.168.11.2

Хотя подобную связку пробовал, буду пробовать ещё. Как понимаю, сеть 192.168.100.0/24 только в супервлане.

А через 20 влан, у вас маршрут в сторону браса.

Да 20 влан на брас, но сеть была маленькая /24, на большой нагрузке схема не проверялась ...

Edited by Олег Кривицкий

Share this post


Link to post
Share on other sites

Да 20 влан на брас, но сеть была маленькая /24, на большой нагрузке схема не проверялась ...

Понятно.

 

Не взлетает схема. Работает только, если на брасе саб поднять пользовательский с назначением адреса. Но в таком случаи, смысла нет во всей схеме.

Может на брасе ещё с маршрутизацией что-то делать надо в сторону железки с супервланом?

 

Может тогда если не supervlan, а через ip unnumbered на циске сможет кто-нибудь пояснить как работает связка?

L2 (3200) -> L3 (пускай будет какой-нибудь catalyst 3550) -> Bras (asr1002)

L3 примерно понимаю, а вот как идет связь с брасом

Edited by mod3m

Share this post


Link to post
Share on other sites

Проблема решена. Всем спасибо. Дело естественно в маршрутизации было.

Share this post


Link to post
Share on other sites

mod3m, опишите способ решения если Вас не затруднит.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this