Jump to content
Калькуляторы

Балансировка 2х провайдеров static IP + PPP USB modem билайн Мгновенный обрыв PPP

Прошу помощи.

Для организации моей задумки у Вас был приобретен роутер Mikrotik RB2011UiAS-2HnD-IN. Обновлены софт и прошивка до последних версий

Имеются два провайдера:

1 провайдер - Статический IP адрес 172.19.12.253/24 шлюз 172.19.12.250 канал около 5 мегабит down и 1 мегабит up

2 провайдер - Beeline 3g USB modem huawei E3131 с последней прошивкой с внешней антенной соединение PPP. Предварительно модем был переведен в режим только модем. Виртуальный сидиром и кардридер отключены. Data channel: 0 Info channel: 1 APN: home. beeline.ru. Остальное по-умолчанию. MTU 1500, пробовал снижать - безрезультатно. Уровень сигнала -87 -89.

Локальная сеть с адресами 192.168.25.0/24

Настройка производилась по мануалу с сайта микротика методом PCC (per connection classifier) wiki.mikrotik.com/wiki/Manual:PCC. Интерфейсы были названы аналогично тому, как в мануале.

Так как у билайна динамическая машрутизация и при каждом соединении выдается новый шлюз из диапазона 10.112.112.0-10.112.113.0 было прописано следующее правило mangle

/ ip firewall mangle add chain=prerouting dst-address=10.112.0.0/16  action=accept in-interface=LAN

Проблема в том что при совместном использовании двух соединений происходит мгновенный обрыв PPP билайна. Соединение активно до тех пор пока я не применяю маскарад на этот интерфейс. Без маскарада я пускаю пинги на этот интерфейс и все работает.

 

Грешил на недостаточность питания USB порта Mikrotik. Был самостоятельно смонтирован инжектор питания с блоком питания 5v 1A от старого телефона. Не помогло. При этом, если пустить трафик исключительно на билайн то все работает нормально, соединение не обрывается.

 

Было подозрение, что билайн как-то отслеживает наличие роутера за модемом, была прописана следующая строка из этой статьи mstream.com.ua/mikrotik-tipichnie-problemi-i-ih-resheniay.html из пункта 6.13

 

Прописал эту строку

/ip firewall mangle add action=change-ttl chain=prerouting new-ttl=increment:1 passthrough=yes

и поднял вверх. Не помогло. Пробовали уже помочь знающие ребята, имеющие опыт настройки микротиков, но безрезультатно.

 

Supout.rif здесь https://yadi.sk/d/BxO2AgixcBek9

0.txt

1.txt

Edited by mister_oleg

Share this post


Link to post
Share on other sites

Что бы делать балансировку нужно иметь либо два одинаковых канала, либо с определенной разницей в скорости, но стабильных. 3G модем под такую задачу не подходит. Кроме всего вы не правильно делаете манглы и видимо НАТ, т.к. dst.address это адрес, на который идет запрос в сторону интернета и с внешним адресом роутера он не имеет никакой связи. Соответственно вам нужно убрать все настройки что накрутили, и установить какое-то одно соединение в качестве основного с проверкой доступности пингом, а второе резервное, когда основное отключится.

Share this post


Link to post
Share on other sites

Saab95 в моем первом посте есть мануал на сайте микротика, по нему все настраивалось. Предложите, пожалуйста, свой вариант с конкретными командами. У нас 3g очень даже не плохо работает. в час пик 2 мегабита, ночью до 8-10

Share this post


Link to post
Share on other sites

тупой вопрос:

 

у модема галочка Dial On Demand снята?

 

я вообще как то настраивал PCC для интереса на двух 3G модемах и все работало.

Share this post


Link to post
Share on other sites

Saab95 в моем первом посте есть мануал на сайте микротика, по нему все настраивалось. Предложите, пожалуйста, свой вариант с конкретными командами. У нас 3g очень даже не плохо работает. в час пик 2 мегабита, ночью до 8-10

 

У вас ошибка:

 

/ ip firewall mangleadd chain=prerouting dst-address=10.112.0.0/16  action=accept in-interface=LAN

 

Зачем это правило? Если хотите сделать НАТ, то укажите правило маскардинга по src.address = 192.168.0.0/24 (ваша локальная сеть), т.к. при указании out.interface работать не будет.

Share this post


Link to post
Share on other sites

тупой вопрос:

 

у модема галочка Dial On Demand снята?

 

я вообще как то настраивал PCC для интереса на двух 3G модемах и все работало.

 

drhyperkalich, все три галочки сняты

 

Saab95, вот здесь почитайте сначала, а потом кричите что все неправильно. Там каждая строка объясняется. Для Вас процитирую:

 

Policy routing

/ ip firewall mangle
add chain=prerouting dst-address=10.111.0.0/24  action=accept in-interface=LAN
add chain=prerouting dst-address=10.112.0.0/24  action=accept in-interface=LAN

 

With policy routing it is possible to force all traffic to the specific gateway, even if traffic is destined to the host (other that gateway) from the connected networks. This way routing loop will be generated and communications with those hosts will be impossible. To avoid this situation we need to allow usage of default routing table for traffic to connected networks.

 

10.112.0.0/16 Из этой подсети при каждом подключении выдается новый адрес шлюза

Edited by mister_oleg

Share this post


Link to post
Share on other sites

Saab95, вот здесь почитайте сначала, а потом кричите что все неправильно. Там каждая строка объясняется. Для Вас процитирую:

 

Policy routing

/ ip firewall mangle
add chain=prerouting dst-address=10.111.0.0/24  action=accept in-interface=LAN
add chain=prerouting dst-address=10.112.0.0/24  action=accept in-interface=LAN

 

With policy routing it is possible to force all traffic to the specific gateway, even if traffic is destined to the host (other that gateway) from the connected networks. This way routing loop will be generated and communications with those hosts will be impossible. To avoid this situation we need to allow usage of default routing table for traffic to connected networks.

 

10.112.0.0/16 Из этой подсети при каждом подключении выдается новый адрес шлюза

 

Вот так делят абонентов на 2 канала интернета, при этом никакие внешние адреса в настройках не фигурируют и все работает:

 

/ip firewall mangle
add action=add-src-to-address-list address-list=ISP1 chain=prerouting per-connection-classifier=src-address:2/1 src-address=192.168.0.0/24
add action=add-src-to-address-list address-list=ISP2 chain=prerouting per-connection-classifier=src-address:2/0 src-address=192.168.0.0/24
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP1 passthrough=no src-address-list=ISP1
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP2 passthrough=no src-address-list=ISP2

Share this post


Link to post
Share on other sites

Saab95, вот здесь почитайте сначала, а потом кричите что все неправильно. Там каждая строка объясняется. Для Вас процитирую:

 

Policy routing

/ ip firewall mangle
add chain=prerouting dst-address=10.111.0.0/24  action=accept in-interface=LAN
add chain=prerouting dst-address=10.112.0.0/24  action=accept in-interface=LAN

 

With policy routing it is possible to force all traffic to the specific gateway, even if traffic is destined to the host (other that gateway) from the connected networks. This way routing loop will be generated and communications with those hosts will be impossible. To avoid this situation we need to allow usage of default routing table for traffic to connected networks.

 

10.112.0.0/16 Из этой подсети при каждом подключении выдается новый адрес шлюза

 

Вот так делят абонентов на 2 канала интернета, при этом никакие внешние адреса в настройках не фигурируют и все работает:

 

/ip firewall mangle
add action=add-src-to-address-list address-list=ISP1 chain=prerouting per-connection-classifier=src-address:2/1 src-address=192.168.0.0/24
add action=add-src-to-address-list address-list=ISP2 chain=prerouting per-connection-classifier=src-address:2/0 src-address=192.168.0.0/24
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP1 passthrough=no src-address-list=ISP1
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=to_ISP2 passthrough=no src-address-list=ISP2

 

Перечитайте, пожалуйста, первый пост внимательнее, и если не знаете решения или не можете ничего подсказать, оставьте данный топик.

Share this post


Link to post
Share on other sites

Вот так делят абонентов на 2 канала интернета, при этом никакие внешние адреса в настройках не фигурируют и все работает:

 

Вообще существует много вариантов как их поделить, у каждого есть свои преимущества и недостатки. В этом мануале их 7. Еще существует много подвидов указанных вариантов. Я понимаю, что у людей все работает. В мануалах, которые мне попадались разбираются случаи с двумя провайдерами, у которых адреса и шлюзы статические. А у билайна адреса и шлюзы динамические. Лучше подскажите скрипт, который бы их узнавал и при изменении менял бы в ip firewall / ip route

Edited by mister_oleg

Share this post


Link to post
Share on other sites

Вообще существует много вариантов как их поделить, у каждого есть свои преимущества и недостатки. В этом мануале их 7. Еще существует много подвидов указанных вариантов. Я понимаю, что у людей все работает. В мануалах, которые мне попадались разбираются случаи с двумя провайдерами, у которых адреса и шлюзы статические. А у билайна адреса и шлюзы динамические. Лучше подскажите скрипт, который бы их узнавал и при изменении менял бы в ip firewall / ip route

 

Так проблем никаких нет - ставите еще 2 микротика, первый принимает канал одного провайдера, второй канал второго, третьим их собираете. Соответственно у вас уже будут статические адреса и статические маршруты.

Share this post


Link to post
Share on other sites

Может хватит мозги епать?

http://www.draytek.com/index.php?option=com_k2&view=item&layout=item&id=2639&Itemid=596〈=en

либо подобные.

Делается всё за пару секунд.

И работает действительно балансировка каналов, а не "деление" абонентов кому куда.

Share this post


Link to post
Share on other sites

Может хватит мозги епать?

http://www.draytek.c...mid=596〈=en

либо подобные.

Делается всё за пару секунд.

И работает действительно балансировка каналов, а не "деление" абонентов кому куда.

что то подобное тплинк за бешанные бабки(валяется хер кому продашь) не смог путем отбалансировать 2 абсолютно одинаковых канала, настроек в нем было минимум, а вот копеешный микротик работает уже второй год и не кашляет

Share this post


Link to post
Share on other sites

Давайте придерживаться темы. Есть задача сделать балансировку имеющимися средствами

Share this post


Link to post
Share on other sites

/ ip firewall mangle add chain=prerouting dst-address=10.112.0.0/16 action=accept in-interface=LAN

Параметр dst-address замените на dst-address-list. Для начала.

saab95 прав в своих советах, в routeros NAT слегка через жопу работает. Вы проверяли его советы?

3G свисток работает как бридж или как роутер?

Share this post


Link to post
Share on other sites

3G свисток работает как бридж или как роутер?

в первом посту написано, что работает как модем (бридж)

 

Вот что ответили из техподдержки микротика:

У билайна особая маршрутизация, все последующие их устройства в подсети 10.0.0.0/8, но

сервер похоже где-то ещё. Т.е. соединение 3G (PPP) устанавливается с этим сервером,

а потом трафик идёт уже в 10.0.0.0./8

Потому соединение с сервером (служебное для PPP) после подключения PPP тут же пропадает.

И статус интерейса уходит в DOWN, потом снова подключается и пропадает, и т.д.

Т.н. "Dual Access" от билайна.

Потому нам нужно сказать микротику "к серверу PPP ходи только через ISP2". Но мы не знаем

пока что адреса (или диапазона адресов, т.е. подсети) этого сервера. А имя хоста в маршруте

не укажешь.

Как узнаем диапазон адресов, так сможем указать и PPP-соедение не будет рваться

(т.к. служебные пакеты будут в обе стороны доходить).

Вероятно в этом и есть причина TermReq пакета в PPP-соединении - как в Cisco писали - One of the PPP peers do not respond / terminates connection.

Короче нужен адрес (или адрес подсети) сервера PPP билайна. Или модем не билайновский (где не будет такого dual access).

Попробуйте до их техподдержки достучаться (только они могут сказать "проблема в вашем роутере", но вы попробуйте добиться ответа).

 

 

такая же проблема была и у PPTP-пользователй билайна (обычных кабельных, типа FTTx)

решалось только через nslookup с компьютера (при отсутствии роутера) и последующей настройке

маршрута на роутере...

 

скорее всего пробелма именно в этом.

ну или первая из проблем в этом, но остальное мы достаточно тщательно уже проверили.

пока что все подозрения именно на это.

Share this post


Link to post
Share on other sites

А у билайна адреса и шлюзы динамические. Лучше подскажите скрипт, который бы их узнавал и при изменении менял бы в ip firewall / ip route

Могу подсказать на примере Мегафона. Можно взять статический IP за 300 руб/месяц, но мне не дали, сказали только для юр.лиц, а в Краснодаре можно взять любому. Я взял белый динамический за 100 руб/месяц и привязал его через DNS-Master от RU-Centr (наш аналог DynDNS и NO-IP) к своему поддомену. Теперь в роутере указываю вместо статического айпи свой поддомен, всё работает. Можно вводить айпи цифрами, но мне не нужно, я их не узнавал. После подключения 3g модема через 1-1,5 мин DNS уже направляет куда нужно.

Edited by SAMEK

Share this post


Link to post
Share on other sites

А у билайна адреса и шлюзы динамические.

Не епи мозг. Адрес и шлюз в локалке Билайн не меняется годами. Даже адреса впн и днс серверов можно узнать и прописать статично. Я так и сделал и никаких проблем нет.

Share this post


Link to post
Share on other sites

А у билайна адреса и шлюзы динамические.

Не епи мозг. Адрес и шлюз в локалке Билайн не меняется годами. Даже адреса впн и днс серверов можно узнать и прописать статично. Я так и сделал и никаких проблем нет.

Готов ответить за свои слова?

При каждом новом подключении меняется не только адрес, но и шлюз. Называется динамическая маршрутизация для балансировки нагрузки. В микротике это все отлично видно. А зачем узнавать адреса днс, если их и так видно? В общем сударь, идите лесом!

Share this post


Link to post
Share on other sites

Да и уже давно можно указывать домен в микротике, у самого на билайне так сделано.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this