Jump to content
Калькуляторы

multicast cisco 3560g pim-sm+msdp+bgp

Доброе утро.

Суть в следующем, есть стык с внешним источником мультикаста.

Есть локально сформированный контент с адресом источника, предположим 192.168.37.104, хотелось бы отдавать локальный мультикаст в существующий стык.

Прилагаю кусок конфига, насколько понимаю задача анонсировать лок. источник в bgp safi multicast, но в случае если прописываю network, сеть все равно не анонсируется.

 

interface Vlan6 (интерфейс с внешним источником)

description MCAST-MSK

ip address 192.168.37.2 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim bsr-border

ip pim sparse-mode

!

interface Vlan7

ip address 192.168.37.6 255.255.255.252

!

router bgp 64513

bgp router-id 192.168.37.2

bgp log-neighbor-changes

neighbor 192.168.37.1 remote-as 8359

neighbor 192.168.37.1 transport path-mtu-discovery

neighbor 192.168.37.1 version 4

neighbor 192.168.37.5 remote-as 8359

neighbor 192.168.37.5 transport path-mtu-discovery

neighbor 192.168.37.99 remote-as 64513

neighbor 192.168.37.99 transport path-mtu-discovery

neighbor 192.168.37.99 version 4

neighbor 192.168.37.131 remote-as 64513

neighbor 192.168.37.131 transport path-mtu-discovery

neighbor 192.168.37.131 version 4

!

address-family ipv4

redistribute connected

no neighbor 192.168.37.1 activate

neighbor 192.168.37.5 activate

neighbor 192.168.37.99 activate

neighbor 192.168.37.131 activate

no auto-summary

no synchronization

network 192.168.37.0

exit-address-family

!

address-family ipv4 multicast

neighbor 192.168.37.1 activate

neighbor 192.168.37.99 activate

neighbor 192.168.37.131 activate

no auto-summary

exit-address-family

!

i

ip pim rp-address 192.168.37.2

ip msdp peer 192.168.37.1 remote-as 8359

ip msdp cache-sa-state

 

пробовал анонсировать сеть и как 192.168.37.104/32 и как 192.168.37.0/24.

 

address-family ipv4 multicast

neighbor 192.168.37.1 activate

neighbor 192.168.37.99 activate

neighbor 192.168.37.131 activate

network 192.168.37.104 mask 255.255.255.255

no auto-summary

exit-address-family

 

 

sh bgp ipv4 multicast показывает только что мне анонсится

Network Next Hop Metric LocPrf Weight Path

*> 172.16.248.0/21 192.168.37.1 0 8359 i

 

если смотреть sh ip mroute, видно

(192.168.37.103, 239.255.37.123), 05:23:47/00:02:55, flags: PTA

Incoming interface: Vlan4, RPF nbr 0.0.0.0

Outgoing interface list: Null

 

т.е. локально сформированный мультикаст в табличке есть

Share this post


Link to post
Share on other sites

spartak

как у вас представлен хост 192.168.37.104 в unicast-таблице маршрутизации? Нужно анонсировать не /32, не /24, а так, как он выглядить в unicast-таблице и анонсировать его надо в ipv4 multicast пространстве, а не просто в ipv4 как это у вас сделано в конфиге

address-family ipv4

redistribute connected

no neighbor 192.168.37.1 activate

neighbor 192.168.37.5 activate

neighbor 192.168.37.99 activate

neighbor 192.168.37.131 activate

no auto-summary

no synchronization

network 192.168.37.0

exit-address-family

!

address-family ipv4 multicast

neighbor 192.168.37.1 activate

neighbor 192.168.37.99 activate

neighbor 192.168.37.131 activate

no auto-summary

exit-address-family

 

Вот вам рабочий пример в контексте bgp ipv4-multicast:

 

hostname R2

!

interface FastEthernet0/0

ip address 1.1.1.2 255.255.255.252

duplex half

speed auto

!

interface FastEthernet0/1

ip address 2.2.2.1 255.255.255.252

duplex auto

speed auto

!

router bgp 2

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 1

!

address-family ipv4

no neighbor 1.1.1.1 activate

no auto-summary

no synchronization

exit-address-family

!

address-family ipv4 multicast

neighbor 1.1.1.1 activate

no auto-summary

no synchronization

network 2.2.2.0 mask 255.255.255.252

exit-address-family

!

R2#show bgp ipv4 mul

BGP table version is 2, local router ID is 1.1.1.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

 

Network Next Hop Metric LocPrf Weight Path

*> 2.2.2.0/30 0.0.0.0 0 32768 i

с другой стороны:

R1#show bgp ipv4 multicast

BGP table version is 2, local router ID is 1.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

 

Network Next Hop Metric LocPrf Weight Path

*> 2.2.2.0/30 1.1.1.2 0 0 2 i

 

Это то, что касается ipv4-multicast, теперь вам ещё по msdp нужно отдать те (S,G), которые нужно вещать в as8359

 

Ну и естественно, нужно чтобы с другой стороны приняли префиксы по bgp и (S,G) списки по msdp (т.е. соответствующим образом были настроены разрешающие фильтры в вашу сторону)

Share this post


Link to post
Share on other sites

Src ip источника можно и по unicast спонсировать. Вы группу и src все равно по msdp передадите. Для multicast нужно знать по msdp куда отправить report и маршрут до src, чтобы потом не сделать prune на поток. Для чего в bgp именно family multicast делать анонс?

Share this post


Link to post
Share on other sites

dmvy

дело в том, что классическая схема inter-as взаимодействия по мультику это именно pim+msdp+mbgp. Используется именно mbgp, а не просто bgp ipv4 unicast потому что значительно кол-ва оборудования(и даже современного) не умеют полноценного vrf-multicast и поэтому приходится гонять multicast в GRT. А если в GRT принимать всякую фигню от клиентов/пиров/апстримов(как предлагаете Вы), то рано или поздно будет банальное пересечение сетей, потому что очень часто у мультикаста серый ip.src и кончится может всё это очень печально.

 

В любом случае, ответ на вопрос

Для чего в bgp именно family multicast делать анонс?

потому что as-партнёр ждёт его там, а не в обычном unicast-v4.

 

А делать различные схемы взаимодействия от того, что с обеих сторон операторы что-то умеют или не умеют не разумно - это прямое увеличение OPEX. Проще по возможности использовать единую схему, а не устраивать из сети лабораторию (для этого есть gns3 и подобные средства)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this