Jump to content
Калькуляторы

Mikrotik 951 точка многоточка автоматическое добавление маршрутов динамическая маршрутизация

Доброго времени суток!

 

Есть два (Mikrotik 951) роутера, R1 с публичным адресом, R2 за NAT другого провайдера. Между R1(172.16.0.1) и R2(172.16.0.252) SSTP тоннель. За R1 находится ресурс (10.15.1.94 gw 10.15.1.1) который должен быть доступен из сети (10.15.2.0/24 gw для клиентов этой сети 10.15.2.1) за R2.

Задача решается прописыванием на R2 маршрута 10.15.1.0/24 GW 172.16.0.1 и на R1 10.15.2.0/24 GW 172.16.0.252

т.е. для каждого нового клиента на R1 необходимо будет вручную прописывать маршрут на его ip.

Как сделать, чтобы маршрут на сеть 10.15.2.0/24 с шлюзом интерфейса добавлялся автоматически при его возникновении?

Могут ли за каждым роутером клиентом с разным ip 172.16.0.xxx на примере R2 быть одинаковые сети 10.15.2.0/24 ?

на скриншоте 1 пакет пинга.

Share this post


Link to post
Share on other sites

Включите OSPF и укажите сети для анонса. Соответственно как ее установите на роутере, так все узнают в какую сторону отправлять пакеты для нее.

Share this post


Link to post
Share on other sites

Спасибо за направление!

 

Получилось вот так.

#### R1

 

/routing ospf instance

set [ find default=yes ] name=OSPF_MAIN_ROUTER router-id=172.16.0.1

/routing ospf network

add area=backbone network=172.16.0.0/24

 

 

#### R2

 

/routing ospf instance

set [ find default=yes ] name=CLIENT_252 redistribute-connected=as-type-2 router-id=172.16.0.252

/routing ospf network

add area=backbone network=172.16.0.0/24

 

В принципе работает, может что еще добавить, изменить?

Share this post


Link to post
Share on other sites

Ну лично я бы добавил In/Out-фильтры, чтобы исключить попадания всякой бяки куда не надо. В остальном - простое лучше сложного.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this