Jump to content
Калькуляторы

APC SU3000RMINET - замена батарей.. Не проходит калибровка

Достался почти даром старенький APC SU3000RMINET с дохлыми батареями (не заменялись с рождения).

Smart-UPS 3000 RM
Firmware Revision : 92.14.I
Manufacture Date  : 07/13/04

Заменил аккумуляторы, решил сделать калибровку, для начала "по-простому" - с помощью фирменного софта от АРС.

Но.. Получилось "как всегда".. С нагрузкой 900 Вт (~42%) калибровка идёт 3 мин., индикатор заряда батареи (на морде) за это время опускается до последней точки и упс переходит на питание от сети. Т.о. ничего не калибруется..

Нагуглил инфу о том, что после замены батареи необходимо сначала скорректировать значение "регистра 0" (увеличить до FF).

После чего произвести калибровку "обычным путём". Но не тут-то было!

УПС категорически не желает пускать в режим "PROG" (Shift-Y+два раза "1" с паузой 2-3 сек). После Shift-Y в терминал выводится, как и положено, - SM, а вот дальше затык.. Как не изгалялся с нажатием "1", ничего не происходит.. В терминале пустота, никакой реакции до тех пор пока снова не нажмёшь Shift-Y. Да, текущее значение регистра "0" - 30.

Попытался откалибровать софтиной UpsDiag 2.0, в ней есть кнопка "Коррекция после замены батарей", жму, как положено, при заряде 100% и подключённой нагрузке - в ответ только лишь мигание всех светодиодов линейки индикации заряда батареи..

Попытался с помощью той же софтины поправить вручную регистр "0" - пишет Не могу записать в "EEPROM"..

Одним словом - тупик.. :(

Плюнул на всё это, как говорил товарищ Бендер, слюной, тупо подключил нагрузку (те же 900 Вт) и выдернул вилку питания..

Через 3 мин. индикатор заряда сказал "приехали" (один светодиод из всей линейки светился), НО!! Упс оттарабанил на батарейке 26 мин., как с куста!

После перезапуска снова решил проверить значение пресловутого "регистра 0" - увы - те же 30...

После всего этого в раздумье.. Реально эту железку привести в "правильное состояние", или ещё раз плюнуть слюной??

Share this post


Link to post
Share on other sites

Отдайте в сервис на калибровку. Аккумуляторы новые нормальные?

Share this post


Link to post
Share on other sites

Отдайте в сервис на калибровку.

Пока не вижу смысла. Всё необходимое (помещение, инструмент, "голова/руки", etc) за исключением доп. документации, имеется.

Аккумуляторы новые нормальные?

Естественно. Практически "родные" SVEN-ы (из того же Китая :)) 17 А*ч

Share this post


Link to post
Share on other sites

Упс оттарабанил на батарейке 26 мин., как с куста!

Так и должно быть, попробуйте предыдущий UPS Diag, или сервис, или apcfix.

Share this post


Link to post
Share on other sites

...попробуйте предыдущий UPS Diag, или сервис, или apcfix.

А смысл? Если доступа к пресловутому "регистру 0" нет и никаких изменений в нём не произошло?

Как я понял, UpsDiag именно по этой причине и не может произвести калибровку.

Подозреваю, что в данной фирмваре (92.14.I) доступ в "PROG" дополнительно защищён чем-то "железным".

Т.е. надо что-то где-то перепаять/перемкнуть/разомкнуть.

 

UPD.

Добавил картинку от UpsDiag. Это если нажать кнопку "Устранение дефекта при замене батарей".

Если нажать "Калибровка батарей", то всё происходит, как и было ранее - 3 мин. тест, батарея "в ноль" (по светодиодам) и "тест успешно завершен".

Кстати, заметил такую странность - если упс со 100% заряженной батареей и включенной сетью нагрузить ~45%, начинает мигать вся линейка заряда. Стоит только скинуть нагрузку до 30% - мигание пропадает. Что это может значить?? Снова результат "неочищенного регистра 0"?

upsdiag.JPG

Share this post


Link to post
Share on other sites

Мда.. Вот бы никогда не догадался!!

.. Чтобы войти в режим PROG нужно сначала обесточить ИБП (отключить питание, отключить батарею) и обязательно вынуть из ИБП карту управления AP96xx.

Всё поехало. Поправил рег. "0", запустил калибровку, упс пообещал 36 мин. на 41% нагрузке, жду..

pvl, спасибо за подсказку!

 

UPD.

Калибровка завершилась через 21 мин., регистр "0" с AF уменьшился до 87.

Как считаете, оставить всё так, или "добавить"?

Edited by AlKov

Share this post


Link to post
Share on other sites

Вот насчёт полной зарядки батарей не уверен.. После манипуляций с удалением AP9617 и установки константы в "AF", заряд показывал 95%.

Но до 100% мне показалось, что-то уж быстро он догнал - где-то минут за 30.. После чего запустил калибровку.

Кстати, вот тут удалось найти константу для моей модели -

SU3000iNET
SU3000RMiNET
96

Переписал, поставил на зарядку. Наверное, так и оставлю.

 

P.S. Не подскажете, где скачать "нормальные" MIB для AP9617, которые можно подсунуть MIBBrowser-у. Мне пока попадается не то, что надо..

УПС будет стоять на удалённом "узле", где у него на попечении будут пара коммутаторов и кассета с медиаконвертерами.

Хочу сделать нормальное оповещение о состоянии питания на узле с помощью snmp traps.

Share this post


Link to post
Share on other sites

Возможно здесь.

Internal Server Error - Read

The server encountered an internal error or misconfiguration and was unable to complete your request.
Reference #3.d6260e6b.1410862500.15e05d1

... :-(

 

В принципе, уже почти всё необходимое нашел. Даже конфиг для snmptt.

Правда, пришлось попотеть на пару с гуглем. :)

Share this post


Link to post
Share on other sites

pvl, а подскажите, как всё-таки правильно производить калибровку?

Какая-то ерунда у меня получается..

Делал так: удалил плату AP9617, изменил регистр "0" на 96, запустил калибровку из UpsDiag 2.0 без модуля AP9617.

По окончании, как уже писал, получил значение рег. "0"=87. Установил плату на место, произвёл обычный разряд батарей до отключения, той же нагрузкой в 40%. Рег. "0" изменился, стал 7С..

Зарядил батареи (не менее 12 час. заряжал), ничего не изменилось (те же 7С).

Снова удаляю плату и... Рег. "0" сам вернулся в 96!!

Ставлю плату на место, запускаю калибровку из UpsDiag, по окончанию те же 96..

Ничего не понимаю...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this