Jump to content
Калькуляторы

Микротик. Проблема с L2tp сервером и клиентами

Коллеги, подскажите.L2tp сервер на Mikrotik в центральном офисе, куча l2tp клиентов подключаются к нему с филиалов (по доменному имени вида domen.com (за него отвечают 2 айпишника-основной и резервный)). с 2 х клиентов не могу подключиться к серверу-подключение проходит, только если в свойствах подключения вместо доменного имени вписать резервный айпишник. Если резервный канал отключен-2 клиента простаивают. Настройки одинаковые для всех клиентов. в чём проблема может быть-не пойму (прошивать клиентов пробовал-никак). Маршрутизация настроена через OSPF. в чём может быть косяк?

Share this post


Link to post
Share on other sites

Через PPTP соединяется? Бывает у провайдеров проблема с пропуском L2TP трафика.

Share this post


Link to post
Share on other sites

Через PPTP соединяется? Бывает у провайдеров проблема с пропуском L2TP трафика.

Бред жеш.

 

Тс, попробуйте на проблемных машинах поставить какой-нибудь публичный днс, скорее всего проблема в этом.

Как вариант 8.8.8.8 8.8.4.4 - гугловские днсы.

Share this post


Link to post
Share on other sites

Проблема не в том, что на клиентских машинах нет подключения-микротики между собой не соединяются по l2tp. (в настройках микротика днсы гугла стоят по дефолту). PPTP подключение пробовал-те же яйца. и sstp попробовал. через провайдера основного работает около 18 l2tp подключений. и только 2 требуют резервного провайдера для работы и при замене его в настройке на основого не коннектятся...

Edited by vadiara50

Share this post


Link to post
Share on other sites

подключение проходит, только если в свойствах подключения вместо доменного имени вписать резервный айпишник

Если у клиентов микротик, то может старая версия ros? До 6.3 там вроде нельзя указывать домен, только ip.

Share this post


Link to post
Share on other sites

А в журнале ничего интересного нет?

Может попробовать с MTU поиграть?

А вообще - да, странноватый эффект.

Share this post


Link to post
Share on other sites

Такс, на одной всё решилось, когда на интерфейсе инета у клиента MTU на 1400 переставил, спасибо Danilbal. со вторым фокус не прокатил..

Edited by vadiara50

Share this post


Link to post
Share on other sites

Такс, на одной всё решилось, когда на интерфейсе инета у клиента MTU на 1400 переставил, спасибо Danilbal. со вторым фокус не прокатил..

 

Откуда это MTU? Обычно микротик сам определяет его размер, соответственно нигде не нужно делать правила смены MTU, от этого как раз идут все косяки. Если же нужно поменять MTU на туннелях, то делать это следует в настройках подключения самого туннеля, а еще лучше в центре на PPP сервере. Тогда не придется изменять типовые настройки удаленных устройств.

Share this post


Link to post
Share on other sites

Наступило утро и параметр MTU перестал влиять-рано я обрадовался. Поменял на сервере L2tp значение MTU на 1400-изменений нет. какие ещё есть мнения?

Share this post


Link to post
Share on other sites

В журнале что пишет все же? Попытки делаются? На каком этапе отказывает?

Share this post


Link to post
Share on other sites

Это при попытке подключения

09:14:25 l2tp,ppp,info l2tp-stavtrans: terminating... 
09:14:25 l2tp,ppp,info l2tp-stavtrans: disconnected 
09:14:25 l2tp,ppp,info l2tp-stavtrans: initializing... 
09:14:25 l2tp,ppp,info l2tp-stavtrans: connecting... 
10:00:17 route,ospf,info OSPFv2 neighbor 1.2.3.4: state change from Full to D
own 

Это когда айпишник меняешь на резервный (возвращаешь рабочую схему)

10:00:17 l2tp,ppp,info l2tp-stavtrans: authenticated 
10:00:18 l2tp,ppp,info l2tp-stavtrans: connected 
10:00:18 l2tp,ppp,info l2tp-stavtrans: using encoding - MPPE128 stateless 

Share this post


Link to post
Share on other sites

А если снять дамп трафика в момент подключения к основному? Может там что всплывет.

Share this post


Link to post
Share on other sites

То есть: вроде даже линк устанавливается, получается? И больше вроде ничего в логе не пишет...

А на обратной стороне? А если в журнале debug включить?

Share this post


Link to post
Share on other sites

Перешил головное устройство (CCR1016-12G) на котором поднят сервер прошивой 6.18-проблемные клиенты заработали (смену IP и перезагрузку пережили адекватно-пока ничего не отвалилось)). Посмотрим утром, решилась ли проблема таким образом.

 

Saab95 - можно Ваши координаты получить на почту vadiara@inbox.ru-есть несколько простых для вас вопросов (вознаграждение с меня)..

Share this post


Link to post
Share on other sites

В некоторых версиях ПО 6.х есть проблемы с PPP подключениями. Нужно посмотреть в случае проблемы, нет ли красных IP адресов или PPP клиентов в статусе, но в новых прошивках все исправили.

Share this post


Link to post
Share on other sites

Микротик в качестве l2tp клиента тоже странный. Пытается соединиться ещё до того, как поднял интерфейс и получил локальный адрес у билайна...

Это везде так или только в 6.5 ?

l2tpbug.jpg

Edited by Diamont

Share this post


Link to post
Share on other sites

Так и должно быть. После старта туннели пытаются соединиться. Ведь у маршрутизатора могут быть и другие каналы в интернет, а не только те, которые адрес получают автоматически.

Share this post


Link to post
Share on other sites

18 часов прошло-полёт нормальный, видимо, всё решилось прошивкой 6.18. Видимо проблема была в "В некоторых версиях ПО 6.х есть проблемы с PPP подключениями. "...

Share this post


Link to post
Share on other sites

Так и должно быть. После старта туннели пытаются соединиться. Ведь у маршрутизатора могут быть и другие каналы в интернет, а не только те, которые адрес получают автоматически.

В том то и дело, что для л2тп нужно узнать имя сервера, а днс на тот момент ещё не получен. Куда ломится!? Кроме того, маршруты к л2тп серверам прописаны через конкретный шлюз, который также не доступен. Но всё равно лезет. Говяный длинк не поднимает л2тп, пока не получил адрес. Мелочь, а неприятно.

Share this post


Link to post
Share on other sites

В том то и дело, что для л2тп нужно узнать имя сервера, а днс на тот момент ещё не получен. Куда ломится!? Кроме того, маршруты к л2тп серверам прописаны через конкретный шлюз, который также не доступен. Но всё равно лезет. Говяный длинк не поднимает л2тп, пока не получил адрес. Мелочь, а неприятно.

 

У длинка один WAN порт, а тут может быть несколько, поэтому так и сделано. Вообще в микротике все интерфейсы изолированы друг от друга и могут работать по отдельности, поэтому при включении стартуют все разом.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this