Jump to content
Калькуляторы

mikrotik & ip unnumbered

Может есть какой смысл замутить ip unnumbered на микротике в связке с dhcp?)

Share this post


Link to post
Share on other sites

Вешаете одну и ту же сеть на разные L3 интерфейсы, правда маршруты всё равно придётся прописывать в конфиг, ибо оно не умеет добавлять маршрут /32 на основе dchp-сигнализации

Share this post


Link to post
Share on other sites

Маршруты можно не прописывать, а просто жестко прибить адреса к портам. Тогда все работает без проблем.

Share this post


Link to post
Share on other sites

Saab95

пример можно?

 

s.lobanov

а может как-то скриптами это можно сделать? никто не озадачивался?

Share this post


Link to post
Share on other sites

911

можно конечно, но лично я не делал, т.к. считаю, что микротику не место в ISP. его место - SOHO и как очень дешёвый роутер в лабу

Share this post


Link to post
Share on other sites

Saab95

пример можно?

 

Вот. Сначала делаете:

 

/ip dhcp-server network
add address=192.168.100.0/24 dns-server=8.8.8.8 gateway=192.168.100.1

 

Потом добавляете порты абонентов:

 

/interface vlan
add arp=reply-only interface=bridge_vlan name=vlan_2 vlan-id=2

/ip address
add address=192.168.100.1/32 network=192.168.100.2 interface=vlan_2

/ip pool
add name=dhcp_pool_2 ranges=192.168.100.2

/ip dhcp-server
add add-arp=yes address-pool=dhcp_pool_2 disabled=no interface=vlan_2 lease-time=5m name=dhcp_2

/queue simple
add max-limit=15M/30M name=vlan_2 target=192.168.100.2/32

Share this post


Link to post
Share on other sites

Saab95

конфигурить через cli это устаревшая технология, даёшь скрины с винбокса!

Share this post


Link to post
Share on other sites

Это вариант с кучей DHCP +QinQ+ PCQ /31. Каждому может выдаваться по 2 ip адреса.

Делать это придётся через устаревшую технологию (CLI). Через винбокс будет делать только мазохист =)

post-101104-084842400 1406921873_thumb.png

Edited by AKim

Share this post


Link to post
Share on other sites

Это вариант с кучей DHCP +QinQ+ PCQ /31. Каждому может выдаваться по 2 ip адреса.

Делать это придётся через устаревшую технологию (CLI). Через винбокс будет делать только мазохист =)

 

Вам надо разнести терминирование по железкам, сделав L3 сеть, что бы не создавать кучу адресов на центральной железке.

Share this post


Link to post
Share on other sites

AKim

Вы заранее конфигурируете микротик? создаете все вланы и навешиваете все ип адреса?

Share this post


Link to post
Share on other sites

Вы заранее конфигурируете микротик? создаете все вланы и навешиваете все ип адреса?

 

открываю в Notepad конфиг, создаю пару домов и при помощи копирования/поиска/замены, создаю необходимое количество домов.

 

Создаю все вланы и ип адреса на коммутаторы которые работают, а активирую вланы на нужных портах по необходимости.

 

QinQ упрощает конфигурацию доступа, запутаться не получиться. На всех коммутаторах доступа созданы vlan 2-25.

 

Пока что заметил только проблему с шейпером /31. Он очень сильно грузит систему. Придётся отказаться и выдавать только 1 ip.

Edited by AKim

Share this post


Link to post
Share on other sites

911

А зачем вообще создавать эти эпические костыли, когда есть linux+accel?

Share this post


Link to post
Share on other sites

А зачем вообще создавать эти эпические костыли, когда есть linux+accel?

 

С linux+accel нужно разобраться и протестировать. В моём случае, нужно было готовое, рабочее и понятное любому решение за 2 дня.

Share this post


Link to post
Share on other sites

kayot

иногда есть места, где уже стоит железный микротик и надо что-то с ним делать

Share this post


Link to post
Share on other sites

"железный" микротик стоит копейки, поэтому его можно положить на склад или продать клиенту.

Share this post


Link to post
Share on other sites

911

А зачем вообще создавать эти эпические костыли, когда есть linux+accel?

 

На микротик уже много раз приводили конфиг этой схемы. А вот на линукс до сих пор никто подробной инструкции для чайников не выложил.

Share this post


Link to post
Share on other sites

Мазохизм чистой воды.

 

Это ж как надо себя не любить, чтобы строить на микротике такие схемы, там же все сделано чужими для хищников.

 

P.S: делали халтуру на асселе(l2-conneted qinq, инициализация сессии по dhcp-discover пакету) - взлетело все с полпинка.

Share this post


Link to post
Share on other sites

Вешаете одну и ту же сеть на разные L3 интерфейсы, правда маршруты всё равно придётся прописывать в конфиг, ибо оно не умеет добавлять маршрут /32 на основе dchp-сигнализации

 

Вы тестировали или предположение? Согласно документации умеет. В dhcp из радиуса передаются атрибуты маршрутов. Маршрут нужно добавлять на dst интерефейс.

Share this post


Link to post
Share on other sites

Sonne

вы про маршруты, которые передаются абоненту в dhcp-offer и dhcp-ack или про маршрут, который надо создавать на точке терминирования для unnumbered? (ну и ссылку тоже давайте, мало ли не то найду)

Share this post


Link to post
Share on other sites

Вешаете одну и ту же сеть на разные L3 интерфейсы, правда маршруты всё равно придётся прописывать в конфиг, ибо оно не умеет добавлять маршрут /32 на основе dchp-сигнализации

 

Вы тестировали или предположение? Согласно документации умеет. В dhcp из радиуса передаются атрибуты маршрутов. Маршрут нужно добавлять на dst интерефейс.

Уже несколько раз обсуждалось. Вы хоть понятие получите, о чем разговор.

Share this post


Link to post
Share on other sites

Это ж как надо себя не любить, чтобы строить на микротике такие схемы, там же все сделано чужими для хищников.

 

что в этой схеме такого страшного и сложного?

 

Куча dhcp и маршрутов не есть хорошо, но никто ещё не прикрепил доказательств, что это не работает. Так же не нужно приводить доводов типа "вот когда будет пять тысяч абонов, вы пожалеете". Когда будет, будут другие конфигурации и другое оборудование.

Каждый админ хвалит свой курятник, у каждого лучше чем у соседа. Я привык проверять лично работоспособность чего-либо, а не основываться на предположении кого-то.

 

В данный момент работает и проблем не доставляет. Дальше будет видно, быть может я буду тем человеком, который напишет здесь же, что эту схему лучше не использовать.

Share this post


Link to post
Share on other sites

что в этой схеме такого страшного и сложного?

Ну как минимум невозможно сделать динамическую выдачу адресов. Ну т.е. если есть белый пул - эдак 50% пула простаивает (ибо редко когда более 50% активных абонов онлайн, о неактивных - помолчу). Сколько там сейчас PI стОит в месяц?

Далее, как рулить доступом всем этим хозяйством? Скорость менять, гасить абонов за долги? Другими эпическими костылями?

Потом, добавление абона - превращается в нехилый квест, который может выполнить только админ (оператор техподдержки парой кликов не сделает).

Share this post


Link to post
Share on other sites

Менять скорость и рулить абонами точно так же как и при любом другом способе подключения. Используется PCQ шейпер с адрес листами. Добавить абонента - это активировать нужный vlan и прописать выданный ip в адрес лист с тарифом или активировать vlan и нужный ip в адрес листе, тогда это всего два клика. Добавить новые дома- это открыть заготовку конфига в notepad и изменить одну цифру в ip через копию/замену и номер одного vlan.

 

Выдавать белые адреса всем не планируется в ближайший год-два.

Edited by AKim

Share this post


Link to post
Share on other sites

Вообще через апи микрика замечательно все можно делать хоть из под винды.. мне вот пхп нравится , вот он и делает все сравнения, удаления, добавления...

Share this post


Link to post
Share on other sites

Ну как минимум невозможно сделать динамическую выдачу адресов. Ну т.е. если есть белый пул - эдак 50% пула простаивает (ибо редко когда более 50% активных абонов онлайн, о неактивных - помолчу). Сколько там сейчас PI стОит в месяц?

 

Малые операторы не покупают свои пулы адресов а используют серые.

 

Далее, как рулить доступом всем этим хозяйством? Скорость менять, гасить абонов за долги? Другими эпическими костылями?

 

Менять скорость, гасить за долги там же где и всегда - на пограничном шлюзе и шейпере. Это стандартная схема где нет никаких костылей. Вы разве до сих пор все на одной железке делаете?

 

Потом, добавление абона - превращается в нехилый квест, который может выполнить только админ (оператор техподдержки парой кликов не сделает).

 

Если адреса серые, то на все порты вешаются адреса с увеличением на 1, а оператор техподдержки просто выбирает номер порта и получает адрес, который нужно забить в биллинг, при этом автоматически создастся ограничение скорости. Кроме всего, привязка идет к интерфейсу и никаких проблем отделить одного абонента от другого нет. Соответственно указали интерфейс, и если используются белые адреса, на него повесился маршрут, в DHCP указался нужный пул и готово. Линукс отдыхает.

 

Приведите ка команды на линуксе для блокировки одного IP адреса и создания шейпера? На микротике это 2 коротких строчки.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this