Jump to content
Калькуляторы

QINQ DGS-3120 & C3750

Всем привет, пытаюсь запустить qinq, но пока безуспешно

агрегатор DGS3120 8-м портом (UNI mode) подключен к каталисту, одинарные вланы ходят, двойные нет

 

DGS-3120

# VLAN

enable pvid auto_assign
config vlan default delete 1-26
config vlan default add untagged 1-6,8-26
config vlan default advertisement disable
create vlan s500 tag 500
config vlan s500 add tagged 8 advertisement disable
create vlan Test_Node tag 916
config vlan Test_Node add tagged 1-6,8-24 advertisement disable
create vlan c1000 tag 1000
config vlan c1000 add tagged 1-6,8-24 advertisement disable
enable qinq
disable gvrp
config gvrp nni_bpdu_addr dot1ad
disable asymmetric_vlan
disable vlan_trunk
config port_vlan 1-26 gvrp_state disable ingress_checking enable acceptable_frame admit_all pvid 1

# QINQ

config qinq ports 1-7,9-24  outer_tpid 0x8100
config qinq ports 8 role uni missdrop enable outer_tpid 0x8100
create vlan_translation ports 8 replace cvid 916 svid 916
create vlan_translation ports 8 add cvid 1000 svid 500

Command: show qinq

QinQ Status : Enabled

 

с3750

c3750-48#sh run | b 1/0/39
interface GigabitEthernet1/0/39
description Test-Node
switchport trunk encapsulation dot1q
switchport trunk native vlan 28
switchport trunk allowed vlan 28,500,916
switchport mode trunk
spanning-tree bpdufilter enable
spanning-tree bpduguard enable

c3750-48#sh system mtu

System MTU size is 1504 bytes
System Jumbo MTU size is 9000 bytes
Routing MTU size is 1500 bytes

 

смысл - завернуть клиентский влан 1000 и в 500-й и по нему доставить до браса. брас подключен в тот же каталист:

 

interface Port-channel2
description NAS30-channel
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,500
switchport mode trunk
.....
interface GigabitEthernet1/0/17
description NAS30_aggr
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,500
switchport mode trunk
channel-group 2 mode active
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/18
description NAS30_aggr
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,500
switchport mode trunk
channel-group 2 mode active
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/19
description NAS30_aggr
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,500
switchport mode trunk
channel-group 2 mode active
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/20
description NAS30_aggr
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,500
switchport mode trunk
channel-group 2 mode active
spanning-tree bpdufilter enable
spanning-tree bpduguard enable

 

на сервере

 

bond1: flags=5187<UP,BROADCAST,RUNNING,MASTER,MULTICAST>  mtu 1500
       inet 172.16.0.230  netmask 255.255.255.0  broadcast 172.16.0.255
       ether 6c:ae:8b:52:9a:ea  txqueuelen 0  (Ethernet)
       RX packets 380225  bytes 42970600 (40.9 MiB)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 10779  bytes 1395743 (1.3 MiB)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

bond1.500: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       ether 6c:ae:8b:52:9a:ea  txqueuelen 0  (Ethernet)
       RX packets 0  bytes 0 (0.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 0  bytes 0 (0.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

bond1.501: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       ether 6c:ae:8b:52:9a:ea  txqueuelen 0  (Ethernet)
       RX packets 0  bytes 0 (0.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 0  bytes 0 (0.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

bond1.500.1000: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
       inet 10.10.10.1  netmask 255.255.255.0  broadcast 10.10.10.255
       ether 6c:ae:8b:52:9a:ea  txqueuelen 0  (Ethernet)
       RX packets 0  bytes 0 (0.0 B)
       RX errors 0  dropped 0  overruns 0  frame 0
       TX packets 0  bytes 0 (0.0 B)
       TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

 

где собака порылась?

Share this post


Link to post
Share on other sites

create vlan_translation ports 8 add cvid 1000 svid 500

 

Это вы пакетам, с тэгом 1000, приходящим с 8ого порта добавляете второй тэг 500

Share this post


Link to post
Share on other sites

create vlan_translation ports 8 add cvid 1000 svid 500

 

Это вы пакетам, с тэгом 1000, приходящим с 8ого порта добавляете второй тэг 500

тогда как правильно сделать? к портам агрегатора подключены кольца раздачи, в них клиентские вланы 1000 ..., мне нужно их завернуть в сервисные 500 ...,

вланы 1..999 должны проходить через агрегатор без изменений, в данном случае 8 порт аплинк

Share this post


Link to post
Share on other sites

Наверное правильнее сделать на 3750 "uni" access порт в влане 500. Я не настраивал qinq на циско, поэтому точно не знаю как это делается

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this