Jump to content
Калькуляторы

Нужен скрипт для МТ Скрипт для ребута USB

Народ доброго всем времени суток .

Ситуация следующая есть борд МТ в него вставлен свисток Уёты который периодически виснет , ребут борда не спасает так как usb при этом не сбрасывает питание ,а вот ребут питания usb помогает (программно) ,есть ли возможность накатать скрип что бы при обрыве пинга (ну скажем до гугла ) борд делал ребут питания usb на 10-20 сек . ?

Share this post


Link to post
Share on other sites

tools/netwatch оно?

 

 

не не то нужен был скрипп именно для ребута питания usb порта при отсутствия связи с внешним миром , но скрипт найден всем спс !

Share this post


Link to post
Share on other sites

А какой борд?

Не все умеют USB power reset

 

А так, вообще, в tool/netwatch, Адрес любой внешний, в on DOWN

system routerboard usb power-reset duration=1 ;

Share this post


Link to post
Share on other sites

А какой борд?

Не все умеют USB power reset

 

А так, вообще, в tool/netwatch, Адрес любой внешний, в on DOWN

system routerboard usb power-reset duration=1 ;

 

 

спс нашел скрипт , переделал под свои нужды и всё заработало . Вообще борд 912 ,но разве не все МТ могут юсб ресет делать ? я думал это от прошивки зависит ?

Share this post


Link to post
Share on other sites

спс нашел скрипт , переделал под свои нужды и всё заработало

 

не я худею с вас, а поделиться?????

Share this post


Link to post
Share on other sites

спс нашел скрипт , переделал под свои нужды и всё заработало

 

не я худею с вас, а поделиться?????

 

 

Да нет проблем :

:local PingCount 3

:local google 8.8.8.8

:local yandex 77.88.8.8

:local mail 94.100.180.201

:local ResultGoogle [/ping count=$PingCount $Google interface=yota]

:local Resultyandex [/ping count=$PingCount $yandex interface=yota]

:local ResultMail [/ping count=$PingCount $mail interface=yota]

:local MainIfInetOk false;

:set MainIfInetOk (($ResultGoogle + $Resultyandex + $ResultMail) >= (2 * $PingCount))

:put "MainIfInetOk=$MainIfInetOk"

if (!$MainIfInetOk) do={

/log error "Bad connect"

/system routerboard usb power-reset

/system reboot

}

if ($MainIfInetOk) do={

/log info "Connect OK"

}

 

 

 

Можно дать команду отключить а потом включить usb интерфейс.

В скрипте если нужно выполнить следующую команду через время, прописывается delay между командами, то есть выполнить через секунду

 

CODE:

delay 1;

 

 

или через 10 секунд

 

CODE:

delay 10;

 

/system script run script1 - для шудалера !

 

время проверки я думаю по вкусу =)

 

 

написали в начале это ,но потом подумали нах нам ребут борда "/system reboot" и выкинули эту строку =) в строке где указано "yota" это имя интерфейса (может быть что угодно мегафон или другой иной usb свисток) - для тех кто в танке =)

Edited by porozut

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this