Jump to content
Калькуляторы

NAT отключил, адрес занят CISCO7206VXR+NPE-225

Использовали NAT, избавились от него, с конфигов про NAT всё вычистили, в том числе адрес пула.

Но в выводе show ip aliases этот адрес светится с типом Dynamic, соотвественно, этот адрес, циской и циска с этого адреса не пингуется, но что самое интересное — всё маршрутизируется как положено!

 

Как без перезагрузки адрес освободить?

Edited by nevzorofff

Share this post


Link to post
Share on other sites

Пробовал, не помогает.

Ещё пробовал навесить адрес на интерфейс и удалить — тоже без результата.

Share this post


Link to post
Share on other sites

может что-то осталось в таблицах трансляций:

clear ip nat tr *

Share this post


Link to post
Share on other sites

И это делал, таблицы пусты чисты.

Share this post


Link to post
Share on other sites

А так:

This solution involves clearing the IP NAT translations using the clear ip nat translation command, and then replacing 
the NAT configuration quickly, before any new NAT entries are populated into the translation table due to active NAT traffic. 
To do this, create a script with the configuration commands written in a text format. For example:

   clear ip nat translation *
   config terminal
   no ip nat pool old pool name

   ip nat pool new pool
    ....... 

Once you have the script, cut and paste the script into the router enable mode (Router#).

Note: This may take more than one try since it is still possible that the router will create a translation after the translation has been cleared. 

Edited by Merridius

Share this post


Link to post
Share on other sites

Да у меня новый трансляций не появляется потому что клиентов за натом нет и конфиг успешно вычистился и без сих танцев с бубном.

Чтобы их избежать можно удалить сначала строки inside-outside с интерфейсов, потом почистить трансляции(новые уже не создадутся), а потом уже снести и пулы.

 

ps попробовал таки, создав назад тот пул, результата нет.

Share this post


Link to post
Share on other sites

А так:

Не так.

conf t
do clear ip nat trans force
do clear ip nat trans *
do clear ip nat trans *
no ip nat pool
ip nat pool

Но это только на маленьком трафике сработает.

На большом нужно вначале снять nat с интерфейсов, а затем чистить трансляции и пересоздать пулы.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this