Jump to content
Калькуляторы

asterisk + GSM модем E1550

Всем привет. Есть сип номер московский и астериск настроенный. Все работает, при звонке есть ivr

 

Хочу подключить жсм модем, вроде прописал все в dongle.conf привязал к нужному, при звонке на мобильный. слышу свое меню, но при попытке что то выбрать (нажимаю 1 или 2) ничего не происходит, т.е. тоны с мобильника не определяются...

Как быть и починить? И будет ли работать?

Share this post


Link to post
Share on other sites

не корректно настроен dongle.conf - там есть параметры dtmf

Share this post


Link to post
Share on other sites

что не до настроено?

# cat dongle.conf

[general]

 

interval=15 ; Number of seconds between trying to connect to devices

 

[defaults]

context=default ; context for incoming calls

group=0 ; calling group

rxgain=0 ; increase the incoming volume; may be negative

txgain=0 ; increase the outgoint volume; may be negative

autodeletesms=yes ; auto delete incoming sms

resetdongle=yes ; reset dongle during initialization with ATZ command

u2diag=-1 ; set ^U2DIAG parameter on device (0 = disable everything except modem function) ; -1 not use ^U2DIAG command

usecallingpres=yes ; use the caller ID presentation or not

callingpres=allowed_passed_screen ; set caller ID presentation by default use default network settings

mindtmfgap=45

mindtmfduration=80

mindtmfinterval=200

 

exten=96....79

dtmf=inband

 

[dongle0]

rxgain=-5

txgain=-5

audio=/dev/ttyUSB1 ; tty port for audio connection; no default value

data=/dev/ttyUSB2 ; tty port for AT commands; no default value

imei=35....61

imsi=25....52

Share this post


Link to post
Share on other sites

Поиском ищите правильные параметры - собака зарыта в этих параметрах

 

 

mindtmfduration=80

mindtmfinterval=200

Share this post


Link to post
Share on other sites

dtmf=relax не меняет картины.

 

привел к такому варианту:

mindtmfgap=0

mindtmfduration=0

mindtmfinterval=100

dtmf=relax

 

стало срабатывать, но только когда прошло приветствие и через раз как то

Share this post


Link to post
Share on other sites

в общем вынес еще модем по ближе к GSM сети :) и с такими параметрами заработало как положено, будем тестить...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this