Перейти к содержимому
Калькуляторы

raisecom ISCOM2128EA-MA option 82 не работает

Взяли на тест два свича ISCOM2128EA-MA (на доступ). Сразу же возникли проблемы с настройкой базового функционала нашей сети - DHCP option 82

На стенде 4 порт - "абонент", 25 порт - аплинк в ядро, 1 порт монитор (миррор) на исходящий трафик с 25 порта.

В wireshark ни одного юникаст DHCP запроса, но есть броадкаст запросы (соответственно без опции 82). target-ip (я так понял это helper) со свитча доступен.

 

Пробовал разные прошивки:

ROS_4.14.1781.ISCOM2128EA-MA.167.20120920

ROS_4.14.1931.ISCOM2128EA-MA.000.20130805

ROS_4.14.1967.ISCOM2128EA-MA-6.002.20140225

ROS_4.14.2013(a).ISCOM2128EA-MA.000.20131217

 

Результат почти один и тот же. Только на ROS_4.14.1967.ISCOM2128EA-MA-6.002.20140225 хотя бы росли счетчики в "sh ip dhcp relay statistics" (колонка Receive строка Discover. Но Send - по нулям). Так же в этой прошивке нет команды "ip dhcp relay information trusted port-list"

 

Настраивал все по мануалу, но может чего упустил/не знал/не указал.

Может оно без чего нибудь не работает, или наоборот с чем нибудь.

Вспоминается SNR 48 портовый - там без снупинга не работало. Но хотя бы отсылало юникасты.

 

Есть тут те, кто настраивал такую железяку на опцию 82 ?

 

 System current configuration:
!ROS  Version ROS_4.14.1781.ISCOM2128EA-MA.167.20120920 
!command in view_mode
!
!command in config_mode first-step
create vlan 5,1001 active
!
!command in aclmap_mode
!
!command in enable_mode
clock timezone + 11 0
!
!command in region_mode
!
!command in ip igmp profile mode
!
!command in service_mode
!
!command in port_mode
!
interface port 1 
switchport access vlan 5 
switchport access egress-allowed vlan remove 1 
!
interface port 4 
switchport access vlan 1001 
switchport access egress-allowed vlan remove 1 
!
interface port 25 
switchport mode trunk
!
interface port 26 
switchport mode trunk
!
interface port 27 
switchport mode trunk
!
interface port 28 
switchport mode trunk
!
!command in vlan configuration mode
!
!command in ip interface mode
interface ip 0
ip address 192.168.128.16 255.255.240.0 1
!
!command in cluster_mode
!         
!command in cmap_mode
!
!command in pmap_mode
!
!command in config_mode
mirror enable 
mirror source-port-list egress 25 
ip default-gateway 192.168.128.1
ip dhcp relay
ip dhcp relay ip-list 0 target-ip 80.х.х.х
ip dhcp relay information option

!Здесь пробовал и только 4 (вроде как по мануалу) и только 25 (вроде как по 
!логике) и вообще без портов (на последней прошивке нет этой команды)
!результат одинаковый.
ip dhcp relay information trusted port-list 4,25 

sntp server 80.х.х.х
service config
!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

если не изменяет память, то option82 на орионах настраивается совместно с dhcp snooping:

 

(config)#ip dhcp snooping

(config)#ip dhcp snooping port-list { all | port-list }

(config)#ip dhcp snooping information option

на аплинке

(config)#interface port port-id 25

(config-port)#ip dhcp snooping trust

Изменено пользователем tractor_driver

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
совместно с dhcp snooping

Пробовал, но с релеем оно не включается.

Enable DHCP Snooping unsuccessfully. Other DHCP service is enabled !

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Дык у них же техподдержка есть → support(супер мега пупер значек эт)raisecom.su

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Спасибо за наводку про орион. Нашел решение тут http://forum.nag.ru/forum/index.php?showtopic=90552&view=findpost&p=910267

ip dhcp relay ip-list all target-ip x.x.x.x

interface ip 1

ip vlan 1001

Однако все равно не очень подходит - у нас схема vlan на абонента, а на этой железяке всего 15 ip интерфейсов. Т.е. получится подключить всего 14 абонентов (1 интерфейс управления). Пошел составлять писмецо в поддержку.

Всем спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Может уже нужно, но стоит у них и спросить ( http://www.raisecom.su/support ).

Изменено пользователем devoid013

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Он еще собака не заполняет поле relay IP agent address в DHCP пакете.

 

Прошивка ROS_4.14.2013(a).ISCOM2128EA-MA.000.20131217 исправила ситуацию :)

Изменено пользователем zorn

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ROS_4.14.2013(a).ISCOM2128EA-MA.000.20131217

замечено что а прошивках без web-морды эти коммутаторы работают стабильней.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Если актуально,

 

У нас так работает:

 

System current configuration:

!ROS Version ROS_4.12.1358.ISCOM2126EA-MA.220.20100625

!command in view_mode

!

!command in config_mode first-step

create vlan 8,77,100,130,140,150 active

mvr enable

mvr vlan 77

mvr mode dynamic

mvr vlan 77 group 23*.1.1.1 250

ip igmp querier enable

ip igmp querier query-interval 100

ethernet cfm domain md-name MdLevel0Default level 0

!

!command in aclmap_mode

!

!command in enable_mode

hostname *******

!

!command in region_mode

!

!command in ip igmp profile mode

!

!command in service_mode

service Level0MaName level 0

!

!command in port_mode

!

interface port 1

switchport access vlan 140

flowcontrol receive on

rndp disable

mvr type receiver

!

interface port 2

switchport access vlan 140

flowcontrol receive on

rndp disable

mvr type receiver

!

*******************************

!

interface port 24

switchport access vlan 140

rndp disable

!

interface port 25

switchport trunk allowed vlan 8,77,130,140,150

switchport trunk untagged vlan remove 1

switchport mode trunk

ip dhcp snooping trust

mvr type source

!

interface port 26

switchport trunk allowed vlan 8,130,140,150

switchport trunk untagged vlan remove 1

switchport mode trunk

ip dhcp snooping trust

mvr type source

!

!command in vlan configuration mode

!

!command in ip interface mode

interface ip 2

ip address 192.168.8.21 255.255.252.0 8

!

!command in cluster_mode

!

!command in cmap_mode

!

!command in pmap_mode

!

!command in config_mode

rate-limit port-list 19 ingress 87424 8

mac-address-table multicast filter-mode filter-all

 

ip dhcp snooping

ip dhcp snooping information option

no logging console

rndp disable

!

 

И да, Тех. Поддержка у них на высоте, решат проблему. Очень ими довольны.

 

Пишите, если смогу - помогу с данным оборудованием.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А для чего у вас querier включен?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

А для чего у вас querier включен?

 

Видимо эхо войны, а если серьёзно, то кажется были какие-то проблемы с этим, поэтому оставили.

 

Также к сабжу не относятся: flowcontrol, mvr и прочее. Я хотел показать, что железка годная и вполне работает с IPTV, ШПД.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Ну это не правильно, квирер должен быть 1 в сети...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Если актуально,

 

У нас так работает:

У вас снупинг, а мне нужен релей. А там проблема в 15 ip интерфейсах (у нас влан на абонента) - чтобы релей работал нужен ip интерфейс с вланом абонента.

IPTV тоже не получилось с наскока настроить. IGMP запросы пошли, а поток нет. Но особо и не пытался на самом деле. Ограничивать каналы я так понимаю igmp профилями и фильтрами ?

 

И да, Тех. Поддержка у них на высоте, решат проблему. Очень ими довольны.

Может быть, однако

Бесплатная техподдержка оказывается только клиентам, купившим оборудование, привезенное нашей компанией, или клиентам, заключившим дополнительный договор.

 

Даже не уверен, что он дальше тестового стенда уйдет...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

люди добрый подскажите, где взять свежие прошивки под Raisecom ISCOM2110EA-MA и Raisecom ISCOM2924GF???

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Поддерживает ли этот коммутатор MAC address-based VLAN?

Изменено пользователем 0x05bc

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

подниму тему, подскажите что не так делаю.

Пытаюсь настроить коммутатор Raisecom ISCOM2110EA-MA и вот что получается:

при попытке включить

B-3(config)#ip dhcp server

Enable DHCP server unsuccessfully. DHCP Client or Snooping is enabled !

B-3(config)#ip dhcp relay

Enable DHCP relay unsuccessfully. DHCP Client or Snooping is enabled !

B-3(config)#ip dhcp snooping

Enable DHCP Snooping successfully

 

Мне нужно, чтобы всё было включено, вот так:

service dhcp

ip forward-protocol udp bootps

ip dhcp relay information option

ip dhcp relay information option subscriber-id format hex

ip dhcp broadcast suppress

ip dhcp snooping enable

ip dhcp snooping vlan 9

ip dhcp snooping binding enable

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

кто в теме, подскажите, может это одно временно работать:

ip dhcp server

ip dhcp snooping

ip dhcp snooping information option

или я что-то не так делаю?

Изменено пользователем filin911

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 08.07.2014 в 04:49, zorn сказал:

IPTV не получилось настроить. IGMP запросы пошли, а поток нет.

Добрый день всем, кто может помочь, достался тут за даром звереныш древний решил его изучить и применить в работе и столкнулся с подобной проблемой.

Подписка проходит, но самой картинки нет. и TSReader не кажет получения потока. Ман на это чудо зачитан.

Product name: ISCOM2110A-MA
ROS  Version ROS_4.14.1943.ISCOM2110A-MA.153.20130925.(Compiled Sep 25 2013, 10:03:55)
Bootstrap  Version Bootstrap_2.3.39.ISCOM2110A-MA.2.20120525
FPGA Version
Hardware ISCOM2110A-MA. Version Rev.A.2

 

MVR Multicast VLAN    Group IP         User VLAN   Live Time    Join Port
-------------------------------------------------------------------------
362                   229.1.1.1        220         183          9
362                   229.1.4.10       220         343          9

 

и на аплинковсом свитче показывает, что подписка произошла

IGMP Snooping Connect Group Membership
Note:*-All Source, (S)- Include Source, [S]-Exclude Source

Groups          Sources             Ports               Exptime  SrcMac              System Level
229.1.1.1       *                   Ethernet1/0/22      00:04:13 68:05:CA:15:EC:80   V3
229.1.4.10      *                   Ethernet1/0/22      00:04:17 68:05:CA:15:EC:80   V3

Прошивка судя по инету последняя.

Или не стоит мучить этого мамонта? Хотя так хотелось его на один из участков не нагруженных, где на нем будет-то пару клиентов от силы.

Заранее благодарствую.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Это родственник Orion Alpha.

Почитайте документацию в выделенной ветке.

Конфигурации будут довольно похожи, только софт нужно обновить, 5 лет это слишком много.

Во всяком случае на Orion-ах именно в более-менее свежих прошивках IPTV довели до ума, до этого работало плохо.

 

P.S. У вас действительно используется IGMPv3?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Конфиг то райскома покажите

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 часов назад, alibek сказал:

Это родственник Orion Alpha.

Почитайте документацию в выделенной ветке.

Конфигурации будут довольно похожи, только софт нужно обновить, 5 лет это слишком много.

Во всяком случае на Orion-ах именно в более-менее свежих прошивках IPTV довели до ума, до этого работало плохо.

 

P.S. У вас действительно используется IGMPv3?

Нет конечно, винда по умолчанию юзает 3ью, рестарт еще после правки реестра не выполнял.

Прошивка в публичном доступе на данный коммутатор последняя, да и он уже давно снят с производства, не думаю, что есть свежее.

Спасибо за наводку.

Не хватало на пользовательском порту включения его в мультикаст влан.

switchport access egress-allowed vlan add 362

И самого главного, что: В случае реализации MVR не следует включать IGMP snooping.

отличается конечно принцип настройки от SNR или CISCO

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас