Jump to content
Калькуляторы

mikrotik переключение канала

настраиваю переключение каналов на ccr-1036 делал по статье http://wiki.mikrotik.com/wiki/Advanced_Routing_Failover_without_Scripting

/ip route
add distance=1 gateway=109.206.x.1 routing-mark=kdms
add check-gateway=ping distance=1 gateway=8.8.8.8 routing-mark=kdms
add check-gateway=ping distance=2 gateway=8.8.4.4 routing-mark=kdms
add distance=1 gateway=94.131.y.1 routing-mark=avk
add check-gateway=ping distance=1 gateway=8.8.4.4 routing-mark=avk
add check-gateway=ping distance=2 gateway=8.8.8.8 routing-mark=avk
add distance=1 gateway=109.206.x.1,94.131.y.1
add distance=1 dst-address=8.8.4.4/32 gateway=94.131.y.1 scope=10
add distance=1 dst-address=8.8.8.8/32 gateway=109.206.x.1 scope=10

при отключение 109.206.x.1 провейдера пакеты сороыно хотят идти через него на 94.131.y.1 пакеты не идут

Share this post


Link to post
Share on other sites

Этот микротик натит интернет т.е. у него есть активные коннекты? Если есть надо их разрывать.

Share this post


Link to post
Share on other sites

нет на нем нет nat он используется как router потдерживает связь с центральным офисом

Share this post


Link to post
Share on other sites

Если у вас связь с центральным офисом, то самое то для OSPF - ставите 2 микротика, каждый подключаете к своему каналу, соответственно каждый поднимает PPP туннель до центрального сервера и все. При отключении каналов все автоматически отработает.

Share this post


Link to post
Share on other sites

Если у вас связь с центральным офисом, то самое то для OSPF - ставите 2 микротика, каждый подключаете к своему каналу, соответственно каждый поднимает PPP туннель до центрального сервера и все. При отключении каналов все автоматически отработает.

лишних микротиков в наличии нету есть cisco 1841

в нутри сети пользователи получают маршруты через dhcp тоесть я могу указать только один роутер или я что то не понимаю ?

Share this post


Link to post
Share on other sites

лишних микротиков в наличии нету есть cisco 1841

в нутри сети пользователи получают маршруты через dhcp тоесть я могу указать только один роутер или я что то не понимаю ?

 

Есть сеть транспортная, а есть абонентская. Вы можете по OSPF раздавать адреса напрямую с удаленного устройства, при этом никакие маршруты выдавать не потребуется (да и что вообще за такая штука как выдача маршрутов компьютерам, давайте их сразу по BGP подключать). Если же используется что-то вроде доменов винды или еще какой хитрой схемы, просто поверх L3 сети пускаете в EoIP или MPLS трафик L2, во время работоспособности обоих каналов данные будут бегать через какой-то один, как случится беда, перейдут на оставшийся в работе.

 

Просто такая схема работает сама по себе по стандартным признакам - нет инета - нет связи по туннелю - оборвался. Если же делать скриптами, то у роутера один шлюз по умолчанию, соответственно нужно пинговать какие-то узлы в интернете, что бы проверить доступность каналов, переключать маршруты и т.п. Все это не удобно и может дать сбой.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this