Jump to content
Калькуляторы

не удается поднять vpn на MikroTik Router CCR-1036

Всем доброе время суток!

Помогите пожалуйста разобраться, не могу поднять впн на микторике.

Все что находил в гугле по запросу: впн и микротик, везде описано одно и тоже.

Собственно вроде ничего сложного. Всего 3 шага.

1 Включаем Сервер PPTP

2 Создаем пользователя и пароль.

3 Добавляем правила в фаирвол.

внутри сети впн подымается, т.е на виндовой машине создаю новое подключение ввожу ip роутера, имя и пароль, впн поднялся, ip получил, который указал в настройках. Вобщем работает. Но пытаюсь проделать тоже самое из вне, не работает. Отваливается с ошибкой 800.

Логи на микротике:

TCP connection established from 92.47.246.78
<pptp-0> :waiting for call.. 
<pptp-0>:terminating... - call cleared 
<pptp-0>:disconnected

 

Вот настройки на миктотике:

[viktor@MikroTik] > ppp export 
# jun/13/2014 09:15:34 by RouterOS 6.1
# software id = ND3L-R6QR
#
/ppp secret
add local-address=192.168.1.1 name=User1c password=P@ssword remote-address=\
   192.168.1.14 service=pptp
[viktor@MikroTik] > ip firewall filter export 
# jun/13/2014 09:16:41 by RouterOS 6.1
# software id = ND3L-R6QR
#
/ip firewall filter
add chain=input protocol=gre
add chain=input dst-port=1723 protocol=tcp
add chain=output protocol=tcp src-port=1723
add chain=forward src-address=192.168.1.55
add chain=forward src-address=192.168.1.60
add chain=forward dst-address=192.168.1.0/24 protocol=tcp src-port=443
add chain=forward dst-port=443 protocol=tcp src-address=192.168.1.0/24
add chain=forward dst-address=192.168.1.0/24 protocol=tcp src-port=25
add chain=forward dst-port=25 protocol=tcp src-address=192.168.1.0/24
add chain=forward dst-address=192.168.1.0/24 protocol=tcp src-port=110
add chain=forward dst-port=110 protocol=tcp src-address=192.168.1.0/24
add chain=forward dst-address=192.168.1.0/24 protocol=tcp src-port=20
add chain=forward dst-port=20 protocol=tcp src-address=192.168.1.0/24
add chain=forward dst-address=192.168.1.0/24 protocol=tcp src-port=21
add chain=forward dst-port=21 protocol=tcp src-address=192.168.1.0/24
add chain=forward disabled=yes dst-address=192.168.1.0/24 protocol=tcp \
   src-port=443
add action=drop chain=forward dst-port=6881-6889 in-interface=LAN protocol=\
   tcp time=8h-20h,mon,tue,wed,thu,fri
add action=drop chain=forward content=d1:ad2:id20: dst-port=1025-65535 \
   in-interface=LAN packet-size=95-190 protocol=udp time=\
   8h-20h,mon,tue,wed,thu,fri
add chain=forward connection-state=established
add chain=forward connection-state=related disabled=yes
add action=drop chain=forward connection-state=invalid
add action=drop chain=input connection-state=invalid

Share this post


Link to post
Share on other sites

Методом тыка нашел проблему, на микротик приходит два провайдера. Когда отключаю одного, впн подымается. Как настроить чтобы впн работал с двумя провайдерами?

Share this post


Link to post
Share on other sites

Методом тыка нашел проблему, на микротик приходит два провайдера. Когда отключаю одного, впн подымается. Как настроить чтобы впн работал с двумя провайдерами?

 

Проверьте, работает ли впн через каждого оператора по очереди, потом определите, через какого не работает, проверьте, не попадает ли трафик впн под какую-то маркировку. В отличии от L2TP, у PPTP нет необходимости жесткой привязки к исходящим адресам, то есть подключение может быть по одному адресу, а исходящий трафик приходить с другого адреса, например, если дефолтный маршрут идет только через одного оператора.

Share this post


Link to post
Share on other sites

Saab95, по очереди подключается через каждого провайдера.

[viktor@MikroTik] > ip route print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
0 A S  0.0.0.0/0                          80.xx.xx.xx             1
                                          212.xx.xx.xx     
1 ADC  80.xx.xx.xx/29   80.xx.xx.xx   ISP1                       0
2 ADC  192.168.1.0/24     192.168.1.1     LAN                       0
3 ADC  212.xx.xx.xx/30   212.xx.xx.xx   ISP2                      0

Share this post


Link to post
Share on other sites

Разнести по разным таблицам маршрутизации провайдеров не судьба? :)

Share this post


Link to post
Share on other sites

Разнести по разным таблицам маршрутизации провайдеров не судьба? :)

Знал бы как не спрашивал.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this