Jump to content
Калькуляторы

cisco 7206 npe-g2, мультикаст, картинка рассыпается в общем-то как всегда снимите с ручника :-)

Всем доброго дня!

Итак ситуация: ГС кабельного телевещания, с одного из их коммутаторов в сеть передачи данных забираем мультикаст, если важно - c7606 в качестве клиента, c3750 и мультиплексор в виде источника. Все там вроде работает, но есть небольшие проблемы ради решения которых пытаюсь развернуть стенд. Стенд - c7206, подключенная к той же 3750, настройки pim-ssm как на 7606, трафика мизер, на выходе квадраты вместо картинки.

Ниже конфиг 7206-й:

 

ip multicast-routing 
ip igmp ssm-map enable
no ip igmp ssm-map query dns
! это адреса мультиплексоров - вещателей
ip igmp ssm-map static ssm-range 192.168.200.1
ip igmp ssm-map static ssm-range 192.168.200.8
! 
! интерфейс в сторону c3750
interface GigabitEthernet0/1
ip address 192.168.50.6 255.255.255.252
ip pim dr-priority 10
ip pim sparse-mode
no ip mroute-cache
load-interval 30
duplex full
speed 1000
media-type rj45
negotiation auto
!  интерфейс в сторону тестовых клиентов
interface GigabitEthernet0/2.400
description IPTV_mvr_AC3
encapsulation dot1Q 400
ip address 192.168.53.17 255.255.255.252
no ip redirects
ip pim sparse-mode
ip igmp static-group 239.1.0.126 source ssm-map
ip igmp static-group 239.1.0.127 source ssm-map
ip igmp static-group 239.1.0.128 source ssm-map
ip igmp static-group 239.1.0.129 source ssm-map
ip igmp static-group 239.1.0.130 source ssm-map
no ip mroute-cache
no snmp trap link-status
! статические маршруты до мультиплексоров
ip classless
ip route 192.168.200.1 255.255.255.255 192.168.50.5
ip route 192.168.200.8 255.255.255.255 192.168.50.5
! RP назначена с3750
ip pim rp-address 192.168.50.5 ssm-range override
ip pim ssm range ssm-range
! ну и собственно нечто вроде фильтра
ip access-list standard ssm-range
permit 239.1.0.0 0.0.0.255
permit 239.2.0.0 0.0.0.255
! 

 

К с7206 подключен коммутатор D-Link DES-3200, где с помощью ISM и igmp snooping обеспечивается возможность подключенному клиенту попросить передать ему телеканалы с ГС.

Схема проста как лом, работает, НО! на экране квадраты вместо картинки, при этом если просто подключить ноутбук к проводу от с3750 и в VLC попросить показать какой-то поток, то картинка в порядке. Вывод - где-то на с7206 что-то не так.

состояние интерфейсов:

 

GigabitEthernet0/1 is up, line protocol is up 
 Hardware is MV64460 Internal MAC, address is 0021.1c52.8c1b (bia 0021.1c52.8c1b)
 Internet address is 192.168.50.6/30
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 1000Mb/s, media type is RJ45
 output flow-control is XON, input flow-control is unsupported
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:00, output 00:00:05, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/3311 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 30 second input rate 7394000 bits/sec, 681 packets/sec
 30 second output rate 0 bits/sec, 0 packets/sec
    33581665 packets input, 2650990338 bytes, 0 no buffer
    Received 1 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 33578733 multicast, 0 pause input
    0 input packets with dribble condition detected
    16670 packets output, 1328511 bytes, 0 underruns
    4 output errors, 0 collisions, 3 interface resets
    0 babbles, 0 late collision, 0 deferred
    4 lost carrier, 0 no carrier, 0 pause output
    0 output buffer failures, 0 output buffers swapped out

GigabitEthernet0/2 is up, line protocol is up 
 Hardware is MV64460 Internal MAC, address is 0021.1c52.8c1a (bia 0021.1c52.8c1a)
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
 Keepalive set (10 sec)
 Full-duplex, 1000Mb/s, media type is RJ45
 output flow-control is XON, input flow-control is unsupported
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:24, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 30 second input rate 0 bits/sec, 0 packets/sec
 30 second output rate 7502000 bits/sec, 688 packets/sec
    4186 packets input, 267904 bytes, 0 no buffer
    Received 2526 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog, 1660 multicast, 0 pause input
    0 input packets with dribble condition detected
    33608671 packets output, 2814656355 bytes, 0 underruns
    4 output errors, 0 collisions, 3 interface resets
    0 babbles, 0 late collision, 0 deferred
    4 lost carrier, 0 no carrier, 0 pause output
    0 output buffer failures, 0 output buffers swapped out

 

Ошибок нет, IOS менял, сейчас установлен:

Cisco IOS Software, 7200 Software (C7200P-ADVIPSERVICESK9-M), Version 12.4(4)XD12, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 04-May-09 11:33 by tinhuang

ROM: System Bootstrap, Version 12.4(12.2r)T, RELEASE SOFTWARE (fc1)
BOOTLDR: Cisco IOS Software, 7200 Software (C7200P-KBOOT-M), Version 12.4(15)T4, RELEASE SOFTWARE (fc2)

Router uptime is 13 hours, 50 minutes
System returned to ROM by reload at 08:02:13 UTC Wed May 28 2014
System image file is "disk2:c7200p-advipservicesk9-mz.124-4.XD12.bin"
Last reload reason: Reload Command

 

Прошу коллег помочь с решением этой беды и рассказать, где я все-таки дурак

Share this post


Link to post
Share on other sites

у вас фаст свитчинг мультика врублен, весь мультик льется через проц 7200 жует мкаст с софтваре

 

interface GigabitEthernet0/1

ip address 192.168.50.6 255.255.255.252

ip pim dr-priority 10

ip pim sparse-mode

no ip mroute-cache <------------------------------------------------------

load-interval 30

duplex full

speed 1000

media-type rj45

negotiation auto

! интерфейс в сторону тестовых клиентов

interface GigabitEthernet0/2.400

description IPTV_mvr_AC3

encapsulation dot1Q 400

ip address 192.168.53.17 255.255.255.252

no ip redirects

ip pim sparse-mode

ip igmp static-group 239.1.0.126 source ssm-map

ip igmp static-group 239.1.0.127 source ssm-map

ip igmp static-group 239.1.0.128 source ssm-map

ip igmp static-group 239.1.0.129 source ssm-map

ip igmp static-group 239.1.0.130 source ssm-map

no ip mroute-cache <------------------------------------------------------

no snmp trap link-status

Edited by applx

Share this post


Link to post
Share on other sites

у вас фаст свитчинг мультика врублен

 

да, я в обеих позах пробовал, и с включением и с выключением - эффекта это не дает никакого, картинка все также сыпется

Edited by White_Alex

Share this post


Link to post
Share on other sites

а сколько трафика? у 7200 нет подобия CEF для мкаста и все жует проц

Share this post


Link to post
Share on other sites

а сколько трафика? у 7200 нет подобия CEF для мкаста и все жует проц

 

ну я выше привел загрузку интерфейсов, ориентировочно на данном этапе около 7 метров, копейки на мой взгляд даже для cpu

 

sh proc cpu s
CPU utilization for five seconds: 0%/0%; one minute: 0%; five minutes: 0%

sh int gi 0/1 | i pack
 30 second input rate 7326000 bits/sec, 673 packets/sec
 30 second output rate 0 bits/sec, 0 packets/sec
sh int gi 0/2 | i pack
 30 second input rate 0 bits/sec, 0 packets/sec
 30 second output rate 7369000 bits/sec, 676 packets/sec

Share this post


Link to post
Share on other sites

а мкаст точно на 7200 не приходит битым? если в 3750 на прямую подключится?

Share this post


Link to post
Share on other sites

а мкаст точно на 7200 не приходит битым? если в 3750 на прямую подключится?

 

я в первом посте топика писал, что таки при подключении хоста прямо к кабелю от с3750 картинка показывается нормального качества без артефактов

Share this post


Link to post
Share on other sites

я в первом посте топика писал, что таки при подключении хоста прямо к кабелю от с3750 картинка показывается нормального качества без артефактов

 

А что происходит, если подключить хост прямо к с7206 минуя коммутатор D-Link DES-3200?

Share this post


Link to post
Share on other sites

А что происходит, если подключить хост прямо к с7206 минуя коммутатор D-Link DES-3200?

 

валится картинка к сожалению

завтра вместо 7206-й включу 3560 коммутатор, нашел один свободный, надоела она мне ей богу :-)

Share this post


Link to post
Share on other sites

Дабы закрыть тему:

грабли оказались в с3750, при физическом переключении линка в другой коммутатор стека все поехало без сбоев. Остался вопрос - что это было? Т.к. по L2 можно получить мультикаст целым с любого коммутатора в стеке, а как только появляется PIM и L3 - нормально отдается картинка только со стек-мастера.

Всем спасибо, кто участвовал в обсуждении.

Share this post


Link to post
Share on other sites

закртыть тему вопросом?

интересный подход

 

что это было? баг софта? это надо детально изучать, но раз проблема разрешилась, то можно просто забить.

на самом деле стеки это такая ущербность, никому бы не рекомендовал, пусть уж лучше независимые железки сами по себе

Share this post


Link to post
Share on other sites

что это было? баг софта? это надо детально изучать, но раз проблема разрешилась, то можно просто забить.

тут все дело в том, что с этой железкой на ГС особо не поразбираешься - хомяки устроят нашествие по случаю неработающего зомбоящика, так что малость спланировал тестирование и запустил телевизионщикам телегу, чтобы думали про окно для работ, жду чего скажут :-)

Share this post


Link to post
Share on other sites

ну не на сети же тестить, создать лабу, роутер, пару свичей в стек и колдунствовать на досуге, софт разный попробовать, статистику дропов разных посмотреть, чего-нибудь где-нибудь да найдется, без сервис контракта конечно это только от скуки делать, а так ведь можно было бы и кейс открыть

Share this post


Link to post
Share on other sites

ну не на сети же тестить, создать лабу, роутер, пару свичей в стек и колдунствовать на досуге, софт разный попробовать, статистику дропов разных посмотреть, чего-нибудь где-нибудь да найдется, без сервис контракта конечно это только от скуки делать, а так ведь можно было бы и кейс открыть

эх... как же ж в пятницу да не помечтать о красивом, правда?:-) реальность она как всегда немного другая, но мы не унываем да :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this