Jump to content
Калькуляторы

Разная скорость Интернет+Peer+local на ASR1k Lanbilling+ISG

Приветствую всех!

 

Нужна помощь в настройке связки АСР LANBilling 2.0 с Cisco ISG.

 

Схема авторизации IPoE (DHCP+Opt.82)

 

Нужно привязать к ISG разные скорости к разным сетям (peer+local), есть вариант сделать через ACL, но этот костыль не подходит для пиринга, там по BGP много префиксов приходит.

 

У кого какие мысли ?

 

 

Заранее спасибо!

Share this post


Link to post
Share on other sites

Есть вариант типа:

policy-map p-in

class c-in

police rate 20480000 burst 20480000 conform-action transmit exceed-action drop

 

policy-map p-out

class c-out

police 20480000 20480000 20480000 conform-action transmit exceed-action drop

 

class-map match-all c-out

match access-group 101

 

class-map match-all c-in

match access-group 100

 

access-list 100 permit ip any any

access-list 101 permit ip any any

 

но тогда придется все IP адреса из пиринга прописывать в ACL. Как сделать что-бы без этого костыля ?

Share this post


Link to post
Share on other sites

похоже, что никак с таким подходом. обычные классмапы нельзя сувать в сервис.. так можно было бы чекнуть по qos-group, или еще чему-нить (типа dscp).

 

хотя попробуйте.

 

class-map match-all OLOLO
match qos-group 10

policy-map OLOLOLO
class OLOLO
 police cir 100000000
  conform-action transmit
  exceed-action drop
  violate-action drop
!

policy-map type service OLOLO
 service-policy output OLOLOLO
!

и вешать сервис OLOLO (возможно перепутал направление).

ну и полиси мама на пиринговом интерфейсе с set qos-group на инпут.

Edited by zhenya`

Share this post


Link to post
Share on other sites

похоже, что никак с таким подходом.

На какой подход поменять ?

Share this post


Link to post
Share on other sites

похоже, что никак с таким подходом.

На какой подход поменять ?

продолжение гляньте с классмапой и полисей. потом отпишите интересно сработает или нет..

Share this post


Link to post
Share on other sites

Да конечно, попробую отпишусь...

Share this post


Link to post
Share on other sites

похоже, что никак с таким подходом. обычные классмапы нельзя сувать в сервис.. так можно было бы чекнуть по qos-group, или еще чему-нить (типа dscp).

 

хотя попробуйте.

 

class-map match-all OLOLO
match qos-group 10

policy-map OLOLOLO
class OLOLO
 police cir 100000000
  conform-action transmit
  exceed-action drop
  violate-action drop
!

policy-map type service OLOLO
 service-policy output OLOLOLO
!

и вешать сервис OLOLO (возможно перепутал направление).

ну и полиси мама на пиринговом интерфейсе с set qos-group на инпут.

 

не взлетела

Share this post


Link to post
Share on other sites

У меня на 3845 работала вот такая конструкция:

policy-map PEERS-In
 description --- Set QoS Group = 10 to All Traffic ---
class class-default
 set qos-group 10

; Навешиваем ее на IN пиринговых интерфейсов... - то есть "раскрашиваем" пакеты, можно хоть по dscp

class-map match-any PEER-Traffic
match qos-group 10

policy-map SHAPER
class PEER-Traffic  ; Обязательно первым правилом
...
; лимитируем кому и сколько
...

; Навешиваем на OUT на интерфейсах к клиентам

Share this post


Link to post
Share on other sites

У меня на 3845 работала вот такая конструкция:

policy-map PEERS-In
 description --- Set QoS Group = 10 to All Traffic ---
class class-default
 set qos-group 10

; Навешиваем ее на IN пиринговых интерфейсов... - то есть "раскрашиваем" пакеты, можно хоть по dscp

class-map match-any PEER-Traffic
match qos-group 10

policy-map SHAPER
class PEER-Traffic  ; Обязательно первым правилом
...
; лимитируем кому и сколько
...

; Навешиваем на OUT на интерфейсах к клиентам

 

Через Cisco-Avpair += lcp:interface-config#1=service-policy input это понятно как навешать, как это сделать через Cisco-Service-Info

Share this post


Link to post
Share on other sites

похоже, что никак с таким подходом. обычные классмапы нельзя сувать в сервис.. так можно было бы чекнуть по qos-group, или еще чему-нить (типа dscp).

 

хотя попробуйте.

 

class-map match-all OLOLO
match qos-group 10

policy-map OLOLOLO
class OLOLO
 police cir 100000000
  conform-action transmit
  exceed-action drop
  violate-action drop
!

policy-map type service OLOLO
 service-policy output OLOLOLO
!

и вешать сервис OLOLO (возможно перепутал направление).

ну и полиси мама на пиринговом интерфейсе с set qos-group на инпут.

Или я не правильно вас понял... но МОЖНО.

 

class-map match-all SNMP

match access-group name SNMP

class-map match-all TELNET

match access-group name TELNET

 

 

policy-map Tunnel-child

class SNMP

bandwidth percent 2

class TELNET

bandwidth percent 1

 

 

policy-map Tunnel_10M

class class-default

shape average 10000000

police rate 10000000

violate-action drop

service-policy Tunnel-child

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this