Jump to content
Калькуляторы

eompls cisco

Коллеги, прошу прощения не нубский вопрос:

 

Будет ли работать eompls через обычную сеть? Через туннели например

Правильно ли я понимаю, что если у меня sh mpls ldp neighbor отрабатывает, то и вланы можно пробрасывать?

 

Спасибо!

Share this post


Link to post
Share on other sites

LDP он лдп. LSP нужно между точками или ты хочешь eompls over gre ?

Share this post


Link to post
Share on other sites

я хочу получить проброс вланов между площадки любым путем. между ними есть провайдерская оптика и проброшен один акссес влан

Share this post


Link to post
Share on other sites

я как раз не давно спрашивал про это :)

просмотрите тему "Простой вопрос по MPLS", ссылку дать не могу, т.к. сижу с телефона.

Edited by elyor

Share this post


Link to post
Share on other sites

прочитал тему, спасибо. насколько я понимаю, мне надо использовать gre?

Share this post


Link to post
Share on other sites

если вам нужен именно eompls, то да, нужно mpls пустить через gre.

Share this post


Link to post
Share on other sites

я хочу получить проброс вланов между площадки любым путем. между ними есть провайдерская оптика и проброшен один акссес влан

Что значит провайдерскай оптика и один влан ?

Если волокно провайдера, но активное оборудование своё, то это физическая связь и вланов тут можно пробросить сколько угодно без всякого MPLS.

Share this post


Link to post
Share on other sites

я хочу получить проброс вланов между площадки любым путем. между ними есть провайдерская оптика и проброшен один акссес влан

если аксесс влан и прямая видимость между вашими маршрутизаторами (т.е. один l2-домен), то можно без gre поднять mpls и пустить eompls.

Share this post


Link to post
Share on other sites

такое ощущение, что из пушки по воробьям...

Share this post


Link to post
Share on other sites

Если дают только один влан, то mpls это самый простой способ пробросить l2 (но не факт, что самый дешёвый, ибо может потребоваться докупка лицензий/модернизация оборудования)

 

ну и конечно же возникает "проблема" с mtu

Share this post


Link to post
Share on other sites

никак не могу я сделать, что бы работал l2 transport. стык пытаюсь сделать из шеститонника и 2901

C6506-kor-OSK-R1#sh mpls l2transport vc 1 d

Local interface: Gi1/5/1.301 up, line protocol up, Eth VLAN 301 up

Interworking type is Ethernet

Destination address: 10.12.12.1, VC ID: 1, VC status: down

Create time: 21:56:42, last status change time: 21:56:42

Signaling protocol: LDP, peer unknown

Targeted Hello: 10.11.11.2(LDP Id) -> 10.12.12.1

Status TLV support (local/remote) : enabled/unknown (no remote binding)

Label/status state machine : local standby, AC-ready, LnuRnd

Last local dataplane status rcvd: no fault

Last local SSS circuit status rcvd: no fault

Last local SSS circuit status sent: not sent

Last local LDP TLV status sent: not sent

Last remote LDP TLV status rcvd: unknown (no remote binding)

MPLS VC labels: local 22, remote unassigned

Group ID: local 0, remote unknown

MTU: local 1500, remote unknown

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 0, send 0

byte totals: receive 0, send 0

packet drops: receive 0, seq error 0, send 0

 

и с рутера

Router#sh mpls l2transport vc 1 d

Local interface: Gi0/1.301 up, line protocol up, Eth VLAN 301 up

Destination address: 10.12.13.1, VC ID: 1, VC status: down

Output interface: none, imposed label stack {}

Preferred path: not configured

Default path: no route

No adjacency

Create time: 22:20:09, last status change time: 21:57:56

Signaling protocol: LDP, peer 10.11.11.2:0 up

Targeted Hello: 10.11.11.1(LDP Id) -> 10.12.13.1

Status TLV support (local/remote) : enabled/unknown (no remote binding)

Label/status state machine : local ready, LruRnd

Last local dataplane status rcvd: no fault

Last local SSS circuit status rcvd: no fault

Last local SSS circuit status sent: not sent

Last local LDP TLV status sent: no fault

Last remote LDP TLV status rcvd: unknown (no remote binding)

MPLS VC labels: local 18, remote unassigned

Group ID: local 0, remote unknown

MTU: local 1500, remote unknown

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 0, send 0

byte totals: receive 0, send 0

packet drops: receive 0, seq error 0, send 0

 

выделил, как мне кажется, проблемное место. ни у кого нет мыслей?

Share this post


Link to post
Share on other sites

l2 router-id, transport-address покажите

а вообще лучше весь конфиг, относящейся к mpls и этому xconnect

Share this post


Link to post
Share on other sites

шеститонник:

interface Loopback0

ip address 10.12.13.1 255.255.255.255

 

 

pseudowire-class vlan

encapsulation mpls

interworking ethernet (это я пытался одинаковый vc сделать)

 

interface GigabitEthernet1/5/1

no switchport

ip address 10.11.11.2 255.255.255.252

ip ospf cost 1

mpls ip

 

 

 

interface GigabitEthernet1/5/1.301

encapsulation dot1Q 301

xconnect 10.12.12.1 1 pw-class vlan

 

 

mpls ldp router-id GigabitEthernet1/5/1 force

 

рутер:

mpls label protocol ldp

 

pseudowire-class vlan

encapsulation mpls

interworking ethernet

 

interface Loopback0

ip address 10.12.12.1 255.255.255.255

 

interface GigabitEthernet0/0.464

encapsulation dot1Q 464

ip address 10.99.64.230 255.255.255.0

!

interface GigabitEthernet0/1

ip address 10.11.11.1 255.255.255.252

duplex auto

speed auto

mpls ip

!

interface GigabitEthernet0/1.301

encapsulation dot1Q 301

xconnect 10.12.13.1 1 pw-class vlan

ldp router-id GigabitEthernet0/1 force

Share this post


Link to post
Share on other sites

прочитал тему, спасибо. насколько я понимаю, мне надо использовать gre?

Нет. Сначала надо просто провайдера спросить что он дает. Если он уже дает xconnect между, то все что вам нужно - это всего лишь завернуть свои вланы туда куда он просит.

Share this post


Link to post
Share on other sites

ну у меня и с gre и без него сейчас ситуация одинаковая

Share this post


Link to post
Share on other sites

Попробуйте сделать так, чтобы LDP router-id брался с Loopback интерфейсов.

Share this post


Link to post
Share on other sites

сделал, ситуация не изменилась

Share this post


Link to post
Share on other sites

а я вот сейчас подумал. не кривизна ли это: я пытаюсь поднять саб интерфейс и указать тэг вилана на порту, который в ip режиме работает

Share this post


Link to post
Share on other sites

да, почему у вас иксконнекты в сторону провайдера? :)

Share this post


Link to post
Share on other sites

Smotrite 4to pishet v remote mtu tam podskazka...

 

Da i voobshe zafiig pseudowire class? Ego mojno ne ykazuvati

Share this post


Link to post
Share on other sites

да, почему у вас иксконнекты в сторону провайдера? :)

 

иксконнекты на лупбеки соседа. а куда надо? :)

 

Smotrite 4to pishet v remote mtu tam podskazka...

 

какая? мту соседа неизвестен. а так он с обеих сторон 1500

Share this post


Link to post
Share on other sites

Покажите с обеих коробок:

 

show ip route <loopback адрес другой коробки>

show mpls ldp neigh

show mpls interface

show mpls ldp discovery

 

Между Loopback-ами ping ходит?

Edited by nnm

Share this post


Link to post
Share on other sites

маршруты к loopback:

C6506-kor-OSK-R1#sh ip ro 10.12.12.1

Routing entry for 10.12.12.1/32

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 10.11.11.1

Route metric is 0, traffic share count is 1

Routing entry for 10.12.13.1/32

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 10.11.11.2

Route metric is 0, traffic share count is 1

 

 

ldp neigh

C6506-kor-OSK-R1#sh mpls ldp ne

Peer LDP Ident: 10.12.12.1:0; Local LDP Ident 10.12.13.1:0

TCP connection: 10.12.12.1.646 - 10.12.13.1.63684

State: Oper; Msgs sent/rcvd: 1556/1496; Downstream

Up time: 21:37:56

LDP discovery sources:

GigabitEthernet1/5/1, Src IP addr: 10.11.11.1

Targeted Hello 10.12.13.1 -> 10.12.12.1, active, passive

Addresses bound to peer LDP Ident:

10.99.64.230 10.11.11.1 10.12.12.1

Router#sh mpls ldp neighbor

Peer LDP Ident: 10.12.13.1:0; Local LDP Ident 10.12.12.1:0

TCP connection: 10.12.13.1.63684 - 10.12.12.1.646

State: Oper; Msgs sent/rcvd: 1497/1557; Downstream

Up time: 21:38:23

LDP discovery sources:

Targeted Hello 10.12.12.1 -> 10.12.13.1, active, passive

GigabitEthernet0/1, Src IP addr: 10.11.11.2

Addresses bound to peer LDP Ident:

192.168.12.2 10.99.57.1 10.99.1.1 10.99.53.1

10.99.54.1 10.99.55.1 10.99.56.1 10.99.58.1

10.99.60.1 10.99.61.3 10.99.63.1 10.10.20.1

10.99.59.1 10.200.22.1 10.11.11.2 10.12.13.1

 

интерфейсы

C6506-kor-OSK-R1#show mpls interface

Interface IP Tunnel BGP Static Operational

GigabitEthernet1/5/1 Yes (ldp) No No No Yes

 

Router#sh mpl int

Interface IP Tunnel BGP Static Operational

GigabitEthernet0/1 Yes (ldp) No No No Yes

Router#

 

ldp discovery

C6506-kor-OSK-R1#show mpls ldp discovery

Local LDP Identifier:

10.12.13.1:0

Discovery Sources:

Interfaces:

GigabitEthernet1/5/1 (ldp): xmit/recv

LDP Id: 10.12.12.1:0

Targeted Hellos:

10.12.13.1 -> 10.12.12.1 (ldp): active/passive, xmit/recv

LDP Id: 10.12.12.1:0

 

Router#sh mpl ld di

Local LDP Identifier:

10.12.12.1:0

Discovery Sources:

Interfaces:

GigabitEthernet0/1 (ldp): xmit/recv

LDP Id: 10.12.13.1:0

Targeted Hellos:

10.12.12.1 -> 10.12.13.1 (ldp): active/passive, xmit/recv

LDP Id: 10.12.13.1:0

 

пинги между лупбэкапи ходят. вообще, все очевидное вроде бы правильно настроено

Share this post


Link to post
Share on other sites

Выглядит красиво. Попробуйте убрать internetworking или весь pw-class. На 65xx/76xx есть ограничения, связанные с IW.

Share this post


Link to post
Share on other sites

да я все это делал. pw-class сделал после такого как enc mpls не завелось

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this