Jump to content
Калькуляторы

Multicast & BDCOM 3310

Добрый день, столкнулся с проблемами реализации 2х услуг одновременно через OLT. Схема, как работает в действующей сети IPTV, приложена.

Сейчас сделано так:

- Источник подключен к Cisco 3750 через vlan 9, она является mrouter

- На Cisco3750 стерминированны vlan 54 (это PPPoE+подмешивается мультикаст) и vlan 10 (чистый мультикаст)

- Если клиенту надо ТВ без интернета, то STB подключается к порту с vlan 10

- Если клиенту надо ТВ + Интернет, то Роутер клиента подключается к порту с vlan 54, настраивается Dual Access PPPoE и multicast forwarding, STB за роутером

- Если клиенту надо ТВ + Интернет, но без ТВ (только на ПК), то аналогично см. выше

Соответственно везде igmp snooping в vlan на коммутаторах включен. Всё работает идеально! )))

Руководство захотело шайтан PON протестировать фирмы BDCOM, модель p3310. Стенд собрал, что то даже сделал (vlan на ONU). А вот сделать так, чтобы работали аналогичные схемы для IPTV через OLT + ONU не могу. Есть у кого опыт в настройки multicast на OLT ? Хотелось бы получить схему с 4х портовой ONU, где сервисы разделены по портам. Но естественно с механизмами, аналогичными igmp snooping. Настроил по мануалу вариант с multicast vlan на OLT, но появились проблемы:

1. Если cts port 1 vlan 54 (чистый PPPoE, без мультикаста) и cts mcst port 1 mc-vlan 10, то в схеме с роутером, Интернет есть, а мультикаст не льётся. Без роутера - есть и Интернет и Мультикаст, только поток идет ровно 30 сек и пропадает.

2. Если cts port 1 vlan 54 (чистый PPPoE, без мультикаста) и cts port 2 vlan 10, то с порта 2 igmp запросы уходят в OLT и там, видимо, дропаются. Интернет разумеется с порта 1 работает.

post-86069-083802000 1397643892_thumb.png

Share this post


Link to post
Share on other sites

тут пример с рабочего олт с мультикастом

 

interface GigaEthernet0/1

switchport trunk vlan-allowed 101-164,3021,4000

switchport trunk vlan-untagged none <--- - это важно

switchport mode trunk

switchport pvid 4000 <--- 4000 multicast vlan - это важно

 

interface EPON0/1

switchport trunk vlan-allowed 101-164,3021,4000,4060-4062

switchport mode trunk

switchport pvid 3021

switchport protected

 

interface EPON0/1:1

onu-configuration

switchport port-security dynamic maximum 10

switchport port-security mode dynamic

epon onu port 1 ctc vlan mode tag 101

epon onu port 2 ctc vlan mode tag 101

epon onu port 3 ctc vlan mode tag 101

epon onu port 4 ctc vlan mode tag 101

 

 

vlan 1,100-164,3021,4000

vlan 4060-4062

!

ip mcst enable

ip mcst mc-vlan 4062 range 239.239.237.1 - 239.239.237.100

ip mcst mc-vlan 4061 range 239.239.238.1 - 239.239.238.50

ip mcst mc-vlan 4060 range 239.239.239.1 - 239.239.239.100 , 239.239.239.200

Share this post


Link to post
Share on other sites

Спасибо, протестирую, но это вариант с Multicast vlan. Кстати, а где в onu config указано, в каких портах есть Multicast vlan ? А можно сделать на OLT классическую схему с igmp snooping внутри нужного vlan ?

Edited by uk2558

Share this post


Link to post
Share on other sites

Кстати, а где в onu config указано, в каких портах есть Multicast vlan ?

сорри

забыл

 

epon onu port 4 ctc mcst tag-stripe enable

epon onu port 4 ctc mcst mc-vlan add 4060-4061

 

на 4 порте будет мультикастом ТВ бегать

Share this post


Link to post
Share on other sites

Спасибо, вроде работает. Но мне не нравиться идея с отдельным multicast vlan. Я так понял, что в OLT нет классического igmp snooping by vlan ... Печально.

Share this post


Link to post
Share on other sites

Доброго дня всем.

 

столкнулся с такой проблемой как на BDCOM 3310C заставить работать мультикаст

схема такая

имееться влан от поставщика контента с PIM

принимаем на микротик CCR1072 тоже с поднятым PIM

далее сеть на OSPF отдаем через PIM на другой микротик и там тоже естественно поднимаем PIM

на нем поднимаем VLAN  включаем его в PIM 

и отдаем на станцию уже в влан на юзеров

картинки нема 

при этом всём если на этом микротике подключаю в PIM интерфейс с компом то VLC  показывает

то есть контент доходит

 

 

 

photo_2018-02-16_10-59-15.jpg

Share this post


Link to post
Share on other sites

Коллеги, а у кого получалось и как передать iptv на однопортовый onu bdcom p1501 ?

Трафик интернет на стенде бегает без проблем

Share this post


Link to post
Share on other sites

Всем доброго подскажите а как настроить OLT и ONU если у меня мультикаст бегает в пользовательском влане и приставка однопортовая
у меня приставка(онушка) имеет назначение как медиаконвертер какие тогда настройки ?
а также какие настройки когда однопортовая приставка но она сама является роутером  - тобиш делает PPPoE

Share this post


Link to post
Share on other sites

Всем привет!

 

Возвращаясь к вопросу по Multicast, подскажите, что не так настроено. 

Имеется IPTV канал, который приходит на Mikrotik через PIM (на микротике мультик гуляет, проверял). 

BDCOM 3310C подключен к Mikrotik. 

Абоненты подключены через терминалы BDCOM P1501D1.

Авторизовываются абоненты через PPPoE, но телевидение не работает. Прочитал на одном из форумов по BDCOM, что multicast с PPPoE не работает, но пробовал выдать ip-адрес абоненту без всяких авторизаций, такая же ситуация. 

 

!version 10.1.0E build 50174
service timestamps log date
service timestamps debug date
service password-encryption
logging buffered 4096
!
port-protected 1
!
ip default-gateway xx.yy.zz.cc
!
no spanning-tree
!
aaa authentication login default local
aaa authentication enable default none
aaa authorization exec default local
!
username SuperUser password 7 000000000000000
!
epon oam-version 1 0x21
epon oam-version 2 0x20
!
epon onu-config-template cfg
 cmd-sequence 001 switchport port-security mode dynamic
 cmd-sequence 002 switchport port-security dynamic maximum 10
 cmd-sequence 003 epon sla upstream pir 1000000 cir 19200
 cmd-sequence 004 epon sla downstream pir 1000000 cir 19200
 cmd-sequence 005 epon onu port 1 ctc vlan mode tag 64 priority 0
!
!!slot 0 89
interface GigaEthernet0/1
 switchport trunk vlan-allowed MNG
 switchport mode trunk
  dhcp snooping trust
  arp inspection trust
  ip-source trust
!
interface GigaEthernet0/2
 switchport pvid MNG
!
interface GigaEthernet0/3
 switchport trunk vlan-allowed MNG,IPTV
 switchport trunk vlan-untagged none
 switchport mode trunk
 switchport pvid IPTV
  dhcp snooping trust
  arp inspection trust
  ip-source trust
!
interface GigaEthernet0/4
 shutdown
!
interface GigaEthernet0/5
 shutdown
!
interface GigaEthernet0/6
 shutdown
!
interface EPON0/1
 epon pre-config-template sprint binded-onu-llid 1-64
 epon bind-onu mac 8479.7399.cba9 1
 epon bind-onu mac 8479.7399.d74f 2
 filter dhcp
 switchport trunk vlan-allowed MNG,IPTV
 switchport mode trunk
 switchport protected 1
 flow-control on
!
interface EPON0/1:1
!
interface EPON0/1:2
 switchport port-security dynamic maximum 10
 switchport port-security mode dynamic
  epon onu port 1 ctc vlan mode tag 64 priority 0
  epon onu port 1 ctc mcst tag-stripe enable
  epon onu port 1 ctc mcst mc-vlan add IPTV
 epon sla upstream pir 1000000 cir 19200
 epon sla downstream pir 1000000 cir 19200
!
interface EPON0/2
 epon pre-config-template sprint binded-onu-llid 1-64
 epon bind-onu mac 8479.7399.c28e 1
 epon bind-onu mac 8479.7399.dea9 2
 epon bind-onu mac 8479.7399.d69d 3
 filter dhcp
 switchport trunk vlan-allowed MNG,IPTV
 switchport mode trunk
 switchport protected 1
 flow-control on
!
interface EPON0/2:1
 switchport port-security dynamic maximum 10
 switchport port-security mode dynamic
  epon onu port 1 ctc vlan mode tag 64 priority 0
  epon onu port 1 ctc mcst tag-stripe enable
  epon onu port 1 ctc mcst mc-vlan add IPTV
 epon sla upstream pir 1000000 cir 19200
 epon sla downstream pir 1000000 cir 19200
!
interface EPON0/2:2
 switchport port-security dynamic maximum 10
 switchport port-security mode dynamic
  epon onu port 1 ctc vlan mode tag 64 priority 0
  epon onu port 1 ctc mcst tag-stripe enable
  epon onu port 1 ctc mcst mc-vlan add IPTV
 epon sla upstream pir 1000000 cir 19200
 epon sla downstream pir 1000000 cir 19200
!
interface EPON0/2:3
 switchport port-security dynamic maximum 10
 switchport port-security mode dynamic
  epon onu port 1 ctc vlan mode tag 64 priority 0
  epon onu port 1 ctc mcst tag-stripe enable
  epon onu port 1 ctc mcst mc-vlan add IPTV
 epon sla upstream pir 1000000 cir 19200
 epon sla downstream pir 1000000 cir 19200
!
interface EPON0/3
 shutdown
 switchport protected 1
!
interface EPON0/4
 shutdown
 switchport protected 1
!
!!slot end
!
interface VLAN_MNG
 ip address xx.yy.zz.cc 255.255.255.0
!
vlan MNG
 name MNG
!
vlan IPTV
 name IPTV
!
vlan 1,MNG,64,IPTV
!
ip mcst enable
ip mcst mrouter interface GigaEthernet0/3
ip mcst mc-vlan IPTV range 225.1.5.1 - 225.1.5.10 , 233.161.171.48 , 233.166.171.41 - 233.166.171.60 , 233.166.172.13 - 233.166.172.16
!
ip dhcp-relay snooping
ip dhcp-relay snooping vlan  64
ip arp inspection vlan  64
ip verify source vlan  64
ip dhcp-relay snooping information option format hn-type
ip dhcp-relay agent
ip dhcp-relay helper-address xx.yy.zz.cc vlan MNG
!
ip telnet source-interface VLAN_MNG
!
ip http server
!
snmp-server community 0 public RO 
!
ntp server xx.yy.zz.cc
!
!No configurations pending global

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this