Jump to content
Калькуляторы

увеличения скорости за счет VPN внутри сети провайдера

Здравствуйте.

В двух точках есть интернет от одного провайдера, в первой скорость значительно выше чем в другой- там оптика, во второй АДСЛ и скорость 1.5мб на вход. На порту стоить скорость 16мб, внутри сети провайдера скорость лимитируется только скоростью порта. Если поднять VPN сервер в первой точке и второй подключится к нему через VPN, то можно будет завернуть весь трафик так, чтобы запрос шел через первую точку, и потом на правах трафика локальной сети, со скоростью порта проходил через VPN без ограничений по тарифу? больше подключить там нельзя.

Share this post


Link to post
Share on other sites

translate: "Подскажите, провайдеры, как правильно с***ить трафик у провайдера?"

Share this post


Link to post
Share on other sites

translate: "Подскажите, провайдеры, как правильно с***ить трафик у провайдера?"

Зато честно, что такого? при том что я не спрашивал пока что как, а спросил стоит в эту сторону копать, или нет, да и по идее все в рамках приличия.

Share this post


Link to post
Share on other sites

Зато честно, что такого? при том что я не спрашивал пока что как, а спросил стоит в эту сторону копать, или нет, да и по идее все в рамках приличия.

Если есть уверенность, что у провайдера через DSL скорость внутри сети не шейпится, то через VPN проканает нормально. А вашему юрлицу зачем скорость выше то? Видео с ютюба тормозит?

Share this post


Link to post
Share on other sites

Если есть уверенность, что у провайдера через DSL скорость внутри сети не шейпится, то через VPN проканает нормально. А вашему юрлицу зачем скорость выше то? Видео с ютюба тормозит?

Это не на работу, другу в сельскую местность прокинуть. при загрузке с торентов, если находит местные раздачи поднимается прилично.

Edited by weedman

Share this post


Link to post
Share on other sites

При работе через DDNS без статики могут быть проблемы?

Share this post


Link to post
Share on other sites

Зато честно, что такого? при том что я не спрашивал пока что как, а спросил стоит в эту сторону копать, или нет, да и по идее все в рамках приличия.

Да ни в какую.

На ADSL выше 2 Мбит/с рассчитывать не стоит.

Share this post


Link to post
Share on other sites

На ADSL выше 2 Мбит/с рассчитывать не стоит.

Эмс... Отчего же?

Share this post


Link to post
Share on other sites

Эмс... Отчего же?

От того, что в большинстве случаев состояние телефонной сети такое.

А кроме того:

1. Весь трафик инкапсулируется в VPN, поэтому он в любом случае будет ограничен восходящим потоком, даже если на входящем канал и пропускает 16 Мбит/с.

2. Раз весь трафик инкапсулируется в VPN, значит он будет занимать двойную полосу.

Share this post


Link to post
Share on other sites

1. Весь трафик инкапсулируется в VPN, поэтому он в любом случае будет ограничен восходящим потоком, даже если на входящем канал и пропускает 16 Мбит/с.

2. Раз весь трафик инкапсулируется в VPN, значит он будет занимать двойную полосу.

Честно говоря нигде не встречал информации, что через VPN такое падение скорости.

Share this post


Link to post
Share on other sites

2. Раз весь трафик инкапсулируется в VPN, значит он будет занимать двойную полосу.

Вот это вот можно более расширенно описать?

Share this post


Link to post
Share on other sites

1. Весь трафик инкапсулируется в VPN, поэтому он в любом случае будет ограничен восходящим потоком, даже если на входящем канал и пропускает 16 Мбит/с.

2. Раз весь трафик инкапсулируется в VPN, значит он будет занимать двойную полосу.

Честно говоря нигде не встречал информации, что через VPN такое падение скорости.

+, на вскидку процентов 5, ну 10 максимум от полосы, но никак не больше

Share this post


Link to post
Share on other sites

у одного достаточно жирного прова, дающего adsl и fttx при этом не лимитирующего скорость внутри сети и дающего абсолютно гондонские тарифы для юриков ***или трафик так:

 

дома как физик поднимали пппое, брали статический ипешник, ставили впн сервер, а в офисе дсл модем и впн роутер

 

дома всё зашибись рулится одним dlink di-804 vpn или любым микротиком

в офисе -- любой adsl модем + роутер с поддержкой vpn

Share this post


Link to post
Share on other sites

Честно говоря нигде не встречал информации, что через VPN такое падение скорости.

Да, перепутал ситуацию немного.

Я говорил не о падении скорости и даже не про overhead, а о том, что трафик который прошел по VPN от точки 1 до точки 2 должен будет потом пройти в обратном направлении и занять такую же полосу. Но это я перепутал, в данном случае такого не будет.

Share this post


Link to post
Share on other sites

у одного достаточно жирного прова, дающего adsl и fttx при этом не лимитирующего скорость внутри сети и дающего абсолютно гондонские тарифы для юриков ***или трафик так:

 

дома как физик поднимали пппое, брали статический ипешник, ставили впн сервер, а в офисе дсл модем и впн роутер

 

дома всё зашибись рулится одним dlink di-804 vpn или любым микротиком

в офисе -- любой adsl модем + роутер с поддержкой vpn

А если делать с DDNS, то проблем не должно быть? если модем настроен бриджем, то и проброс портов делать не надо будет?

Share this post


Link to post
Share on other sites

какой тип VPN хотите? есть split tunnel, там не весь траффик идет через VPN а только выборочный, в данном случае проблем с DDNS не будет

Share this post


Link to post
Share on other sites

какой тип VPN хотите? есть split tunnel, там не весь траффик идет через VPN а только выборочный, в данном случае проблем с DDNS не будет

по поводу типа VPN не определился, хотелось бы самый простой в настройке, элемент безопасности не очень волнует.

Share this post


Link to post
Share on other sites

продвигаюсь черепашьими темпами к решению вопроса, по этой инструкции http://mikrotik.axiom-pro.ru/library.php сделал pptp соединение к своему домашнему компу с работы, пинг идет, подскажите как теперь сделать так, чтобы трафик шел через это подключение? попробовал создать на компе подключение pptp, соединение тоже создалось, но как прикрутить dhcp сервер на pptp сервер пока не понял.

Share this post


Link to post
Share on other sites

но как прикрутить dhcp сервер на pptp сервер пока не понял.

В школах каникулы начались? Кури мануал по микротику. Создай пул адресов на микротике и всё сразу заведётся. Я также наяпываю, только через рррое.

Спасибо микротику...окупился за 3 месяца.

Edited by Diamont

Share this post


Link to post
Share on other sites

Если все на микротиках, и весь трафик то все просто:

r1 - офис, r2 - дом

1. настроить туннель между шлюзами.

r1

/interface l2tp-server server set enabled=yes --- вкл.сервер

/ppp secret add name=test password=pass123 remote-address=10.11.12.2 local-address=10.11.12.1 service=l2tp ---завели пользователя

r2

/interface l2tp-client add user=test password=pass123 add-default-route=no connect-to=1.2.3.4 --зацепились туда

 

2. Настроить маршрутизацию между сетями

например в офисе 192.168.1.0/24 дома 192.168.10.0/24

r1

/ip route add dst-address=192.168.10.0/24 gateway=10.11.12.2

r2

/ip route add dst-address=192.168.1.0/24 gateway=10.11.12.1

 

вот и всё сети между собой связаны, на r1 переназначать основной шлюз на 10.11.12.2, у подключения в инет выставить distance=100, тогда трафик будет идти через дом - а если отвалится то все как обычно. Ну и NATить только что идет в инет

/ip firewall address-list add list=my_net address=192.168.1.0/24

/ip firewall address-list add list=my_net address=192.168.10.0/24

/ip firewall nat add action=masquerade out-interface=dsl-out src-address-list=my_net dst-address-list=!my_net

 

на r2 - настроить NAT для выхода в инет из обоих сетей.

ну как-то так

/ip firewall address-list add list=my_net address=192.168.1.0/24

/ip firewall address-list add list=my_net address=192.168.10.0/24

/ip firewall nat add action=masquerade out-interface=ether1-wan src-address-list=my_net dst-address-list=!my_net

Edited by eugenesch

Share this post


Link to post
Share on other sites

Спасибо за подробное обьяснение, если я правильно понял, то сервер в офисе, дома клиент VPN, но ходить будет из офиса через VPN сервер в VPN клиент и оттуда в интернет? первая часть (связь сервер-клиент) легкая и получается нормально, вторая (маршрутизация) не совсем понятна.

Share this post


Link to post
Share on other sites

в общем смотри

надо разделить на 2 части задачу.

1. связать сети

2. выход в инет по определенным правилам.

...............

первая часть VPN просто частный случай, если сети 2 то нет разницы где клиент где сервер. (можно их связать каким нибудь GRE или IPIP туннелем, если они друг друга видят). Сервер в офисе расположил по причине, что скорей всего в офисе адрес статический, а дома динамика может быть.

Далее - маршрутизация. мммм, а в чем проблема то? На первом роутере прописываем ходить в сеть офиса через туннель, на втором что ходить в домашнюю сеть через туннель. ну т.е.

|ДОМ(телик например) |r2|туннель через провайдера|r1|ОФИС(тут диск с фильмами)|

часть 2 - NAT. my_net это список наших сетей. Надо на обоих роутерах разрешить выход в инет из my_net, и при этом не натить трафик между сетями.

/ip firewall nat add action=masquerade out-interface=ether1-wan src-address-list=my_net dst-address-list=!my_net вот както так

теперь надо сказать роутеру в офисе что, шлюз у него не пров, а домаший роутер.

/ip route add dst-address=0.0.0.0/0 gateway=10.11.12.2 distance=1

на случай если связь с домом пропала оставим выход как обычно

/ip route add dst-address=0.0.0.0/0 gateway=шлюз из договора distance=10

все. теперь офисная сеть и домашняя сеть видят друг друга, из офиса в инет ходят через дом, а текущий канал в резерве.

Share this post


Link to post
Share on other sites

Буду пробовать, понимаю что это для спеца элементарно, но я только учусь маленькими шагами, вообще интересная тема, но образования гуманитария с ин.яза не совсем хватает. на работе динамика, дома специально для тестов поставил статику белую, эксперементирую.

Share this post


Link to post
Share on other sites

скопипастил в ворд и переделал под своею сеть, сразу скажу не получилось ничего.

Настраиваю так, чтобы хоить с работы через дом, там подключил статику.

дома сеть- 10.1.0.0/24

на работе микротик 10.1.1.0/24 стоит за 192.168.1.0/24 (то что он за этой сетью на сколько понимаю не важно, соединение в любом случае есть)

Дома создан L2pt сервер 10.11.12.1

На работе клиент подключен 10.11.12.2

у обоих Wan- ether1

Делаю следующее, но к сожалению без понимания.

r1

/ip route add dst-address=10.1.0.0/24 gateway=10.11.12.2

r2

/ip route add dst-address=10.1.1.0/24 gateway=10.11.12.1

 

и на обоих роутерах

/ip firewall address-list add list=my_net address=10.1.1.0/24

/ip firewall address-list add list=my_net address=10.1.0.0/24

/ip firewall nat add action=masquerade out-interface= ether1 src-address-list=my_net dst-address-list=!my_net

 

после третьей строки, терминал спрашивает "Chain:", пишу forward

 

В чем ошибка?

Share this post


Link to post
Share on other sites

Зато честно, что такого? при том что я не спрашивал пока что как, а спросил стоит в эту сторону копать, или нет, да и по идее все в рамках приличия.

Да ни в какую.

На ADSL выше 2 Мбит/с рассчитывать не стоит.

Чего???! :)))

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this