Jump to content
Калькуляторы

MikroTik+Q-in-Q+D-Link

Всем привет! Сломал уже всю голову... прошу совета

 

Имеем:

MikroTik и два D-Link DES-1228/ME/B1

 

На Mikrotik создаю:

Vlan1 (VID10)

Vlan2 (VID20) (на этот влан вешаю сетку 192.168.5.1/24)

 

На первом делинке включаю qinq, 1 порт UNI, 2 порт NNI, Outer TPID 0x8100. На этом же делинке создаю VLAN 10 и в него тегирую порты 1 и 2.

 

Второй делинк:

соединяю оба делинка в первые порты. Создаю VLAN 20, 1 порт Tagged, 2 порт Untagged. Во второй порт подключаю ноутбук с ИП 192.168.5.5.

 

 

 

В итоге ни по маку ни как не вижу нойтбук и соответственно с ноутбука не вижу микротик.

 

Подскажите как будет правильнее. Или что я делаю не так.

Спасибо!

Share this post


Link to post
Share on other sites

http://www.dlink.ru/ru/faq/62/237.html читать до просветления. (Часть про pvid & missdrop например)

Не чего нового не нашел, пересматривал данную статью и раньше. единственное что нет у меня missdrop в прошивке.

 

В мануале от 1228/МЕ вообще про q-in-q ничего не написано, он это точно умеет?

Раньше стояла прошивка DES1228_Run_2_50_B004, обновил на прошивку DES1228_Run_2_60_B003 не помогло.

Я так понимаю если в вебинтерфейсе есть раздел QinQ то он должен ведь работать по идее.

Share this post


Link to post
Share on other sites

На микротике при создания влана можно поставить галочку, попробуйте с ней и без нее.

Share this post


Link to post
Share on other sites

Всем спасибо, заменил первый d-Link на DGS-3120-24SC и все завелось! 1228/МЕ не умеет добавлять/снимать сразу два тега.

Share this post


Link to post
Share on other sites

Всем спасибо, заменил первый d-Link на DGS-3120-24SC и все завелось! 1228/МЕ не умеет добавлять/снимать сразу два тега.

 

Схема была такая:

 

Микротик -> Dlink 1228ME -> Dlink 1228ME -> ноутбук

 

Но какой влан нужно прокинуть через QinQ из описания не понятно.

 

Предположим, что Vlan 10 внутри которого влан 20.

 

На микротике создаём вланы

 

/interface vlan
add interface=LAN name=vlan10 vlan-id=10
add interface=vlan10 name=vlan20 vlan-id=20

 

На длинке создаём вланы

 

create vlan v10 tag 10
config vlan v10 add tagged 2
config vlan v10 add untagged 1

config gvrp 1 pvid 10

enable qinq

config qinq ports all 0x8100
config qinq ports 1 role uni
config qinq ports 2 role nni

 

на втором длинке

 

create vlan v20 tag 20
config vlan v20 add tagged 1
config vlan v20 add untagged 2

Edited by AKim

Share this post


Link to post
Share on other sites

На длинке создаём вланы

 

create vlan v10 tag 10

config vlan v10 add tagged 2

config vlan v10 add untagged 1

 

config gvrp 1 pvid 10

 

enable qinq

 

config qinq ports all 0x8100

config qinq ports 2 role uni

config qinq ports 1 role nni

 

Спасибо попробую еще раз на Dlink 1228ME. А У Вас получилось?

 

Еще вопрос, не ошибка ли тут:

create vlan v10 tag 10

config vlan v10 add tagged 2

config vlan v10 add untagged 1

точно 1 порт untagged?

Share this post


Link to post
Share on other sites

точно 1 порт untagged?

 

точно

 

и не забыть

config gvrp 1 pvid 10

 

 

А У Вас получилось?

 

 

получилось. QinQ на длинке изучил подробно.

 

Единственно, что 1228ME мне не подошёл, так как не умеет vlan translation port based. Хотя это коммутатор доступа, от него и не требуется.

 

А так я использую QinQ + vlan per user

Share this post


Link to post
Share on other sites

AKim, Спасибо, завтра буду пробовать! Потом отпишусь получилось ли у меня при такой схеме.

Share this post


Link to post
Share on other sites

AKim, Спасибо, завтра буду пробовать! Потом отпишусь получилось ли у меня при такой схеме.

 

ошибка была в конфиге. Порты чуть спутал. Так что пробуйте по конфигу из моего первого сообщения. Я поправил

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this