Jump to content
Калькуляторы

Beeline раздача по DHCP Выдает статику к неиспользуемой подсети

Здравствуйте, если на mikrotik по DHCP получать default-gateway, то в таблице маршрутизации появляется 2 маршрута:

 

> /ip dhcp-client export
# apr/01/2014 15:14:43 by RouterOS 5.24
#
/ip dhcp-client
add add-default-route=yes default-route-distance=254 

> /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
3  DS  10.0.0.0/8                         10.46.16.1              254
10 ADS  78.107.196.0/22                    10.46.16.1              254

 

При этом DNS и L2TP сервера находятся в подсетях

 

77.106.201.0/24
77.106.202.0/24

 

И приходится смотреть default от DHCP и прописывать статику:

 

> /ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
8 A S  77.106.201.0/24                    10.46.16.1                1
9 A S  77.106.202.0/24                    10.46.16.1                1

 

Трасса:

 

> tool traceroute 78.107.196.2 use-dns=yes
# ADDRESS                                 RT1   RT2   RT3   STATUS
1 10.46.16.1                              11ms  2ms   2ms
2 10.10.10.1                              3ms   1ms   2ms
3 10.10.50.161                            4ms   1ms   3ms
4 10.10.50.105                            1ms   1ms   1ms
5 10.10.50.85                             11ms  7ms   4ms
6 10.10.8.49                              1ms   1ms   1ms
7 10.10.8.102                             1ms   5ms   3ms
8 172.21.16.121                           3ms   2ms   6ms
9 msu-bb-te3-5q2605.corbina.net           25ms  25ms  28ms
10 ko-crs-tengige0-5-0-0.corbina.net       28ms  25ms  29ms
11 lesnor-bb-be1.corbina.net               26ms  26ms  27ms
12 dolg-asr.corbina.net                    32ms  27ms  27ms
13 8m-iptv-bb-vl22.corbina.net             29ms  27ms  29ms
14 0.0.0.0                                 0ms   0ms   0ms

 

Кто знает в чем смысл выдачи 78.107.196.0/22?

 

ЗЫ: Подсети даже не в одной AS. Шаблоны рулят?

Share this post


Link to post
Share on other sites

Печально то, что при описании данной проблемы на их почту поддержки, идет ответ: "mikrotik не из списка рекомендуемого оборудования .." и всё, е***сь как хотите.

Share this post


Link to post
Share on other sites

Печально то, что при описании данной проблемы на их почту поддержки, идет ответ: "mikrotik не из списка рекомендуемого оборудования .." и всё, е***сь как хотите.

 

Есть подозрение, что маршруты передаются опцией 249, которую microtic может и не понимать. По хорошему на дамп нужно смотреть...

Share this post


Link to post
Share on other sites
[admin@MikroTik] > ip dhcp-client export
# jan/02/1970 00:35:56 by RouterOS 6.22
#
/ip dhcp-client option
add code=55 name=parameter_request_list value=0xF9
/ip dhcp-client
add dhcp-options=parameter_request_list,hostname,clientid disabled=no interface=ether1-gateway

[admin@MikroTik] > ip route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
#      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
0 ADS  10.0.0.0/8                         10.10.224.1               1
1 ADC  10.10.224.0/24     10.10.224.193   ether1-gateway            0
...
8 ADS  192.168.0.0/16                     10.10.224.1               1
...

Share this post


Link to post
Share on other sites

Не помню как раньше, но с каких-то пор в мирротике для опции add-default-route появился параметр "add-default-route" помимо "yes" и "no".

Это, вроде, как раз позволяет понять опцию 249.

Share this post


Link to post
Share on other sites

Не помню как раньше, но с каких-то пор в мирротике для опции add-default-route появился параметр "add-default-route" помимо "yes" и "no".

Это, вроде, как раз позволяет понять опцию 249.

 

add-default-route (yes | no | special-classless; Default: yes)

 

Ни "Yes" ни "special-classless" не давали результата.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this